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Введ ени е  

Настоящее учебное пособие подготовлено на основе многолетнего опы-
та преподавания курса «Информационные технологии управления проектами» 
на магистратуре экономического факультета МГУ и на семинарах по управле-
нию проектами, проводившихся в рамках международной программы Институ-
та экономического развития Мирового банка «Анализ проектов: подготовка 
преподавателей». 

Цель пособия — познакомить студентов с современными информацион-
ными технологиями управления проектами, привить навыки эффективного ис-
пользования соответствующего математического обеспечения, дать представ-
ление о трудностях и проблемах, с которыми встречается менеджер проекта, и о 
путях их преодоления. 

Существующие многочисленные издания на эту тему, как правило, яв-
ляются либо теоретическими учебниками, либо руководствами по использова-
нию программных средств, ориентированными на менеджера, имеющего необ-
ходимую практическую подготовку. Особенность данного пособия состоит в 
том, что оно содержит краткий обзор наиболее важных элементов информаци-
онной технологии, ориентированных на решение конкретных задач, состав-
ляющих содержание профессиональной деятельности менеджера проектов. 
Практика показывает, что такой обзор достаточен для последующего самостоя-
тельного углублённого изучения технологии управления проектами с помощью 
литературы, описывающей её инструментальный аспект. 

Пособие адресовано в первую очередь студентам магистратуры по эко-
номическим направлениям, изучающим курс по выбору «Управление проекта-
ми» или близкие к нему по содержанию курсы объёмом 24-48 академических 
часов аудиторных занятий. При отсутствии в учебном плане курсов, посвящён-
ных вопросам управления проектами, оно может быть использовано при прове-
дении компьютерного практикума по менеджменту объёмом до 32 часов либо 
практических занятий по соответствующей теме курса «Информационные тех-
нологии в экономике» объёмом 4-8 часов. Рекомендуется пособие также аспи-
рантам, ведущим исследования по специальности 08.00.05 «Экономика и 
управление народным хозяйством» (специализация «управление инновациями и 
инвестиционной деятельностью») и начинающим менеджерам-практикам. Оно 
окажется полезным системным администраторам и программистам, работаю-
щим в организациях, деятельность которых связана с управлением проектами: 
сотрудники таких организаций часто обращаются к специалистам этого профи-
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ля за консультациями по использованию инструментальных средств управления 
проектами. 

Эффективное использование учебного пособия требует соблюдения ряда 
условий. Читатель должен иметь представление о методе динамического про-
граммирования, владеть основными понятиями анализа инвестиционных про-
ектов (цикл проекта, критерии оценки проекта) и автоматизированных инфор-
мационных технологий, а также основами теории управления. Отсюда соответ-
ствующие требования к размещению курса, в рамках которого используется по-
собие, в учебном плане вуза. Если они по каким-либо причинам не могут быть 
выполнены, преподавателю следует дополнить настоящее пособие необходи-
мым лекционным материалом и рекомендовать соответствующую литературу.  

Пособие состоит из теоретической части и лабораторного практикума. 
Для удобства читателя оно снабжено предметным указателем, облегчающим 
овладение новой терминологией. 

Выполнение практического задания при очной и очно-заочной формах 
обучения требует наличия компьютерного класса на 8-15 рабочих мест, осна-
щённого персональными ЭВМ, работающими под управлением Windows XP 
или Windows 2003 с установленной на них программой Microsoft Project 2003. 
Желательны наличие локальной вычислительной сети (ЛВС) и возможность со-
вместного доступа к файлам. Предлагаемые в пособии лабораторные работы, за 
исключением последней, могут быть выполнены и в отсутствие ЛВС, но с 
меньшей эффективностью. 

Прежде чем приступить к выполнению практического задания в компь-
ютерном классе, студент обязан изучить теоретический материал и содержание 
практического задания, обратиться к преподавателю с возникшими вопросами. 
Преподаватель, со своей стороны, не должен допускать к выполнению практи-
ческого задания студентов, не подготовившихся к занятию надлежащим обра-
зом, чтобы предотвратить нерациональное использование учебного времени и 
предупредить возникновение нештатных ситуаций. 

Лабораторная работа №5 не включается в курс объёмом 24 ч. Она может 
быть исключена также из более продолжительных курсов, если преподаватель 
придаёт большее значение семинарским занятиям с тем, чтобы обеспечить 
твёрдые теоретические знания и глубокое понимание организационно-
экономического аспекта применения современных методик управления проек-
тами. В расширенном виде эта работа может стать основой для организации 
учебной практики или компьютерного практикума по менеджменту. 

В данном учебном пособии лабораторный практикум и изложение тео-
ретического материала по работе с программным обеспечением ориентированы 
на англоязычную версию программы Microsoft Project 2003 Professional. Выбор 
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для изучения англоязычной версии обусловлен тем, что на практике она полу-
чила более широкое распространение, чем локализованная. Если практикум ор-
ганизован на базе другого программного обеспечения, преподавателю необхо-
димо сопроводить данное пособие соответствующими инструктивными мате-
риалами или методическими указаниями. 

Авторы благодарят сотрудников Института экономического развития 
Мирового банка П. Кэнон-Оливарес, Д. Фичета, И. Зимина, заведующего ка-
федрой информационно-консультационных технологий Российского государ-
ственного аграрного университета – МСХА имени К.А. Тимирязева 
Д. Алексанова за ценные советы и за экспертизу лабораторного практикума. 
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Теор е тич е ская  ча с ть  

1. Сущность и содержание управления проектами 
Цель и критерии управления проектом. Факторы управления проектом. Ответствен-

ность менеджера проекта. Этапы управления проектом. 

Управление проектами можно определить как вид управленческой дея-
тельности, состоящий в организационном обеспечении выполнения проектов 
при условии соблюдения заданных смет и сроков. 

В теории управления проектами используются следующие понятия. 
♦ Проект — последовательность работ, реализующая заданную цель в 

установленные сроки и в рамках заданной сметы. 
Проекты могут различаться масштабами, представление о которых даёт 

размер инвестиционных затрат, и сроками выполнения (как правило, от не-
скольких дней до нескольких десятилетий). 

♦ Работа — технологическая операция, мероприятие, вид деятельности 
или их совокупность, характеризующиеся затратами времени на выполнение, 
потребностью в ресурсах и условиями, при которых они могут выполняться. 
Примеры работ: междурядная обработка посевов; протравливание семян; мон-
таж подъёмного крана; уборка снега со строительной площадки; заключение 
контракта; оформление документов на право собственности на объект недви-
жимости; командировка в проектный институт. 

Работы, выполняемые одновременно, называют параллельными. 
♦ Ресурсы — работники, специалисты, машины и оборудование, мате-

риалы, необходимые для выполнения конкретной работы и подконтрольные 
менеджеру проекта. 

Ресурсы бывают нескладируемые и складируемые. 
Нескладируемые ресурсы — ресурсы, высвобождаемые по завершении 

работы и годные для последующего использования на других работах. Приме-
ры: работники и специалисты всех специальностей; трактор; электродрель; пор-
тативный компьютер; мобильный телефон; термостат. 

Имеющееся в распоряжении менеджера проекта количество несклади-
руемого ресурса ограничивает возможность одновременного (параллельного) 
выполнения работ, на которых используется данный ресурс. 

Складируемые ресурсы (иначе материалы) — ресурсы, полностью рас-
ходуемые при выполнении конкретной работы (поступающие со склада). При-
меры: пиломатериалы; асфальт; удобрения; топливо; электролампочки; семена. 
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Несвоевременная поставка складируемого ресурса может задержать вы-
полнение сразу всех работ, во время которых он расходуется. На возможности 
параллельного выполнения работ наличие складируемого ресурса не влияет. 

♦ Смета проекта — документ, содержащий оценку затрат (по видам), 
необходимых для сдачи проекта в эксплуатацию. 

♦ Сетевой план — документ, устанавливающий сроки выполнения всех 
работ, необходимых для сдачи проекта в эксплуатацию. 

♦ Финансовый план — документ, устанавливающий сроки поступления 
финансовых ресурсов и их расходования на финансирование затрат, преду-
смотренных сметой проекта. 

Цель управления проектом состоит в рациональном распределении 
имеющихся ресурсов для выполнения всех предусмотренных конкретным про-
ектом работ (задач, технологических операций) в заданные сроки и без сверх-
нормативных затрат. 

Качество управления проектом оценивается по следующим критериям , 
расположенным в порядке убывания значимости: 

♦ чистая текущая стоимость проекта; 
♦ срок сдачи проекта в эксплуатацию; 
♦ затраты на реализацию проекта; 
♦ своевременность финансирования и поставок; 
♦ равномерность загрузки ресурсов; 
♦ соблюдение запланированных сроков выполнения работ; 
♦ отношения в трудовом коллективе, 
♦ взаимоотношения с подрядчиками, инвесторами и другими партнёра-

ми. 
Критерий чистой текущей стоимости проекта — определяющий, все ос-

тальные являются его следствиями. Однако влияние конкретных решений ме-
неджера на чистую текущую стоимость установить очень сложно. 

Зато не составляет труда оценить их влияние на срок сдачи проекта в 
эксплуатацию. Практика показывает, что при условии соблюдения сметы про-
екта его чистая текущая стоимость оказывается тем выше, чем раньше заверше-
на инвестиционная фаза и началась эксплуатация проекта. 

В этом случае выгоды начинают поступать раньше и оказываются, с 
учётом дисконтирования, более ценными. Кроме того, сокращаются процент-
ные платежи, поскольку кредиты выплачиваются в более ранние сроки. Суще-
ственное значение имеет также фактор опережения конкурентов в предоставле-
нии потребителям продукции или услуг, ради которых предпринят проект. 
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Вот почему на практике главным признаётся критерий минимизации 
продолжительности инвестиционной фазы, что означает возможно скорейшее 
начало эксплуатации. 

Управляя проектом, менеджер должен принимать во внимание много-
численные разнородные факторы , например: 

♦ технологическую последовательность работ; 
♦ обеспеченность работ материальными и трудовыми ресурсами; 
♦ возможность привлечения дополнительных ресурсов; 
♦ режим работы руководителей, специалистов, рабочих и служащих; 
♦ возможность сверхурочной работы и сопряжённые с ней затраты; 
♦ своевременность финансирования; 
♦ согласованность во времени присутствия на рабочих местах специа-

листов, наличия необходимого оборудования и техники; 
♦ своевременность доставки материалов; 
♦ риски и неопределённости; 
♦ потери, возникающие в случае отставания реализации проекта от гра-

фика; 
♦ человеческий фактор: отношения в трудовом коллективе, деловые ка-

чества  руководителей и специалистов различного профиля, их мнения по во-
просам выполнения проекта. 

В условиях жёсткой конкурентной борьбы реализация сложных проек-
тов в кратчайшие сроки является необходимым условием их успеха. Отсюда 
высокие требования руководителей бизнеса к квалификации менеджеров про-
ектов, необходимость овладения современными информационными техноло-
гиями, позволяющими оперировать полной информацией по всем вышепере-
численным позициям. 

Без компьютерной поддержки менеджер, управляя проектом, может на-
деяться лишь на интуицию и на благоприятное стечение обстоятельств. Такой 
подход может оправдать себя, если проект предусматривает выполнение десят-
ков работ. Если же речь идёт о десятках тысяч, провалы неизбежны даже в дея-
тельности самых талантливых менеджеров, Ценой провалов могут стать вре-
менная неплатёжеспособность, ухудшение деловой репутации, а иногда и бан-
кротство фирмы. 

Менеджер проекта несёт ответственность за скорейшую сдачу проек-
та в эксплуатацию, за соблюдение сметы проекта, за качество составления, за 
выполнение сетевого плана и плана финансирования, за рациональную загрузку 
используемых ресурсов, за своевременность и точность информации, предос-
тавляемой всем участникам процесса реализации проекта. 
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Процесс управления проектом по своему содержанию подразделяется на 
три этапа: 

♦ планирование; 
♦ мониторинг; 
♦ анализ. 
На этапе планирования определяется смета проекта, составляется сете-

вой план, а на его основе формируется финансовый план и планируется дата 
сдачи проекта в эксплуатацию. В компетенцию менеджера проекта на этом эта-
пе входит составление сетевого плана. Смета, сетевой план и план финансиро-
вания утверждаются руководителем проекта. Если наложить процесс управле-
ния проектом на цикл проекта, то этап планирования войдёт в фазу разработки 
проекта. 

Инвестиционная фаза проектного цикла, иначе называемая фазой 
реализации проекта, совпадает с этапом процесса управления проекта, назы-
ваемым мониторингом. Это наиболее напряжённый этап деятельности менед-
жера. В этот период он должен обеспечить соблюдение сетевого плана и плана 
финансирования в условиях неопределённости и быстро меняющихся внешних 
условий, а при необходимости существенного отклонения от них — своевре-
менно представить информацию об этом руководству проекта, предложить и 
аргументировать конкретные решения, подготовить проекты соответствующих 
документов и соглашений. 

Этап анализа, согласно циклу проекта, относится к фазе эксплуатации 
проекта. На этом этапе менеджер подводит итоги выполнения проекта, выявля-
ет резервы сокращения продолжительности работ и размеров затрат, изучает 
допущенные ошибки и просчёты и предлагает мероприятия, позволяющие из-
бежать их в будущем, готовит соответствующие предложения руководству сво-
ей компании и её партнёрам. 

Контрольные вопросы 

1. Что понимается под управлением проектами? 
2. Что из нижеперечисленного не является работой: пахота; навеска плуга; ис-

пользование трактора для пахоты; оплата труда механизатора? 
3. Что из приведённого списка не является ресурсом: зерносушилка; бухгал-

тер; менеджер проекта; монтаж подъёмного крана; линия электропередач. 
Ответ поясните. 

4. Чем складируемые ресурсы отличаются от нескладируемых? 
5. В чём различие между сметой проекта и его финансовым планом? 
6. Что такое сетевой план? 
7. В чём состоит цель управления проектами? 
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8. Каков главный критерий управления проектами? Почему? 
9. Чем обусловлена сложность управления проектами? 
10. Что составляет сферу ответственности менеджера проекта? 
11. Какой этап процесса управления проектами наиболее ответственный? Пояс-

ните, почему вы так считаете. 
12. Назовите причины распространения информационных технологий в управ-

лении проектами. 

2. Технология PERT 
Динамическое программирование — формализм для представления модели проекта. 

Метод критического пути в планировании. Содержание технологии PERT. Функциональные 
и обеспечивающие подсистемы технологии PERT. 

Для эффективного управления проектом необходимо иметь его модель. 
Элементами модели являются работы, которые необходимо выполнить в тече-
ние инвестиционной фазы проекта, и ресурсы, которые требуются для выпол-
нения работ. 

Модель проекта должна быть достаточно простой, чтобы затраты на её 
разработку и эксплуатацию (в том числе затраты времени) были несущественны 
в сравнении со сметной стоимостью проекта и заведомо себя оправдывали в 
процессе управления, и в то же время достаточно мощной, чтобы учесть все или 
большинство факторов управления проектом. 

Выполнимость этого требования обеспечивается выбором подходящего 
формализма для реализации модели. Если принять в качестве критерия управ-
ления проектом скорейший срок сдачи его в эксплуатацию — как отмечалось в 
предыдущем разделе, для этого имеются достаточные практические основа-
ния, — то таким формализмом оказывается динамическое программирование. 
Этот формализм в приложении к задачам управления проектами не свободен от 
недостатков. Наиболее существенные из них мы обсудим, рассматривая кон-
кретные технологические решения, основанные на его использовании. 

Динамическое программирование основывается на методе критического 
пути (critical path metod, CPM). Напомним, в основе метода лежит принцип оп-
тимальности, сформулированный Р. Беллманом. Он состоит в том, что любая 
часть оптимального (критического) пути между двумя вершинами графа сама 
является оптимальным путём между соответствующими вершинами. Благодаря 
этому свойству существует эффективная вычислительная процедура, которая 
позволяет определить критический путь к каждой следующей вершине как про-
должение критического пути к одной из предыдущих вершин графа. 
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Чтобы представить модель проекта в форме задачи динамического про-
граммирования, работы ставят в соответствие рёбрам графа, а события, соот-
ветствующие завершению определённых работ или их групп, — его вершинам. 
Модель позволяет определить минимально возможный срок выполнения проек-
та при заданных сроках выполнения работ и, найдя критический путь, указать 
подмножество критических работ, даже самая малая задержка которых непре-
менно приведёт к отсрочке завершения проекта. Благодаря этому менеджер 
проекта может сосредоточить своё внимание на критических работах (то есть 
на работах, образующих критический путь), предупреждая перебои и концен-
трируя ресурсы на наиболее ответственных участках. 

Для работ, не принадлежащих критическому пути (некритических), су-
ществует резерв времени: если их задержать на срок, не превышающий этого 
резерва, то продолжительность выполнения проекта не изменится. Если же за-
держка превысит резерв, то изменится критический путь: задержавшаяся работа 
станет критической. Срок выполнения проекта в этом случае увеличится. Мо-
дель, основанная на методе критического пути, позволяет рассчитать резерв 
времени по всем работам. 

До появления персональных ЭВМ модель проекта использовалась толь-
ко для составления оптимального сетевого плана, который принимался менед-
жером к исполнению и впоследствии не пересматривался. Задержки критиче-
ских работ, таким образом, приводили к срыву плана, а у менеджеров появля-
лись мотивы к компенсации отставания за счёт нарушения технологий. Если в 
результате задержек изменялся критический путь, менеджер оказывался дез-
ориентирован, а имеющийся сетевой план становился бесполезным. Модель 
проекта, систематически корректируемая на отклонения от первоначального 
плана, могла бы помочь менеджеру отыскать наилучшую последовательность 
действий в случае нарушения первоначально составленного плана. Но из-за ог-
раниченной доступности ЭВМ и необходимости посредничества оператора ме-
жду менеджером и вычислительной системой такой подход был слишком доро-
гостоящим и себя не оправдывал. 

Появление персональных и особенно переносных ЭВМ достаточной 
мощности, оснащённых специализированным программным обеспечением с 
понятным менеджеру интерфейсом сделало возможным использование воз-
можностей метода критического пути в любой момент фазы реализации проек-
та. Возникла принципиально новая технология управленческой деятельности — 
технология оценки и уточнения проекта (Project (или Program) Evaluation and 
Review Technique, PERT). 

Технология PERT входит в класс автоматизированных информационных 
технологий, отличающихся той особенностью, что предметом труда при их ис-
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пользовании является информация, а средством труда — вычислительная тех-
ника. Продуктом технологии PERT являются подготовленные управленческие 
решения о сроках выполнения работ и о рациональном использовании ресурсов 
для их выполнения, обеспечивающие завершение проекта в кратчайшие сроки 
ценой приемлемых затрат. 

Суть технологии в том, что модель проекта, составленная на фазе его 
разработки и ставшая основой первоначального варианта сетевого плана, ис-
пользуется с необходимыми уточнениями на фазе реализации проекта для ин-
формационной поддержки оперативного принятия решений по управлению 
проектом в реально сложившейся ситуации. Она предполагает определение 
критического пути в любой момент времени, когда эта информация требуется 
менеджеру, на основе информации о фактическом ходе выполнения работ и о 
фактическом наличии ресурсов. 

Функциональные подсистемы технологии PERT включают, как правило, 
следующие подсистемы: 

♦ планирования — предназначена для составления плана выполнения 
проекта; 

♦ мониторинга — предназначена для контроля выполнения плана и его 
систематического уточнения в случае отклонений; 

♦ подготовки презентаций — предназначена для компактного и ёмкого 
представления информации о модели проекта, составленном плане и ходе его 
выполнения. 

К числу обеспечивающих подсистем относятся следующие: 
♦ аппаратное обеспечение — совокупность технических средств реали-

зации технологии PERT, включая, в частности, компьютеры и коммуникацион-
ные средства; 

♦ математическое (алгоритмическое) обеспечение — алгоритмы дина-
мического программирования, расширенные сервисными средствами, решаю-
щими прикладные вычислительные задачи, возникающие в практике управле-
ния проектами, алгоритмы управления базами данных и алгоритмы отображе-
ния данных; 

♦ программное обеспечение — совокупность программных продуктов, 
обеспечивающих реализацию процесса обработки данных на компьютере; 

♦ материальное обеспечение — организационная система обеспечения 
расходными материалами и запасными частями; 

♦ кадровое обеспечение — специалисты, владеющие технологией в це-
лом и отдельными её элементами; 
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♦ нормативно-правовое обеспечение — совокупность документов, рег-
ламентирующих использование технологии в конкретных условиях, права, обя-
занности и ответственность всех участников технологического процесса; 

♦ инструктивно-методическое обеспечение — совокупность докумен-
тов, описывающих операции по реализации технологического процесса обра-
ботки данных, выполняемые каждым его участником. 

Иногда выделяют и другие виды обеспечивающих подсистем. 
В отличие от метода критического пути, технология PERT принимает во 

внимание распорядок рабочего времени и ограничения по ресурсам. 
Учёт календаря и распорядка рабочего дня вполне согласуется с мето-

дом критического пути. Иначе обстоит дело с учётом ресурсных ограничений: к 
этому случаю принцип оптимальности, сформулированный Р. Беллманом, не 
может быть применён. Эффективная вычислительная процедура нахождения 
оптимального плана для такой постановки задачи неизвестна (кроме частных 
случаев, не представляющих практического интереса для менеджера). Однако 
представление проекта в форме задачи динамического программирования ока-
зывается полезным и здесь: в своей практической деятельности менеджер быва-
ет вполне удовлетворён пусть не оптимальным, но удовлетворительным пла-
ном, обеспечивающим согласованное использование ресурсов. 

Для его отыскания сначала определяют критический путь без учёта ог-
раничений по ресурсам, затем определяют периоды, когда ресурсов недоста-
точно, и переносят работы, испытывающие дефицит ресурсов (по возможно-
сти — некритические, а вслед за ними — те, перенос которых в наименьшей 
степени скажется на общей продолжительности проекта), на более поздние сро-
ки. Как правило, существует множество вариантов переноса работ, но во избе-
жание резкого возрастания продолжительности вычислений перебор ограничи-
вают. 

Альтернативный подход — сокращение выделения ресурсов конкури-
рующим работам с соответствующим увеличением продолжительности послед-
них. Во многих случаях он позволяет добиться лучших результатов по сравне-
нию с переносом работ на более поздние сроки, но наименьшая теоретически 
возможная продолжительность фазы реализации проекта, как правило, всё рав-
но не достигается. Кроме того, данный подход практически неосуществим по 
отношению к работам, использующим ресурсы в единичном количестве, по-
этому далеко не всегда плодотворен. 

Развитие технологии PERT под влиянием требований менеджеров-
практиков привело к тому, что в её состав, наряду с вопросами управления сро-
ками работ и распределением ресурсов, были включены: 
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♦ технологические решения по управлению финансированием проекта, 
включая средства составления финансового плана и мониторинга его выполне-
ния; 

♦ средства координации деятельности менеджеров, совместно управ-
ляющих сложным проектом или несколькими проектами, выполняемыми одно-
временно. 

Модель проекта, дополненная стоимостными данными, содержит ин-
формацию, необходимую для решения этих задач. 

Контрольные вопросы 

1. Зачем менеджеру нужна модель проекта? 
2. Обоснуйте применение формализма динамического программирования для 

представления модели проекта. 
3. Как представить инвестиционный проект в форме задачи динамического 

программирования? 
4. В чём состоит метод критического пути? 
5. Какие трудности возникали при применении метода критического пути для 

разработки сетевых планов до появления персональных ЭВМ? 
6. Каковы отличия технологии PERT от метода CPM? 
7. Каковы функциональные подсистемы технологии PERT? Дайте им краткую 

характеристику. 
8. Перечислите обеспечивающие подсистемы технологии PERT. 
9. Почему технология PERT не предусматривает отыскание оптимального се-

тевого плана? 
10. Какими способами обеспечивается согласование использования ресурсов на 

различных работах? 
11. В какой последовательности рекомендуется переносить на более поздние 

сроки работы, не обеспеченные ресурсами? 
12. Какими данными следует дополнить модель проекта для составления на её 

основе финансового плана? 

3. Программное обеспечение управления проектами 
Программы, реализующие технологию PERT: сравнительная характеристика. Сред-

ства сетевого планирования в Project Expert. Другие программные продукты для сетевого 
планирования. 

Существует немало программных реализаций технологии PERT для пер-
сональных ЭВМ. Наиболее известные и широко используемые из них — Micro-
soft Project, OpenPlan, Spider Project. Модели проекта, используемые в них, ос-
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нованы на методе критического пути и отличаются лишь в деталях. Как прави-
ло, овладев одной из программ, реализующих технологию PERT, не составляет 
труда воспользоваться любой другой. 

Все эти программы предназначены для автоматизации управления инве-
стиционными проектами. Они обеспечивают разработку детальных сетевых 
планов, отслеживание (мониторинг) хода выполнения сетевого плана и его опе-
ративную корректировку применительно к меняющимся условиям. 

Большая часть работы по управлению проектом – это сбор и анализ ин-
формации о нём. Вышеназванные программные продукты обеспечивают доста-
точно удобные средства ввода, структурирования и анализа информации, авто-
матизации плановых расчётов и подготовки отчётов. Они обладают следующи-
ми возможностями: 

♦ реализуют метод критического пути с учётом ресурсов, необходимых 
для выполнения предусмотренных проектом работ, и распорядка рабочего вре-
мени;  

♦ обеспечивают согласование использования ресурсов, перенося часть 
работ на более поздние сроки, если некоторые ресурсы в дефиците; 

♦ допускают вмешательство менеджера в процесс согласования исполь-
зования ресурсов, предоставляя ему возможность произвольного сочетания 
приёмов согласования, описанных в предыдущем разделе. 

Программа Microsoft Project интегрирована в Microsoft Office, что уп-
рощает её взаимодействие с базами данных, электронными таблицами, подго-
товку текстовых документов на основе создаваемых ею выходных документов 
и, при необходимости, публикацию их на сайтах корпоративных сетей или сети 
Интернет. Набор предлагаемых ею возможностей не столь широк, как в наибо-
лее мощных программах аналогичного назначения, что вполне компенсируется: 

♦ возможностью выполнения многих операций другими программами, 
входящими в состав семейства Microsoft Office; 

♦ поддержкой универсального языка программирования VBA, общего 
для всех программных средств семейства, который даёт возможность использо-
вать средства различных программ из одного и того же VBA-модуля; 

♦ доступностью для освоения в приемлемый срок менеджером средней 
квалификации; 

♦ развитыми средствами поддержки коллективного управления проек-
тами; 

♦ мощными и разнообразными (во многом, на наш взгляд, избыточны-
ми, неоправданно увеличивающими сложность программы) возможностями 
управления интерфейсом пользователя; 

♦ умеренной ценой; 
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♦ наличием службы обучения и поддержки. 
По этим причинам Microsoft Project стала наиболее распространённой из 

числа программ, предназначенных для управления проектами. 
OpenPlan компании Welcome Corp. превосходит Microsoft Project в сте-

пени автоматизации управления ресурсами и в средствах анализа рисков. 
В отличие от Microsoft Project, данная программа располагает возможно-

стями: 
♦ учёта «квалификации» или «качества» ресурсов, что позволяет про-

грамме при необходимости предлагать замену менее «квалифицированных» 
или «качественных» ресурсов более ценными, но имеющимися в избытке в 
данный момент; 

♦ оптимизации загрузки ресурсов (сокращения простоев); 
♦ назначения ресурса не на всю работу, а только на её часть. 
Анализ рисков выполняется методом Монте-Карло: указанные пользова-

телем параметры проекта изменяются случайным образом в указанных грани-
цах, после чего производится статистическая обработка совокупности значений 
выходных переменных модели проекта, по результатам которой можно судить 
о степени его устойчивости к случайным воздействиям. При необходимости 
менеджер, основываясь на результатах анализа, может пересмотреть последова-
тельность или содержание работ, зарезервировать дополнительные ресурсы или 
предусмотреть запас времени на критические работы, чтобы гарантировать вы-
полнимость проекта в приемлемые сроки даже при неблагоприятных обстоя-
тельствах. 

Spider Project — отечественная разработка, ориентированная преиму-
щественно на российского пользователя. Обладая мощными средствами авто-
матизации управления ресурсами и богатыми сервисными возможностями, она 
отличается от вышеназванных учётом российских стандартов и практики сете-
вого планирования. 

Нижеследующие программы используют метод критического пути и мо-
гут быть использованы на отдельных этапах процесса управления проектами. 

Программа 1С–Рарус фактически представляет собой субмодуль к мо-
дулю бухгалтерского учёта программы 1С–Предприятие — популярного в Рос-
сии средства комплексной автоматизации документооборота на фирме среднего 
масштаба. Она ориентирована не столько на управление проектами как таковы-
ми, сколько на управление ресурсами предприятия, распределяемыми между 
различными задачами офисной и производственной деятельности. Тем не ме-
нее, она содержит необходимые средства для представления модели проекта и 
мониторинга процесса его выполнения. 
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Глубокая интеграция в систему внутрифирменного документооборота 
делает программу 1С–Рарус хорошим выбором для организации, основным ис-
точником дохода которой являются торговая, финансовая деятельность или 
продажа услуг, а реализуемые ею проекты преследуют преимущественно внут-
рифирменные цели. 

Пользующаяся широкой известностью программа Project Expert фир-
мы Про-Инвест-ИТ, реализующая автоматизированную технологию разработки 
бизнес-плана в соответствии с российскими стандартами и требованиями рос-
сийских банков, содержит блок составления сетевого плана, основанный на ме-
тоде CPM. Программа ориентирована на специалистов по бизнес-
планированию и анализу проектов, поэтому не предусматривает развитых 
средств мониторинга. Однако составленная при её помощи модель проекта мо-
жет быть экспортирована в специализированные программы для управления 
проектом, используемые менеджерами. 

Информацию об этих и других программах, используемых менеджерами 
проектов, можно получить на сайте Российской ассоциации управления проек-
тами (http://www.sovnet.ru). 

Перечисленные программы, реализующие составление сетевого плана и 
мониторинг проекта, составляют ядро математического обеспечения техноло-
гии PERT. Однако ни одна из них не может учесть в полном объёме задачи, 
возникающие при управлении проектами. Поэтому эффективная компьютерная 
поддержка данной технологии требует использования, при необходимости, 
программных средств управления базами данных, оптимального планирования, 
статистического анализа, организации документооборота, учёта, экономическо-
го анализа и других. 

Контрольные вопросы 

1. Назовите известные вам программы, реализующие технологию PERT. 
2. По каким причинам программа Microsoft Project завоевала лидерство на 

рынке математического обеспечения управления проектами? 
3. Каковы преимущества OpenPlan перед Microsoft Project? 
4. Какие программные средства отечественных разработчиков, реализующие 

технологию PERT, вам известны? 
5. Каковы возможности использования программы Project Expert в процессе 

управления проектом? 
6. Какая из программ наиболее подходит организациям, для которых управле-

ние проектами не является основным видом деятельности? 
7. Где в Интернете можно получить информацию о программных средствах 

для управления проектами? 
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8. По каким причинам программы, основанные на формализме динамического 
программирования, не в полной мере реализуют информационную техноло-
гию управления проектами? 

4. Данные о проекте 
Структура данных модели проекта. Общая информация по проекту. Календари. Таб-

лица работ. Таблица ресурсов. Распределительная таблица. Источники и верификация дан-
ных. 

Модель проекта, представленная в форме задачи динамического про-
граммирования, использует данные, которые можно организовать в структуру, 
состоящую, помимо общей информации о проекте и календарей, из трёх таб-
лиц: 

♦ таблицы работ; 
♦ таблицы ресурсов; 
♦ распределительной таблицы, хранящей данные о ресурсах, назначен-

ных на конкретные работы. 
 
Общая информация о проекте представлена кортежем, в котором хра-

нятся следующие данные: 
♦ наименование проекта; 
♦ дата начала проектных работ1; 
♦ имя календаря проекта (см. ниже); 
♦ данные о менеджере проекта; 
♦ данные о компании, реализующей проект; 
♦ денежная единица, используемая в модели проекта; 
♦ средняя продолжительность рабочего дня, рабочей недели (в часах), 

рабочего месяца (в днях). 
В конкретных программных реализациях общая информация о проекте 

может включать и другие данные. 
Календари хранят распорядок рабочего дня и информацию о выходных 

днях. Как правило, в календаре указываются рабочие часы для каждого дня не-
дели, а также исключения: отклонение рабочего времени от предусмотренного 
для данного дня недели, намеченное на конкретную дату. Исключения исполь-
зуют, например, для учёта праздничных и предпраздничных дней. 

                                           
1 В компьютерных реализациях допускается указание не даты начала, а даты завер-

шения проекта, если она определена заранее, а менеджер по каким-либо причинам должен 
приступить к выполнению проекта как можно позже. 
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Календарь проекта определяет рабочие дни и часы для проекта в целом. 
Если распорядок рабочего дня для отдельных ресурсов иной, для них могут 
быть указаны специальные календари ресурсов. Если работа использует ресурс, 
для которого задан календарь ресурса, то она может выполняться лишь во вре-
мя, являющееся рабочим и для проекта, и для ресурса. 

Обычно календарям присваиваются имена, которые указываются в кор-
теже общей информации о проекте (при назначении календаря проекта) или в 
таблице ресурсов (при назначении календарей ресурсов). 

Некоторые программные реализации технологии PERT допускают ука-
зание календарей индивидуально для заданных работ. Если для какой-либо ра-
боты определён календарь, то она не подчиняется календарю проекта, а выпол-
няется согласно своему собственному календарю. 

З а м е ч а н и е .  Средние продолжительности рабочего дня, неде-
ли, месяца, относящиеся к общей информации о проекте, необходимы для 
перевода единиц измерения времени, используемых менеджером при ука-
зании продолжительности работ. Эти величины, если их вычислять на ос-
нове календаря проекта, окажутся в зависимости от наличия сокращён-
ных и праздничных дней, что сделает их непригодными к использованию 
в качестве счётной единицы. Поэтому менеджер проекта сам определяет, 
сколько часов он имеет в виду под промежутком рабочего времени, рав-
ным одному дню или одной неделе. 

 
Каждая строка таблицы работ соответствует одной работе. В её столбцах 

помещаются следующие данные: 
♦ номер (числовой идентификатор) работы; 
♦ наименование работы; 
♦ предполагаемая продолжительность; 
♦ список предшествующих работ — тех, которые обязательно должны 

завершиться для того, чтобы можно было начать данную работу; 
♦ список ресурсов, необходимых для выполнения данной работы, с ука-

занием их требуемого количества1; 
♦ дата и время планируемого начала работы; 
♦ дата и время планируемого завершения работы; 
♦ дата и время фактического начала работы; 
♦ дата и время фактического завершения работы; 

                                           
1 Эти данные фактически хранятся в распределительной таблице, но для удобства 

пользователя дублируются в таблице работ в форме списка. 
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♦ запас времени по данной работе — максимальная задержка, не 
влияющая на срок выполнения проекта в целом; 

♦ ограничения на сроки выполнения работ; 
♦ процент завершённости; 
♦ примечания. 
В зависимости от программной реализации модели проекта таблица ра-

бот может содержать и другие столбцы. Некоторые из них, предусмотренные 
разработчиками программы Microsoft Project, будут рассмотрены в последую-
щих темах. 

Большинство программных реализаций таблицы работ допускают ввод 
некоторых данных (связей с другими работами, используемых ресурсов) сразу 
для целых групп работ, а также отражение иерархической структуры работ пу-
тём объединения взаимосвязанных работ в группы. 

 
Каждая строка таблицы ресурсов отражает сведения о ресурсах одного 

вида. Её столбцы содержат: 
♦ номер (числовой идентификатор) ресурса; 
♦ наименование ресурса; 
♦ тип ресурса (складируемый/нескладируемый); 
♦ способ начисления затрат, связанных с использованием данного ре-

сурса (перед началом работы; после завершения работы; пропорционально объ-
ёму выполненной работы); 

♦ примечания; 
только  для складируемых  ресурсов (материалов): 

♦ единицу измерения; 
♦ цену за единицу; 

только  для нескладируемых  ресурсов: 
♦ наименование календаря, назначенного данному ресурсу; 
♦ плату за привлечение данного ресурса (не зависящую от про-
должительности использования ресурса); 
♦ плату за единицу времени использования ресурса; 
♦ плату за сверхурочное использование ресурсов. 

Дополнительная информация, помещаемая в таблицу ресурсов, зависит 
от программной реализации модели проекта. 

 
Распределительная таблица обеспечивает связь между таблицами работ 

и ресурсов. В каждой её строке содержатся следующие данные: 
♦ количество единиц данного ресурса, назначенного на данную работу; 



21 

♦ количество ресурсо-часов использования данного ресурса на данной 
работе; 

♦ объём сверхурочного использования данного ресурса на данной рабо-
те; 

♦ затраты, связанные с использованием данного ресурса на данной ра-
боте. 

 
Источники данных, используемые при разработке модели проекта, во 

многом определяют степень её достоверности, а значит, и качество управления 
проектом на основе технологии PERT. 

Результаты моделирования проекта наиболее чувствительны к данным о 
продолжительности  работ . 

Наиболее надёжным источником сведений о продолжительности работ 
служит опыт прошлых проектов, при выполнении которых производились ана-
логичные работы. Во многих случаях о продолжительности предстоящих работ 
можно судить по опыту проектов, предусматривавших выполнение схожих ра-
бот, если ввести необходимые корректировки. При отсутствии собственного 
опыта организация может воспользоваться опытом других организаций, под-
держивающих с ней партнёрские отношения. Данный источник следует исполь-
зовать всякий раз, когда он доступен, исключая случаи, когда имеющийся опыт 
отражает выполнение работы в экстраординарных условиях. 

Если опыт прошлых проектов привлечь невозможно, продолжитель-
ность наиболее ответственных работ, которые предположительно могут ока-
заться на критическом пути, рассчитывают на основе технологических карт или 
других документов, описывающих технологию выполнения работы. Этот спо-
соб весьма трудо- и времяёмок; он не отражает фактические изменения про-
должительности работы в случаях отклонения технических условий выполне-
ния работы от нормативных; к тому же технологические карты не всегда со-
держат информацию, необходимую для однозначного установления продолжи-
тельности работы. 

Третий по надёжности способ — использование опубликованных норма-
тивов продолжительности работ либо разработка собственных внутрифирмен-
ных нормативов с привлечением методов нормирования. Реальные затраты 
времени могут, однако, существенно отличаться от норматива, установленного 
для определённых целей: например, для контроля, анализа с целью выявления 
узких мест в проектной деятельности и т.д. Но при отсутствии другой инфор-
мации нормативные данные позволяют составить представление о вероятной 
продолжительности работы. Следует также иметь в виду, что разработка внут-
рифирменных нормативов продолжительности предстоящих работ — весьма 
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дорогостоящее мероприятие, оправданное лишь для тех работ, которые имеют 
значительные шансы оказаться критическими. 

Последний способ — экспертную оценку продолжительности работ — 
следует применять тогда, когда ни один из предыдущих неприменим. Он тем 
надёжнее (и дороже), чем больше экспертов опрошено с целью установления 
продолжительности работы, но, сколько бы экспертов ни удалось опросить, 
нельзя быть уверенным, что в их представлении о продолжительности работ не 
содержится систематической ошибки, одной и той же для всех или большинст-
ва опрошенных экспертов. Этот метод чаще других становится причиной оши-
бочного определения продолжительности всего проекта. Если работа, продол-
жительность которой из-за отсутствия времени или средств на более глубокое 
изучение вопроса определена экспертом (экспертами), оказалась на критиче-
ском пути, целесообразно вернуться к её определению методами нормирования 
или на основе технологических карт. 

В столбце «примечание» таблицы работ целесообразно указывать, каким 
способом определена продолжительность работы и в какой степени эта инфор-
мация заслуживает доверия. 

После определения ожидаемой продолжительности работ, как показыва-
ет практика, целесообразно увеличить её значения на некоторый резерв (в про-
центах к ожидаемой продолжительности). Резерв этот менеджеру следует со-
гласовать с руководителем проекта, чтобы разделить с ним ответственность за 
возможный срыв сроков проекта из-за недостаточного запаса либо за потери, 
обусловленные неполным использованием возможностей скорейшего заверше-
ния проекта, если план предусматривал чрезмерный резерв. Величина резерва 
зависит от специфики области проектной деятельности. Существуют проекты, 
для которых предусматривать запас времени бессмысленно. 

З а м е ч а н и е  1 .  Некоторые практикующие менеджеры отрица-
ют необходимость введения резерва времени на этапе планирования, по-
ясняя, что лучше при необходимости затратить дополнительные средства 
на привлечение дополнительных ресурсов для ускорения проекта, чем со-
ставлять план, в который изначально заложены резервы, и вследствие 
этого проигрывать в конкурентной борьбе на рынке услуг по управлению 
проектами. 

З а м е ч а н и е  2 .  Иногда резерв дифференцируют по группам 
работ; но по возможности менеджеру проекта следует избегать подобной 
дифференциации, чтобы элемент субъективизма, вносимый в модель про-
екта, был как можно меньше. Подобную практику можно поддержать 
лишь тогда, когда для дифференциации резервов есть эмпирические ос-
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нования: например, имеются исследования, показывающие особенно вы-
сокую вариацию продолжительности определённых работ в предыдущих 
проектах. 

Информация о связях  между  работами  обычно берётся из техниче-
ского проекта либо определяется экспертами. Здесь риск ошибки значительно 
меньше, чем при определении продолжительности работ, зато цена ошибки 
может оказаться выше. 

На практике проблемы обычно возникают не из-за неправильного опре-
деления связей между работами, а из-за ошибок при вводе модели проекта в 
ЭВМ. Поэтому, получив первоначальный вариант сетевого плана, целесообраз-
но обсудить полученный критический путь с экспертами с целью выявления 
ошибочных связей, назначенных по крайней мере критическим работам. При 
реализации самых ответственных проектов можно поручить разработку пред-
варительного варианта модели проекта двум независимым менеджерам (или 
командам менеджеров), что позволит сравнить оба варианта и прийти к согла-
сованному решению, устранив причины расхождений. 

Потребность в ресурсах  определяется теми же способами, что и про-
должительность работ, с аналогичными замечаниями относительно надёжности 
результатов. Резерв в этом случае не предусматривается: он не снизит риски, а 
только увеличит простои ресурсов. 

 Стоимостные  показатели  определяются: для трудовых ресурсов — 
согласно штатному расписанию, тарифным сеткам или расценкам, существую-
щим на рынке труда; для других ресурсов — согласно эксплуатационным 
сметам, рыночным ценам или арендной плате, запрашиваемой владельцами 
данных или аналогичных ресурсов. Часто организации, занимающиеся управ-
лением проектами, ведут собственные систематически обновляемые базы дан-
ных стоимостной информации. 

Контрольные вопросы 

1. Опишите структуру исходных данных модели проекта. 
2. Какие сведения составляют общую информацию о проекте? 
3. Какая структура данных хранит информацию о распорядке рабочего дня? 
4. Как сочетается информация о рабочем времени для проекта и для конкрет-

ного ресурса? 
5. Как устанавливается связь между таблицей работ и таблицей ресурсов? 
6. В какой таблице хранится стоимостная информация по проекту? 
7. Какие сведения о сетевом плане хранятся в таблице работ? 
8. Какие данные указываются в таблице ресурсов только в том случае, если ре-

сурс является материалом? 
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9. В каких случаях следует использовать опыт предыдущих проектов в качест-
ве источника информации для модели проекта? 

10. Из каких источников менеджер проекта получает стоимостную информа-
цию? 

11. Как обеспечить надёжность данных о связях между работами в модели про-
екта? 

12. Зачем нужен резерв времени при определении продолжительности работ, 
используемых в модели проекта? 

13. Почему не предусматривается резерв по потребности в ресурсах для выпол-
нения работ? 

14. Каковы преимущества и недостатки определения продолжительности работ 
путём опроса экспертов? 

5. Описание модели проекта средствами Microsoft Project 
Формы представления данных о проекте. Приёмы ввода данных о работах. Единицы 

измерения продолжительности работ. Синтаксис описания связей между работами. Состав-
ные работы. Ввод данных о ресурсах. 

Прежде чем использовать Microsoft Project для разработки сетевого пла-
на, необходимо ввести данные, описывающие модель проекта. Программа Mi-
crosoft Project предусматривает множество способов ввода модели проекта: в 
диалоговом режиме при помощи мастеров (wizards); посредством диалоговых 
окон; непосредственно в таблицы работ и ресурсов; с использованием диа-
грамм. 

Ввод при помощи мастеров рекомендуется начинающим пользователям 
программы и здесь не рассматривается. Он более времяёмок, зато исключает 
пропуск необходимых данных. При желании вы можете ознакомиться с рабо-
той мастеров во время самостоятельной работы с программой. 

 
Основные формы представления данных в программе Microsoft Project 

следующие: 
♦ график Ганта (View → Gantt chart); 
♦ таблица ресурсов (View → Resource sheet); 
♦ график PERT (View → Network diagram); 
♦ календарь (View → Calendar; не путать с одноимённой структурой 

данных, хранящей сведения о распорядке рабочего дня). 
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Рис. 1. Форма представления данных «График Ганта» 

 
Есть и другие формы представления, используемые преимущественно на 

этапах мониторинга и анализа. Некоторые из них будут рассмотрены в после-
дующих темах. 

График Ганта (рис.1) представляет собой диаграмму, по оси ординат 
которой откладываются наименования работ в установленном пользователем 
порядке (обычно — в порядке ввода), а по оси абсцисс — время. Каждая работа 
представляется полосой на графике, указывающей занимаемый ею период вре-
мени. Критические работы выделяются красным цветом. График Ганта пред-
ставляет собой удобное средство отображения сетевого плана. 

В программе Microsoft Project график Ганта всегда отображается в соче-
тании с таблицей  работ: её крайний левый столбец — названия работ (Task 
Name) отображается на экране в качестве меток оси ординат графика Ганта. 

 
Рис. 2. Таблица ресурсов 

Чтобы отобразить только таблицу работ, следует переместить мышью 
границу между таблицей и графиком вправо до рамки окна программы; чтобы 
отобразить только график, переместите границу в противоположном направле-
нии. В последнем случае вы не увидите на экране наименования работ; но если 
поместить указатель мыши на полосе, представляющей конкретную работу, и 
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подождать полсекунды, программа выдаст название работы во всплывающей 
подсказке. 

Перемещая границу, всегда можно вернуть представление графика Ганта 
к исходному состоянию или установить любую другую желательную пропор-
цию разделения окна между собственно графиком и таблицей работ. Подробная 
информация о столбцах таблицы работ, предусмотренных программой Micro-
soft Project, приведена в приложениях 1 и 2. Любой из этих столбцов может 
быть при необходимости отображён на экране с помощью команды меню Insert 
→ Column…. 
 

Таблица ресурсов (рис. 2), в отличие от таблицы работ, в программе 
Microsoft Project реализована в виде самостоятельной формы представления. 

 
Рис. 3. График PERT 

График PERT (рис. 3) представляет собой отображение модели проек-
та в форме графа, вершинам которого соответствуют работы, а дугам — связи 
между ними. Каждая вершина представлена блоком, содержащим информацию 
о работе, детальность выдачи которой можно настраивать (команда Format Box 
контекстного меню). Как правило, график PERT весьма громоздок, из-за чего 
это представление используется сравнительно редко. Полезно бывает выдавать 
график PERT лишь для выбранной группы работ: тогда в нём легче разобрать-
ся. 

Календарь (рис. 4) используется для удобного и компактного отобра-
жения работ, выполняемых по состоянию на конкретную дату. Календарь пред-
ставляет собой диаграмму, по оси абсцисс которой отложены дни, а по оси ор-
динат — недели. Каждой работе соответствует полоса, которая охватывает дни, 
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в течение которых работа должна выполняться. Ширину столбца, соответст-
вующего дню недели, можно менять, перемещая мышью границу между любы-
ми двумя столбцами. 

 
Рис. 4. Форма представления данных «Календарь» 

З а м е ч а н и е .  Сужать столбцы календаря нет смысла: это при-
ведёт лишь к неполному использованию пространства окна. Увеличивать 
полезно, если в числе работ имеются очень короткие и потому почти не-
видимые на экране: так можно добиться их удовлетворительного отобра-
жения. Но в этом случае календарь не будет полностью умещаться в окне 
по ширине. 

 
Операции по вводу данных о работах представлены в табл.1. 
В Microsoft Project используются следующие единицы  измерения 

продолжительности  работ: 
♦ m (min) — минуты рабочего времени; 
♦ h (hr) — часы рабочего времени; 
♦ d (day) — рабочие дни (число часов в рабочем дне задаётся командой 

Tools → Options… → Calendar → Hours per day); 
♦ w (wk) — рабочие недели (число часов в рабочей неделе задаётся ко-

мандой Tools → Options… → Calendar → Hours per week); 
♦ mo (mon) — рабочие месяцы (число рабочих дней в рабочем месяце 

задаётся командой Tools → Options… → Calendar → Days per month); 
♦ em (emin) — минуты астрономического времени; 
♦ eh (ehr) — часы астрономического времени; 
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♦ ed (eday) — астрономические сутки (то есть 24 eh); 
♦ ew (ewk) — неделя (7 ed); 
♦ emo (emon) — месяц (30 ed). 



 
 

1. Ввод данных о работах 
Операции В таблице работ На графике Ганта На графике PERT На календаре 

Добавление 
новой 
работы 

♦ Ввести наименова-
ние работы в первой 
свободной строке или 
♦ нажать [Ins], чтобы 
вставить чистую стро-
ку в позиции курсора, 
и ввести название ра-
боты. 

 
— 

Выделить блок, 
соответствующий 
работе, после которой 
необходимо вставить 
новую, и нажать [Ins]. 

♦ Выделить работу и на-
жать [Ins]: новая работа 
будет вставлена после вы-
деленной и запланирована 
после её завершения или 
♦ выделить дату и нажать 
[Ins]: работа будет поме-
щена в конец списка работ 
и запланирована на теку-
щую дату. 

Удаление 
работы 

Выделить строку 
целиком и нажать 
[Del]. 

Выделить графический объект, соответствующий работе, и нажать [Del]. 

Ввод 
продолжител
ьности 
работы 

Ввести 
продолжительность в 
столбец Duration с 
указанием единиц 
измерения времениa). 

Переместить мышью 
правую границу 
полосы, 
соответствующей 
работе, следя за 
информацией во 
всплывающей 
подсказке. 

Двойным щелчком 
мыши на блоке работы 
вызвать окно Task 
Information, выбрать 
ярлычок General и 
ввести требуемые 
данные в поле 
Duration с указанием 
единиц измерения. 

Переместить мышью 
правую границу полосы, 
соответствующей работе, 
следя за информацией во 
всплывающей подсказке. 
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Продолжение табл.1.  
Операции В таблице работ На графике Ганта На графике PERT На календаре 

Ввод связей 
между 
работами 

Ввести номера работ, 
которые должны 
завершиться до начала 
данной, в столбец 
Predecessorsb). 

Нарисовать линию, связывающую предшествующую и последующую 
работы, перемещением мыши при нажатой левой кнопкеc). 
 

Удаление 
связей 
между 
работами 

Удалить ненужные 
номера работ в столбце 
Predecessors. 

Вызвать диалоговое окноd) Task Dependency, в 
котором нажать Delete. 
 

Вызвать диалоговое 
окноd) Task Information, 
выбрать ярлычок 
Predecessors и удалить 
ненужную связь в 
появившейся таблице.  

Назначение 
ресурсов на 
работыe) 

В столбце Resource 
Names выбрать из 
выпадающего списка 
требуемый ресурс; 
если нужно, указать 
его требуемое 
количество в 
квадратных скобкахf). 

Вызвать диалоговое окноd) Task Information, выбрать ярлычок Resources, 
ячейки первого столбца появившейся таблицы заполнить наименованиями 
ресурсов, выбирая их из выпадающего списка, второго — требуемым 
количеством ресурсов.  

30
 



 

Продолжение табл.1.  
Операции В таблице работ На графике Ганта На графике PERT На календаре 

Ввод 
ограничений 
на дату 
начала 
работыg) 

Заполнить столбец 
Start, выбрав дату из 
выпадающего 
календаря. При 
необходимости 
дописать к дате через 
пробел время по 
формату ЧЧ:ММ. 

Переместить вправо 
левую границу полосы, 
соответствующей 
требуемой работе. 

Вызвать диалоговое 
окноd) Task 
Information, выбрать 
ярлычок Advanced, 
установить Constraint 
type=Start no 
earlier than и 
требуемую дату в 
Constraint Date. 

Переместить к требуемой 
дате левую границу 
полосы, соответствующей 
требуемой работе. 

a) Подробнее см. подраздел «Единицы измерения продолжительности работ» (с. 27). 
b) Подробнее см. подраздел «Виды связей между работами» (с. 33). 
c) На графике PERT операция может повлечь изменение взаимного расположения блоков. 
d) Диалоговое окно вызывается двойным щелчком левой кнопкой мыши на соответствующем объекте: полосе, 

означающей работу, или стрелке, отображающей связь между работами. 
e) В предположении, что список ресурсов уже введён (приёмы его ввода описаны ниже). 
f) Если работа требует более одного ресурса, действовать так же, как при назначении ресурсов посредством 

диаграмм. Можно (но не рекомендуется) вводить наименования ресурсов, набирая их на клавиатуре и разделяя точкой 
с запятой (в английской версии Windows — запятой; от того, каков язык используемой версии программы Microsoft 
Project, символ-разделитель не зависит). 

g) Нельзя указать дату более раннюю, чем вычисленная автоматически. При необходимости программа может 
запланировать начало работы позже указанной даты, но никак не раньше. Программа запрашивает подтверждения 
операции ввода ограничения на дату начала работы. 
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Если при вводе данных в столбец Duration таблицы работ или в одно-
имённое поле формы Task Information единица измерения продолжительности 
работы не указана, программа предполагает, что продолжительность указана в 
рабочих днях. Если менеджер желает задать продолжительность работы в дру-
гих единицах, он должен указать единицу после числового значения, не отделяя 
пробелом, используя одну из вышеприведённых аббревиатур, например: 6w; 
4,3ed1; 12min. Программа запоминает использованную менеджером единицу 
измерения и в дальнейшем отображает продолжительность данной работы, если 
она будет по каким-либо причинам перевычислена, в тех же единицах, которые 
использовал менеджер. 

Если для указания продолжительности работы использована единица 
рабочего времени (m, h, d, w, mo), то при определении момента её завершения 
считается, что работа выполняется только во время, рабочее для проекта и для 
всех используемых ею ресурсов согласно назначенным календарям. При ис-
пользовании астрономического времени считается, что работа продолжается 
круглосуточно. Дата её завершения не зависит в этом случае ни от календаря 
проекта, ни от календарей используемых ресурсов, но оплата ресурсов начисля-
ется с учётом календарей (нерабочее время не оплачивается). 

Для указания видов связей  между  работами  в столбце таблицы ра-
бот Predecessors используется синтаксис, представленный в табл.2. 

Если информация о связях вводится посредством диаграмм или через 
форму Task Information, Microsoft Project автоматически формирует описание 
связей в столбце Predecessors таблицы работ согласно правилам, приведённым 
в табл.2. 

Расход  материальных  ресурсов при выполнении работы может быть 
фиксированным (так обстоит дело, например, с бетоном) или переменным — 
зависеть от продолжительности выполнения работы, как, например, расход 
электроэнергии на освещение стройплощадки в тёмное время суток. Во втором 
случае количество используемого ресурса при его назначении на данную рабо-
ту вводят с указанием единицы времени: например, 10/h (10 квт-ч. электро-
энергии за 1 ч рабочего времени). После ввода программа отобразит это коли-
чество следующим образом: 10 квт-ч/h. 

                                           
1 В английской версии Windows для отделения дробной части числа от целой вместо 

запятой следует использовать точку. 



 
 

2. Запись условий связи между работами в столбце Predecessors таблицы работ 

Синтаксис Пояснение Пример 
записи 

Пояснение 
к примеру 

<Номер работы> Работа, представленная в данной стро-
ке таблицы работ, не может начаться 
до завершения работы с указанным 
номером. 

14 Данную работу нельзя начинать, пока не 
завершится работа 14. 

<Номер работы>FS то же 14FS то же 
<Номер работы>SF Работа, представленная в данной стро-

ке таблицы работ, не может завер-
шиться до начала работы с указанным 
номером. 

14SF Работа 14 обязательно должна начаться 
до завершения данной работы 

<Номер работы>SS Работа, представленная в данной стро-
ке таблицы работ, не может начаться, 
пока не началась работа с указанным 
номером. 

17SS Данную работу нельзя начинать, если 
ещё не началась работа 17. 

<Номер работы>FF Работа, представленная в данной стро-
ке таблицы работ, не может закончить-
ся, пока не завершилась работа с ука-
занным номером. 

27FF Работа 27 обязательно должна завер-
шиться до завершения данной работы. 
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Продолжение табл.2. 

Синтаксис Пояснение Пример 
записи 

Пояснение 
к примеру 

12FS+4w
 

Данная работа должна начаться не ранее 
чем спустя 4 рабочих недели после окон-
чания работы 12. 

7SS-2ed Данная работа может быть начата не ра-
нее чем за две календарных недели до 
начала работы 7. 

<Номер работы> <мо-
дификатор 
вида связи><лаг>a) 

Событие, заданное типом связи, долж-
но быть сдвинуто на указанный про-
межуток времени, называемый лагом. 

2SF+1mon Данная работа может завершиться спустя 
не менее одного рабочего месяца после 
начала работы 2. 

a) Модификатор вида связи — одно из обозначений SF, FS, SS, FF, описанных выше. При использовании дан-
ной формы записи модификатор FS опускать нельзя. 

Элемент <лаг> имеет следующую структуру: <лаг> ::= <знак><целое число><единица времени>, где 
<знак> должен быть одним из символов «+» или «–», а единица времени — одной из единиц измерения продолжи-
тельности работ, описанных на с. 27. 

Примечание. Если время выполнения данной работы находится в зависимости от нескольких работ, то описа-
ния связей, соответствующие каждой из них, перечисляются через точку с запятой (в русских версиях Windows) либо 
через запятую (в английских). 
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Если единица времени при вводе затрат материала не указана (например, 

150), считается, что в ходе выполнения работы должно быть израсходовано 
указанное количество ресурса, независимо от её продолжительности: например, 
150 м3 бетона. 

Возможность иерархического  упорядочения  работ  предусмотрена 
для удобства манипулирования группами работ, объединённых общей целью. 
Работы можно организовать в иерархическую структуру, вводя составные ра-
боты (summary tasks). Microsoft Project считает работу составной, если имеются 
работы, входящие в её состав. Последние и сами могут быть составными. Что-
бы объединить одну или несколько работ в составную работу, следует: 

♦ ввести в таблицу работ название составной работы; 
♦ разместить работы, которые должны войти в её состав, непосредст-

венно под ней (если эти работы уже имеются в таблице работ, это можно сде-
лать при помощи буфера обмена или перетаскивая их мышью); 

♦ выделив их, нажать псевдокнопку  (Indent) на панели инструментов 
Formatting. 

Здесь предполагается, что все работы, включаемые в составную работу, 
находятся на одном и том же уровне иерархии. Если это не выполняется, то их 
следует привести к одному уровню, пользуясь псевдокнопками  и . Измене-
ние уровня составной работы влечёт соответствующее изменение уровня всех 
работ, входящих в её состав. 

Составные работы отличаются следующими свойствами: 
♦ их продолжительность нельзя вводить: она вычисляется; 
♦ на эти работы можно назначать ресурсы, затраты на которые будут 

начисляться в согласии с изменениями продолжительности составной работы; 
♦ копирование, перемещение, удаление составной работы влечёт вы-

полнение тех же операций для всех составляющих её работ; 
♦ в таблице работ и на графике Ганта работы, входящие в состав со-

ставной работы, могут быть скрыты, что даёт менеджеру возможность абстра-
гироваться от частностей при управлении проектом; 

♦ на диаграммах для составных работ предусмотрены особые обозначе-
ния. 

Специальные средства предусмотрены для создания периодических ра-
бот — таких, как совещания или регламентное обслуживание оборудования. 

Чтобы запланировать периодические работы и учесть использование от-
влекаемых на них ресурсов, следует, установив курсор в желаемую строку таб-
лицы работ, дать команду Insert → Recurring Task…. В вызываемом ею диало-
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говом окне Recurring Task Information вводятся сведения о периодичности 
работы. Затем программа создаёт составную работу, в которой каждое повторе-
ние представлено отдельной работой, входящей в её состав и имеющей фикси-
рованные даты начала и завершения. 

 
Для операций по вводу данных о ресурсах используется соответствую-

щая форма представления данных — таблица ресурсов. Ниже представлен спи-
сок столбцов таблицы ресурсов, отображаемых по умолчанию. 

Resource Name — наименование ресурса. 
Type — тип ресурса: нескладируемый (Work) или материаль-

ный (Material). 
Material Labels — единицы измерения (только для материалов). 
Max Units — количество ресурса (только для нескладируемых ресур-

сов)1. 
Std. Rate — для нескладируемых ресурсов — плата за единицу вре-

мени. Единица времени при вводе отделяется от числа 
символом /, например, 300/h — 300 руб. за час2. Аб-
бревиатуры астрономического времени здесь неприме-
нимы. Для материалов — цена материала за единицу 
(согласно столбцу Material Labels). 

Ovt. Rate — плата за единицу времени использования ресурсов 
сверх имеющихся в наличии (ставка оплаты сверх-
урочных либо плата за аренду оборудования на сторо-
не)3. Используется только для нескладируемых ресур-
сов. Правила ввода те же, что и для столбца Std. Rate в 
случае нескладируемых ресурсов. 

Cost/Use — плата за привлечение ресурса на работу (не зависящая 
от продолжительности использования). 

                                           
1 По умолчанию количество ресурса в Microsoft Project измеряется в процентах: на-

пример, один работник представляется как 100%, десять — как 1000%. Чтобы вводить коли-
чество ресурсов в штуках, необходимо изменить параметр Tools → Options → Schedule → 
Show assignment units as a с Percentage на Decimal. 

2 Имеется возможность поставить плату за ресурс в зависимость от того, на какой 
работе он задействован и в какие сроки выполняется. Для этого служит ярлычок Costs диа-
логового окна Resource Information, вызываемого двойным щелчком на имени ресурса. 
Здесь можно задать до пяти переменных профилей платы за ресурс. Подробнее см. в прило-
жении 4.  

3 При недостатке ресурса Microsoft Project не начисляет сверхурочные автоматиче-
ски. Для этого надо заполнить столбец Overtime work распределительной таблицы, доступ-
ный в режимах её просмотра View → Task Usage или View → Resource Usage. 
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Accrue At — способ начисления затрат. Выбирайте из выпадающего 
списка подходящий из трёх вариантов: Start — пе-
ред началом работы, End — по завершении работы; 
Prorated — пропорционально выполненному объё-
му работы. 

Base Calendar — имя календаря, назначенного данному ресурсу. 
Затраты на нескладируемый ресурс, относимые на работу, для выполне-

ния которой он используется, вычисляются1 по формуле n·(m·r+c), где n — ко-
личество используемых единиц ресурса, m — продолжительность работы, r — 
повременная плата, c — плата за привлечение ресурса. Плата за материал вы-
числяется по формуле n·r — где r — цена, n — сметный расход ресурса, преду-
смотренный для данной работы. 

З а м е ч а н и е  1 .  Иногда необходимо (или удобно) связывать 
определённые затраты не с использованием нескладируемых ресурсов 
или расходованием материалов, а с фактом выполнения работы. Это мо-
жет потребоваться, когда выполнение работы связано с расходованием 
очень большой номенклатуры материалов. Для этой цели предусмотрен 
столбец таблицы работ Fixed Cost, по умолчанию не отображаемый. Что-
бы отобразить требуемый столбец таблицы работ, следует в области заго-
ловков столбцов вызвать контекстное меню, выбрать в нём команду In-
sert Column… и в поле Field Name: появившегося диалогового окна вы-
брать системное имя требуемого столбца.  

З а м е ч а н и е  2 .  Чтобы изменить данные в ячейке таблицы ра-
бот или ресурсов (например, исправить опечатку в названии работы), сле-
дует выделить эту ячейку и нажать [F2]. 

З а м е ч а н и е  3 .  Данные некоторых ячеек — например, про-
должительность составных работ — вычисляются автоматически. Поль-
зователь не может изменить их непосредственно. 

Ввод данных о рабочем времени производится следующим образом. 
В диалоговом окне Change Working Time (рис. 5), вызываемом командой Tools 
→ Change Working Time…, создаётся необходимый набор календарей, кото-
рые в дальнейшем могут использоваться в качестве календарей проекта, кален-
дарей ресурсов или календарей работ. 

Для создания нового календаря следует нажать псевдокнопку New… и в 
появившемся диалоговом окне указать идентификатор (имя) вновь создаваемо-

                                           
1 Здесь предполагается, что ресурс не используется сверхурочно. 
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го календаря, после чего созданный календарь выбрать из списка For: диалого-
вого окна Change Working Time, чтобы приступить к его корректировке. 

Для изменения рабочего времени для конкретной даты нужно выбрать 
при помощи линейки прокрутки поля Select Date(s): требуемые месяц и год, за-
тем выделить требуемую дату или даты1. Далее при помощи переключателя Set 
selected date(s) to: установить этот день недели рабочим или нерабочим (см. 
рис.5). Для рабочего дня указать интервалы рабочего времени в полях From: и 
To:. Промежутки между указанными интервалами соответствуют перерывам в 
рабочем времени (например, обеденным). Перерывов может быть не более че-
тырёх. 

Можно изменять рабочее время для заданного дня недели (например, 
пятницы). Для этого следует щёлкнуть мышью на букве F в календаре 
(Friday — пятница (англ.)) или на другой букве, соответствующей другому 
требуемому дню недели, после чего действовать так же, как при установке ра-
бочего времени для конкретной даты. 

Изменение рабочего времени для дня недели не ограничивается выбран-
ным месяцем или годом — оно действует на весь календарь, в отличие от изме-
нения, сделанного для конкретной даты. Рабочее время, установленное для да-
ты, действует только в выбранном месяце выбранного года, поэтому особый 
режим работы в праздничные и предпраздничные дни следует устанавливать 
заново для каждого года предполагаемого периода проектных работ. 

Рабочее время, установленное для конкретной даты, всегда имеет при-
оритет над временем, установленным для дня недели, независимо от того, в ка-
кой последовательности пользователь программы выполнял операции по его 
установке. 

                                           
1 Нет возможности выделить одновременно даты, относящиеся к разным месяцам. 

При необходимости внести одинаковые изменения для дат, относящихся к разным месяцам, 
операцию приходится повторять. Альтернатива — создание макрокоманды с использовани-
ем средств языка программирования VBA. 
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Рис. 5. Диалоговое окно Change Working Time. 

Ввод общей информации по проекту осуществляется командами Project 
→ Project Information… → Summary и File → Properties…. 

Первая из них позволяет ввести информацию о наименовании проекта 
(Title:), его менеджере (Manager:) и организации, выполняющей проеке (Com-
pany:). 

Вторая даёт возможность указать дату начала проектных работ (Start 
date:); идентификатор календаря проекта (Calendar:); способ планирования 
(Schedule from:) — как правило, здесь должно быть указано Project Start 
Date, что требует от программы Microsoft Project начать проект в указанную 
дату и завершить как можно раньше. 

Технические параметры проекта, такие, как правила перевода одних 
единиц измерения рабочего времени в другие (см. с. 27), особенности отобра-
жения данных, режимы вычисления модели, задаются при помощи команды 
Tools → Options…. Освещение этих параметров, весьма многочисленных, не 
входит в задачи пособия — при необходимости обращайтесь к рекомендуемой 
литературе. Рекомендуемые значения наиболее существенных из них приведе-
ны в приложении 9. 
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Контрольные вопросы 

1. Какие формы представления данных поддерживаются программой Microsoft 
Project? 

2. Какая из форм представления данных наиболее удобна для отображения ра-
бот, которые должны выполняться по состоянию на конкретную дату? От-
вет обоснуйте. 

3. Как добавить новую работу в модель проекта? 
4. Как ввести продолжительность работы, пользуясь графиком PERT? 
5. Какие способы ввода связей между работами вам известны? 
6. Как удалить связь между двумя работами? 
7. Почему, по вашему мнению, не рекомендуется вводить наименования ре-

сурсов, используемых на данной работе, с клавиатуры? 
8. Какие трудности порождает использование ограничений на даты выполне-

ния работы? Как их преодолевать? 
9. Как вызвать диалоговое окно Task Information? 
10. Какие единицы измерения продолжительности работ применяются в про-

грамме Microsoft Project? Какова взаимосвязь между ними? 
11. Какие виды связей между работами вам известны? Как указать требуемый 

вид связи? 
12. Что такое лаг? Как он задаётся? 
13. Как задать расход материала в зависимости от продолжительности работы? 
14. Для каких целей используются составные работы? 
15. Как создать составную работу? 
16. Какие средства ввода данных о затратах на ресурсы поддерживает програм-

ма Microsoft Project? 
17. Как рассчитываются затраты на нескладируемый ресурс? 

6. Разработка плана 
Согласование использования ресурсов. Зависимость времени выполнения работы от 

количества используемых ресурсов. Трудности, возникающие при согласовании использова-
ния ресурсов, и их преодоление. Форма представления данных «Использование ресурсов». 
Фиксация согласованного варианта плана. 

Следующий этап работы по составлению сетевого плана — согласование 
использования ресурсов. 

Когда вся информация о модели проекта введена, столбцы Start и Finish 
таблицы работ отражают оптимальный сетевой план, не учитывающий недос-
татка ресурсов. Дальнейшие действия зависят от особенностей конкретного 
проекта: 
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a) если сверхурочное использование ресурсов недопустимо или нежела-
тельно (обычно дело обстоит именно так), то менеджер может предпочесть от-
ложить выполнение некоторых из конкурирующих работ на более поздний 
срок; 

b) в противном случае ему следует объявить соответствующую долю ис-
пользования ресурсов в периоды их недостатка сверхурочной работой (для это-
го предназначен столбец Overtime Work распределительной таблицы); 

c) возможна комбинация этих двух способов. 
Подробно рассмотрим вариант (a). 
 
Задержки работ для согласования использования ресурсов вводятся ко-

мандой Tools → Level Resources…. В вызываемом ею диалоговом окне Re-
source Leveling следует: 

♦ включить переключатель Manual (иначе программа будет вводить за-
держки автоматически, не оставляя менеджеру возможности вмешаться в про-
цесс распределения ресурсов); 

♦ параметр Look for overallocations on a установить равным Minute 
by Minute (иначе программа игнорирует нехватку ресурсов в короткие про-
межутки времени); 

♦ выбрать опцию Clear leveling values before leveling (иначе ранее вве-
дённые задержки не будут удалены перед новой операцией согласования ис-
пользования ресурсов). 

Имеются возможности: 
♦ вводить задержки только в течение определённого периода (Level 

from… to…); 
♦ выбирать один из трёх алгоритмов ввода задержек (Leveling order; 

рекомендуется использовать Standard); 
♦ вводить задержки только по некритическим работам в пределах 

имеющегося резерва времени, оставляя разрешение оставшихся проблем ме-
неджеру (опция Level only within available slack); 

♦ в случае недостатка ресурсов увеличивать продолжительность рабо-
ты, не прерывая её, с тем, чтобы обеспечить выполнение запланированного 
объёма ресурсо-часов каждым из назначенных на неё нескладируемых ресурсов 
(опция Leveling can adjust individual assignments on a task); 

♦ прерывать работы в период дефицита ресурсов, возобновляя по окон-
чании дефицита (опция Leveling can create splits in remaining work). 

З а м е ч а н и е  1 .  Поминутное согласование (Minute by 
Minute) может привести к тому, что из-за малой нехватки ресурсов, ко-
торая на практике осталась бы просто незамеченной, возникнет чрезмер-
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ное количество перерывов работ, обусловленных как графиком рабочего 
времени, так и процессом согласования. При других способах согласова-
ния нехватка ресурсов в пределах часа или рабочего дня игнорируется. 
Это уменьшает количество перерывов, но требует от менеджера принятия 
решений по всем случаям, когда дефицит ресурсов сохраняется. Более 
продуктивный подход состоит в том, чтобы при подготовке первоначаль-
ного варианта плана выполнить согласование на поминутной базе, а из-
быточные перерывы устранять уже на стадии мониторинга фактического 
хода выполнения проекта. 

З а м е ч а н и е  2 .  Опции Leveling can adjust individual assign-
ments on a task  и Leveling can create splits in remaining work рекомен-
дуется включать. Вводить ли задержки только в пределах имеющегося ре-
зерва времени или разрешать конфликты использования ресурсов полно-
стью — это зависит от от многих факторов, например, от возможности 
привлечения ресурсов сверх наличия, от разнообразия используемых ре-
сурсов, количества конфликтов распределения, условий финансирования, 
индивидуального стиля работы конкретного менеджера. 

З а м е ч а н и е  3 .  Информация о задержках, вводимых при согла-
совании использования ресурсов, хранится в столбце Leveling Delay 
таблицы работ, который при необходимости может быть отображён. Све-
дения о перерывах в выполнении работ не могут быть выведены в таб-
личной форме, но отображаются на графике Ганта, при использовании 
формы представления данных «Календарь» и других форм, использую-
щих отображение данных вдоль временнóй оси. 

При согласовании использования ресурсов возможны нештатные ситуа-
ции. Если по согласовании использования ресурсов некоторые из них в отдель-
ные моменты времени по-прежнему используются в количествах, превышаю-
щих наличие, причины могут быть в следующем: 

♦ в модели проекта имеются ограничения на сроки выполнения работ; 
♦ отдельным ресурсам или работам назначены календари, отличающие-

ся от календаря проекта; 
♦ менеджер вручную вводил перерывы в выполнение отдельных работ; 
♦ по некоторым работам установлены контрольные сроки их выполне-

ния (то есть столбец Deadline таблицы работ не пуст); 
♦ график затрат ресурсо-часов на некоторые работы был изменён ме-

неджером вручную1; 
                                           
1 Подробнее о корректировке графика использования ресурсов см. на с. 45. 
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♦ количество ресурсов, назначенных на некоторые работы, слишком ве-
лико. 

В последнем случае, если сократить количество назначенных ресурсов 
не представляется возможным, добиться согласования можно, повторяя эту 
процедуру при снятом флажке Clear leveling values before leveling либо выпол-
няя её не для всего проекта, а только для ресурсов, оставшихся в дефиците по-
сле предыдущей операции согласования. Для этого в таблице ресурсов следует 
выделить соответствующие строки и после подачи команды Tools → Level Re-
sources… → Level Now в появившемся диалоговом окне выбрать вариант Se-
lected resources. 

Если эти приёмы не помогают, можно отключить опции Leveling can ad-
just individual assignments on a task  и Leveling can create splits in remaining 
work, что может привести к значительному увеличению запланированного сро-
ка выполнения проекта. 

 
После введения задержек может возникнуть необходимость вмешатель-

ства менеджера для корректировки составленного плана. Для этой цели менед-
жер: 

♦ сокращает продолжительность критических работ, назначая на них 
дополнительные нескладируемые ресурсы; 

♦ высвобождает нескладируемые ресурсы, сокращая их назначение на 
некритические работы со значительным запасом времени и увеличивая тем са-
мым продолжительность их выполнения; 

♦ меняет последовательность введения задержек, устанавливая для 
работ приоритеты (Task Information → General → Priority); 

♦ устанавливает ограничения по датам начала или завершения опреде-
лённых работ, чтобы повлиять на работу процедуры автоматического введения 
задержек; 

♦ уточняет график использования ресурсов на каждой работе. 
Чтобы  программа  автоматически  корректировала  продолжи-

тельность работы  при выделении дополнительных ресурсов на её выполне-
ние, в диалоговом окне Task Information (вызываемом двойным щелчком мы-
ши на объекте, представляющем работу — строке таблицы работ, полосе ка-
лендаря или графика Ганта, блоке графика PERT) необходимо выбрать ярлычок 
Advanced и включить переключатель Effort driven. Обычно он включён по 
умолчанию. Если его выключить, изменения в количестве назначенных ресур-
сов не будут влиять на продолжительность работы. Вместо этого будут перевы-
числяться общая ресурсоёмкость работы и денежные затраты на её выполнение. 
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При включённом переключателе Effort driven, если на данную работу 
назначено несколько ресурсов, программа будет перевычислять продолжитель-
ность работы исходя из ресурсоёмкости, определённой при первоначальном на-
значении ресурсов. 

Пусть, например, на работу продолжительностью 10 рабочих дней пер-
воначально назначено 20 рабочих и 10 ручных косилок (то есть должно быть 
отработано 200 чел.-ч. и 100 ресурсо-часов). Тогда сокращение числа рабочих 
до 10 приведёт к увеличению продолжительности выполнения работы до 20 
дней (чтобы было отработано не менее 200 чел.-ч.), а косилки будут использо-
ваться неэффективно: объём выполняемой ими работы превысит положенные 
100 ресурсо-часов вдвое. При этих условиях сокращение количества косилок до 
5 не повлияет на продолжительность работы, поскольку ограничение по тре-
буемому количеству ресурсо-часов косилок по-прежнему будет выполняться, 
только без избытка. Но если сократить количество косилок до 4, то работа зай-
мёт уже 25 дней, а неэффективно будут использоваться рабочие: трудозатраты 
10 рабочих составят 250 чел.-ч., что больше требуемых 200. 

Если установить количество ресурса, назначенного на данную работу, 
равным нулю, ограничение по нему удаляется и дальнейшие изменения его ко-
личества не будут больше влиять на продолжительность работы. 

З а м е ч а н и е  1 .  Если продолжительность работы измеряется в 
астрономическом времени, то есть обусловлена природными процессами, 
не следует включать для этой работы переключатель Effort driven. 

З а м е ч а н и е  2 .  Если переключатель Effort driven включён и 
на данной работе расходуется фиксированное количество материала, то 
при назначении на работу дополнительных нескладируемых ресурсов 
может возникнуть несоответствие между датами начала и завершения ра-
боты, с одной стороны, и данными столбца таблицы работ Duration, с 
другой. Оно обусловлено тем, что ускорение работы за счёт назначения 
на неё дополнительных ресурсов, отражаемое данными столбца Duration, 
не влияет на ранее установленный график использования материала, учи-
тываемый данными столбцов Start и Finish, если расход материала не за-
висит от времени работы. Поэтому не рекомендуется назначать материа-
лы, используемые в фиксированном количестве, на работы, продолжи-
тельность которых зависит от количества нескладируемых ресурсов.  
 Если такое назначение необходимо, то после каждого изменения 
объёма назначенных на работу нескладируемых ресурсов следует удалять 
назначение материальных ресурсов, используемых в фиксированном ко-
личестве, и затем снова назначать их (не пользуясь операцией отмены 
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предыдущего действия). Тогда график использования материала будет 
составлен заново в согласии с новой продолжительностью выполнения 
работы. 

Ограничения  на сроки  выполнения  работ  можно ввести в диалого-
вом окне Task Information (ярлычок Advanced, выпадающие списки Con-
straint type и Constraint date) либо перемещая мышью полосы, представляю-
щие работу, на графике Ганта или на календаре. 

Ограничения, введённые менеджером, никогда не убираются програм-
мой автоматически: она не может определить, отпала ли надобность в них. По-
этому пользоваться ограничениями на сроки выполнения работ следует только 
при крайней необходимости во избежание возникновения ошибок в модели 
проекта. Программа Microsoft Project сообщает пользователю о наличии работ, 
имеющих такие ограничений, отображая для каждой из них пиктограмму  в 
информационном столбце таблицы работ, озаглавленном символом . 

Если проект содержит очень большое количество работ, а менеджер 
пользуется подобными ограничениями, ему следует систематически просмат-
ривать работы, на которые установлены ограничения по срокам, с помощью 
фильтра Tasks with Fixed Dates. Этот фильтр можно установить посредством 
выпадающего списка Filter на панели инструментов Formatting. Когда он 
включён, на экране отображаются только работы с ограничениями на сроки вы-
полнения, что позволяет менеджеру обнаружить и снять ограничения, назна-
ченные необоснованно или более ненужные. 

Снимается фильтр выбором пункта All Tasks из того же выпадающе-
го списка. 

Для уточнения  графика  использования  ресурсов применяется 
форма представления данных «Назначение ресурсов», вызываемая командой 
View → More Views… → Resource Allocation.При этом в верхней половине эк-
рана отображаются: 

♦ распределительная таблица в разрезе ресурсов (левый верхний квад-
рант); 

♦ расписание использования каждого ресурса на каждой работе в каж-
дый интервал времени (правый верхний квадрант). 

Масштаб времени в расписании менеджер выбирает самостоятельно, 
пользуясь для этого псевдокнопками  и  на стандартной панели инструмен-
тов. В нижней части экрана отображается график Ганта только для тех работ, 
которые используют ресурс, соответствующий текущей строке верхней поло-
вины экрана. В первых строках верхнего левого квадранта в группе 
Unassigned отображаются работы, на которые не назначен ни один ресурс. 
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Такая форма отображения данных позволяет быстро обнаруживать и 
устранять причины дефицита ресурсов, а также выравнивать степень их загруз-
ки, добиваясь сокращения срока выполнения проекта. 

Работая с формой представления данных «Назначение ресурсов», удоб-
но отобразить на экране панель инструментов Resource Management (View → 
Toolbars → Resource Management). Псевдокнопка  этой панели инструмен-
тов позволяет найти на графике Ганта, графике использования ресурсов или в 
расписании использования ресурсов очередной период дефицита ресурсов со-
гласно актуальному на данный момент времени оперативному плану и принять 
необходимые решения по его преодолению. Псевдокнопка  позволяет быстро 
вернуться к форме  «Назначение ресурсов» из других форм представления дан-
ных. Другие псевдокнопки этой панели дают возможность быстро оповестить 
участников проекта об изменениях в плане использования ресурсов; подобрать 
замену ресурсу, оказавшемуся в дефиците; заимствовать ресурсы из других 
проектов и т.п. 

Изменения в график использования ресурсов, назначенный программой, 
вносятся путём корректировки данных в правом верхнем квадранте. Например, 
если остаток работы выполняется в течение первого получаса понедельника, 
вовсе не обязательно требовать в этот период присутствия приглашённого спе-
циалиста, отвечавшего за весь ход выполнения данной работы. Зато можно уве-
личить объём его использования в пятницу. 

З а м е ч а н и е  1 .  Если в график использования ресурса на неко-
торой работе внесены изменения, то при последующих операциях согла-
сования средствами команды Tools → Level Resources… программа уже 
не сможет изменить назначение данного ресурса на данную работу. Это 
может привести к невозможности разрешить все случаи дефицита данно-
го ресурса. 

З а м е ч а н и е  2 .  Изменения в график использования ресурса 
могут также вноситься процедурой согласования использования ресурсов. 
Изменения, внесённые автоматически, программа убирает при выполне-
нии команды Tools → Level Resources… → Clear Leveling…. 

З а м е ч а н и е  3 .  Строки распределительной таблицы, соответ-
ствующие ресурсу, график использования которого отличается от равно-
мерного, помечаются пиктограммой  в информационном столбце (оза-
главленном символом ). 

З а м е ч а н и е  4 .  Если на работу назначены материалы в фикси-
рованных количествах, результатом манипуляций с графиком использо-
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вания ресурсов может стать несоответствие данных столбца Duration да-
там, указанным в столбцах Start и Finish. Причины этой ситуации описа-
ны на с. 44. 

Чтобы после внесения изменений вернуться к автоматически назначен-
ному графику использования ресурса и тем самым снять препятствия работе ал-
горитма согласования использования ресурсов, следует, дважды щёлкнув на 
требуемой строке распределительной таблицы, вызвать диалоговое окно As-
signment information, где из списка Work contour выбрать значение Flat. 
При этом, однако, исходные суммарные затраты ресурсо-часов данного ресурса 
на данную работу, если они были изменены, не восстановятся. Их придётся 
восстанавливать вручную — например, заново указав продолжительность рабо-
ты и требуемое количество ресурса при выключенном переключателе Effort 
driven диалогового окна Task Information. 

Чтобы менеджеру не приходилось заботиться об итоговом количестве 
ресурсо-часов, программа предлагает на выбор несколько предопределённых 
профилей неравномерного использования ресурса на данной работе. Выбирают 
требуемый профиль из уже упомянутого списка Work contour. Предлагаем вам 
поэкспериментировать с профилями самостоятельно во время выполнения ла-
бораторных работ. 

З а м е ч а н и е .  Использование любого профиля, кроме равно-
мерного (Flat), приводит к увеличению продолжительности работы, по-
скольку в некоторые периоды загрузка ресурса окажется меньше макси-
мальной (так можно высвободить ресурсы для критических работ). Уста-
новить нагрузку, превышающую максимум, определённый календарём, 
можно только вручную. В этом случае целесообразно объявить превыше-
ние сверхурочной работой, чтобы она оплачивалась по ставкам сверх-
урочной работы, определённым в таблице ресурсов. Для этого вывести в 
правом верхнем квадранте сведения о сверхурочных работах (команда 
Detail Styles… контекстного меню → выбрать Overtime Work из спи-
ска Available fields → Show >> → OK) и внести объём работы, призна-
ваемый сверхурочной, в соответствующие клетки. 

Согласованный план — это окончательный, принимаемый к исполнению 
вариант сетевого плана. После составления, согласования со всеми сторонами, 
участвующими в реализации проекта, и утверждения руководителем организа-
ции сетевой план фиксируется командой Tools → Tracking → Save Baseline. 
В диалоговом окне Save Baseline, вызываемой этой командой, следует вклю-
чить переключатели Save baseline и Entire project. 
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Зафиксированный согласованный план хранится в столбцах таблицы ра-
бот, имена которых начинаются со слова Baseline: Baseline start, Baseline 
finish, Baseline work и др. Он остаётся неизменным при дальнейших изменени-
ях оперативного сетевого плана в процессе мониторинга проекта. 

С этого момента план может быть использован для заключения трудо-
вых договоров и договоров аренды ресурсов на определённые сроки, для опре-
деления потребности в кредите и для информирования банков, финансирующих 
затраты по проекту, о предполагаемом графике обращения за кредитными ре-
сурсами. Кроме того, согласованный план используют для анализа отклонений 
фактического хода выполнения работ от первоначального плана. 

Пользуясь выпадающим списком Baseline в диалоговом окне Save Base-
line, для целей анализа можно сохранить до 11 вариантов плана в дополнение к 
согласованному. В их числе, например, могут быть резервные планы на случай 
возникновения поддающихся прогнозированию чрезвычайных обстоятельств. 

Контрольные вопросы 

1. Как осуществляется согласование использования ресурсов? 
2. Объясните, почему в большинстве случаев не следует включать режим ав-

томатического согласования использования ресурсов? 
3. Каковы, по-вашему, преимущества и недостатки согласования использова-

ния ресурсов в пределах имеющегося резерва времени? Сформулируйте ус-
ловия, при которых вы могли бы рекомендовать менеджеру этот способ со-
гласования. 

4. Каковы преимущества и недостатки поминутного и почасового согласова-
ния? 

5. Какие способы отображения сведений о задержках и перерывах, обуслов-
ленных согласованием использования ресурсов, вам известны? 

6. Что следует предпринять, если согласование использования ресурсов не 
достигает цели? 

7. Что вы посоветовали бы предпринять, если согласование использования ре-
сурсов приводит к неприемлемо большим задержкам? 

8. Какими причинами обусловлена необходимость корректировки плана, по-
лученного в результате согласования использования ресурсов? 

9. Какие приёмы корректировки плана, полученного с помощью процедуры 
согласования использования ресурсов, вам известны? 

10. Как вычисляется продолжительность работы в случае изменения объёма 
выделенного на её выполнение ресурса при включённом переключателе Ef-
fort driven? 

11. В каких случаях не следует включать переключатель Effort driven? 
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12. Почему может возникать несогласованность между данными столбцов 
Start, Finish и Duration? Как избежать этой ситуации? 

13. Как изменить график использования ресурса на данной работе, предложен-
ный программой? 

14. С какой целью менеджер может вмешаться в график использования ресурса 
на данной работе? 

15. Как объявить работу сверхурочной? В каких случаях это требуется? 
16. Для каких целей используется согласованный план? 
17. Как зафиксировать согласованный план? 

7. Мониторинг проекта 
Ввод и корректировка данных о ходе выполнения проекта. Инструментальная под-

держка и искусство оперативного планирования. Обнаружение ошибок мониторинга и опе-
ративного планирования. 

На практике, едва приступив к выполнению согласованного плана, ме-
неджер под влиянием самых разных обстоятельств столкнётся с тем, что вы-
полнить его в точности практически невозможно. Вот почему мониторинг про-
екта и систематическое уточнение сетевого плана с учётом текущей ситуации 
является неотъемлемой составляющей частью технологии PERT. 

Но вводить информацию о состоянии тысяч работ ежедневно, а тем бо-
лее несколько раз в день, — процесс неоправданно трудоёмкий. В связи с этим 
в большинстве программ для управления проектами принят подход, состоящий 
в том, что менеджер вводит лишь наиболее существенные отклонения от сете-
вого плана — те, которые затрагивают критические работы или, как предпола-
гается, могут изменить критический путь. Об остальных работах делается пред-
положение, что они выполняются без существенных отклонений от графика. 

Реализуется этот подход следующим образом. Вначале менеджер пред-
лагает программе пометить в качестве выполненных все работы, которые 
должны завершиться к текущему моменту времени, и установить соответст-
вующий процент завершённости для выполняющихся. Затем он вручную вво-
дит поправки к изменениям, внесённым программой, основываясь на посту-
пающих сведениях о фактическом выполнении работ. Эти две операции отно-
сятся к мониторингу выполнения проекта. Наконец, менеджер уточняет распи-
сание предстоящих работ и назначение ресурсов с учётом произошедших от-
клонений от согласованного плана — осуществляет оперативное планирование 
на основе данных мониторинга. 

Чтобы на графике Ганта выдавалась информация о степени завершённо-
сти работ, собранная в процессе мониторинга проекта, следует дать команду 
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View → Tracking Gantt. Чтобы столбцы, содержащие данные мониторинга, 
отобразились в таблице работ, требуется дать команду View → Table → Track-
ing. Возврат к исходному представлению таблицы работ происходит по коман-
де View → Table → Entry. 

 
Для автоматизированного ввода данных мониторинга в предположении, 

что проект выполняется согласно оперативному (отражённому данными столб-
цов Start и Finish таблицы работ) сетевому плану, следует: 

♦ дать команду Tools → Tracking → Update Project (на экране появит-
ся диалоговое окно Update Project); 

♦ включить переключатель Update work as complete through; 
♦ в выпадающем календаре справа от переключателя указать дату и, 

при необходимости, дописать время, на которое производится обновление дан-
ных мониторинга (по умолчанию обновление производится на текущий момент 
по системным часам ПЭВМ); 

♦ установить переключатель For в позицию Entire project; 
♦ нажать псевдокнопку OK. 

З а м е ч а н и е .  Перед выполнением операции необходимо про-
верить, что в программу загружен именно согласованный вариант плана, 
а не какой-либо другой. Ошибка на этом этапе может привести к большим 
потерям времени и средств. 

Данные мониторинга помещаются в столбцы Act. Start и Act. Finish 
таблицы работ. В результате приведённой выше последовательности действий в 
них произойдут следующие изменения. 

1) Для работ, которые должны, согласно оперативному плану, завер-
шиться, — будут записаны даты фактического начала и завершения работ, сов-
падающие с данными столбцов Start и Finish, отображающих текущий вариант 
оперативного плана. Кроме того, в столбец % Comp, содержащий данные о 
степени завершённости работы, будет помещено значение 100%. 

2) Для работ, которые должны выполняться в настоящее время, — бу-
дет записана только дата начала работы. Значение столбца Act. Finish останется 
неопределённым. В столбец % Comp будет помещён процент завершённости 
работы. Он вычисляется как отношение продолжительности части работы, 
предшествующей моменту мониторинга, к общей плановой продолжительности 
работы. 

3) Для работ, начало которых запланировано на более позднее время по 
сравнению с моментом мониторинга, значения столбцов Act. Start и Act. Finish 
остаются неопределёнными. 
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Для работ, отклонившихся от графика, можно вводить мониторинговую 
информацию нижеследующими способами: 

♦ если работа уже началась, ввести фактические дату и время начала в 
столбец Act. Start таблицы работ (предварительно потребуется дать команду 
View → Table → Tracking для его отображения); 

♦ если работа не началась, но дата фактического начала введена (на-
пример, вследствие автоматического ввода данных мониторинга), следует уда-
лить значение, содержащееся в столбце Act. Start; 

♦ если работа завершилась, ввести фактические дату и время заверше-
ния в столбец Act. Finish таблицы работ; 

♦ если работа выполняется, ввести процент завершённости работы в 
столбец % Comp таблицы работ либо переместить мышью левую границу по-
лосы на графике Ганта, соответствующей данной работе, следя за информацией 
во всплывающей подсказке. 

Если по нескольким работам нужно установить одну и ту же дату за-
вершения либо один и тот же процент завершённости — выделить эти работы и 
дать команду Tools → Tracking → Update Tasks, после чего в диалоговом окне 
Update Tasks ввести: 

♦ фактические дату и время завершения — в поле Actual Finish, при 
необходимости пользуясь выпадающим календарём; 

♦ фактические дату и время начала, если они не соответствуют запла-
нированным, — в поле Actual Start; 

♦ процент завершённости (для незавершённых работ) — в поле 
% Complete. 

З а м е ч а н и е  1 .  Как правило, вводимая менеджером дата фак-
тического начала работы не должна противоречить связям с другими ра-
ботами (иначе модель проекта не соответствует реальности). При нару-
шении этого условия программа выдаёт соответствующее предупрежде-
ние и предлагает отказаться от операции по вводу данных мониторинга. 
Если менеджер настаивает на вводе, данные мониторинга обладают при-
оритетом перед моделью проекта. 

З а м е ч а н и е  2 .  Конфликты использования ресурсов, возни-
кающие при вводе данных мониторинга, программой игнорируются. Их 
возникновение менеджер должен отслеживать самостоятельно, при необ-
ходимости вводя данные о сверхурочном использовании ресурсов. 

З а м е ч а н и е  3 .  Данные о фактических сроках выполнения ра-
бот, если они введены, можно изменить только вручную, а о степени за-
вершённости работ — также при автоматизированном вводе данных мо-
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ниторинга. Программа их не перевычисляет. Никакое изменение в связях 
между работами, ограничениях на сроки выполнения работ, распределе-
нии ресурсов не может повлиять на данные столбцов Act. Start и Act. 
Finish. Если изменение в модели проекта несовместимо с введёнными 
данными мониторинга, программа отказывается его вносить, выдавая со-
ответствующую диагностику. 

З а м е ч а н и е  4 .  Если продолжительность работы, вычисленная 
исходя из данных мониторинга, отличается от расчётной, то плата за ре-
сурсы будет начисляться исходя из фактического, а не запланированного, 
количества ресурсо-часов. Например, если за фактически израсходован-
ное время работа была завершена с использованием меньшего количества 
ресурсов, менеджер сам должен внести коррективы в информацию о на-
значении ресурсов на данную работу. 

 
Оперативное планирование имеет существенное отличие от составления 

первоначального сетевого плана. Если на момент мониторинга имеются работы, 
которые, вопреки расписанию, всё ещё не начаты, Microsoft Project не перено-
сит срок их начала на более позднее время автоматически. Программа не знает, 
по какой причине менеджер не ввёл сведений о начале работы: то ли работа 
действительно не началась, то ли информация об её начале ещё не поступила. 

В этих условиях обычные приёмы введения задержек могут не дать 
ожидаемого результата: часть работ может быть запланирована на уже про-
шедшее время. 

Для переноса не начавшихся вовремя работ на более позднее время сле-
дует воспользоваться командой Tools → Tracking → Update Project, включив в 
диалоговом окне Update Project переключатель Reschedule uncompleted work 
to start after и указав посредством выпадающего календаря требуемые дату и 
время (по умолчанию используются системные дата и время ЭВМ). Как и при 
автоматическом вводе данных мониторинга, операция может быть выполнена 
для всего проекта либо только для предварительно выделенных работ. 

В результате выполнения данной команды программа вменяет всем либо 
выбранным работам ограничение вида «не раньше» по дате начала работы. Ес-
ли по датам начала или завершения каких-либо из этих работ ранее были указа-
ны другие ограничения, они отменяются. Если менеджер этого не желает, он 
должен предварительно скрыть эти работы с помощью фильтра, а остальные 
выделить и в диалоговом окне Update Project установить переключатель For в 
положение Selected tasks. 
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Операция должна выполняться только для тех работ, о которых досто-
верно известно, что они так и не начались, хотя все условия для их начала уже 
выполнены. Если менеджер не знает, началась ли работа, и располагает доста-
точным временем, он может составить два варианта оперативного плана: в од-
ном из них работа принимается выполняющейся по графику, в другом — за-
державшейся. Если такой возможности не представляется, следует исходить из 
предположения, что работа выполняется по графику, для чего либо не включать 
работу в число работ, по которым переносится срок начала, либо удалить авто-
матически добавленное ограничение по сроку начала работы. Лучше уточнить 
план впоследствии, когда поступит информация, чем задерживать другие рабо-
ты из-за гипотетической задержки данной. 

После переноса сроков начала не начавшихся вовремя работ процедура 
оперативного планирования не отличается от разработки первоначального пла-
на: согласуется использование ресурсов, при необходимости происходит их пе-
рераспределение для скорейшего завершения работ, оказавшихся на новом кри-
тическом пути. 

Контрольные вопросы 

1. Какой подход к преодолению трудоёмкости мониторинга выполнения про-
екта предусматривается технологией PERT? 

2. Раскройте содержание понятия «данные мониторинга». 
3. Как в программе Microsoft Project отобразить данные мониторинга в табли-

це работ? 
4. В какие столбцы таблицы работ записываются данные мониторинга? 
5. Как реализовать автоматизированную процедуру ввода данных мониторин-

га в программе Microsoft Project? 
6. Как вводятся данные мониторинга в случае, если значительная часть работ 

выполняется с отклонением от сетевого плана? 
7. Объясните, почему данные мониторинга могут противоречить модели про-

екта. Как этого избежать? 
8. Как вводить информацию о проценте выполнения работы, используя график 

Ганта? 
9. Объясните различия между командами Tools → Tracking → Update Project 

и Tools → Tracking → Update Tasks. 
10. На работу продолжительностью 12 дней было назначено 2 экскаватора. 

В дальнейшем менеджер назначил на работу дополнительные экскаваторы с 
тем, чтобы сократить её продолжительность до 4 дней (переключатель Ef-
fort driven включён). Определите самостоятельно фактические затраты на 
эксплуатацию экскаваторов, если рабочий день одного экскаватора обхо-
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дится в 2 тыс. руб., а фактическая продолжительность работы, вопреки пла-
нам менеджера, составила 6 дней. Проверьте ответ при помощи программы 
Microsoft Project. 

11. Опишите процедуру корректировки сетевого плана при оперативном плани-
ровании. 

12. Как следует действовать менеджеру при составлении оперативного плана, 
если информация о состоянии некоторых работ не поступила? Почему? 

8. Подготовка аналитических материалов и презентаций 
Управление представлением графика PERT, таблиц работ и ресурсов. Представление 

данных распределительной таблицы. Использование столбцов, определяемых пользователем. 
Изменение вида графика Ганта и графика загруженности ресурса. Применение фильтров, 
ранжирования и группировки. Печать документов. 

Первоначальный план и многие оперативные решения, особенно в слу-
чае превышения сметных расходов или существенного изменения плана финан-
сирования, требуют согласования с руководством и партнёрами организации, 
выполняющей проект. 

Данные мониторинга используются не только для оперативного плани-
рования, но и для анализа с целью выявления проблем, преодоление которых 
может содействовать ускорению выполнения проекта. По завершении выпол-
нения проекта информация, собранная в процессе мониторинга становится цен-
ным источником опыта, обучения новых кадров и совершенствования процедур 
управления проектами, принятых в данной организации. 

Всё это обусловливает потребность в формах представления данных, 
предназначенных для целей, отличающихся от рассмотренных выше. Разнооб-
разие таких целей трудно предусмотреть заранее, поэтому вместе с готовыми 
формами представления данных, ориентированными на удовлетворение часто 
возникающих информационных потребностей, программные средства, реали-
зующие технологию PERT, допускают конструирование новых форм на основе 
предлагаемых по умолчанию. 

Нельзя недооценивать значение процесса подготовки документов, выво-
димых на печать или на экран проектора перед многочисленной аудиторией. 
Оперативность и качество принятия ответственных решений, определяющие 
успех или неудачу применения технологии PERT, во многом зависят от того, 
насколько удачно менеджер выбрал форму представления информации о про-
екте, предоставляемой руководству организации, финансовым менеджерам, 
кредиторам, инвесторам, партнёрам и другим пользователям. 
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График PERT (View → Network Diagram) наглядно отображает струк-
туру проекта и позволяет представить заказчику, инвесторам и кредитным ор-
ганизациям аргументы в пользу планируемой продолжительности фазы реали-
зации проекта. Работы представлены на нём блоками, связи между ними — 
стрелками. 

Составные работы отображаются параллелограммом, обычные — пря-
моугольником, события — шестиугольником. Критические работы и связи ме-
жду ними выделяются цветом и толщиной линий. Полезно бывает использовать 
график PERT и на фазе реализации проекта: в этом случае блоки уже завершён-
ных работ перечёркиваются крест-накрест, а выполняющихся — по диагонали, 
что даёт наглядную картину выполнения работ. 

Для большинства проектов графиком PERT практически невозможно 
пользоваться, если представить на нём все работы. Например, даже для учебно-
го проекта, описанного в разделе «Лабораторный практикум» настоящего посо-
бия, график PERT занимает шесть листов альбомной ориентации в ширину и 
два в высоту. Поэтому на нём обычно отображают лишь составные работы, со-
провождая наиболее важные из них детализирующими графиками PERT, 
оформленными в качестве самостоятельных документов. Но даже в этом случае 
распечатанные графики приходится склеивать из отдельных листов. 

На экране у каждого параллелограмма отображается символ , щёлкнув 
который, можно скрыть работы, входящие в данную составную работу, после 
чего этот символ заменяется символом . Щелчок на  вновь отображает 
скрытые работы. Чтобы сразу скрыть все работы, кроме составных, можно вос-
пользоваться выпадающим списком Filter на панели инструментов Formatting, 
выбрав из него позицию Summary Tasks. Выбор позиции Top Level 
Tasks скрывает все работы, кроме первого уровня. Снятие фильтра выбором 
позиции All Tasks не приводит к раскрытию скрытых работ: для этого нуж-
но воспользоваться символами . 

Другой способ сделать график PERT компактнее — изменить способ 
отображения блоков, соответствующих работам, выдавать в них только номер 
работы. Для этого в режиме просмотра графика PERT следует дать команду 
Format → Layout… → Hide all fields except ID. В таком виде учебный проект 
из лабораторного практикума удаётся разместить всего на двух листах. 

Третий способ — воспользоваться псевдокнопками  и  для достиже-
ния желаемого масштаба изображения. 

Если задержать курсор мыши над блоком, представляющим работу, то 
программа увеличивает этот блок так, чтобы содержащаяся в нём информация 
была представлена достаточно крупным шрифтом. Если установлен режим 
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Hide all fields except ID, в увеличенном блоке отображаются данные, которые 
были бы отображены при отмене этого режима. 

Настроить формат блока можно при помощи команды Format → Box 
styles…, а указать, какие данные должны отображаться в блоке, — при помощи 
команды Format → Box styles… → More Templates…, а когда её возможно-
стей оказывается недостаточно, — Format → Box styles… → More Tem-
plates… → New… или Format → Box styles… → More Templates… → Edit…. 
Изучить возможности этих команд можно самостоятельно, пробуя вносить из-
менения в вызываемые ими диалоговые окна, либо обратиться к рекомендуемой 
литературе. 

Диалоговое окно Layout, вызываемое командой Format → Layout…, 
предоставляет и многие другие способы добиться желаемой выдачи графика 
PERT. Вы можете исследовать их действие во время самостоятельной работы с 
программой. Например, иногда полезно установить переключатель Link Style в 
положение Straight, чтобы стрелки не накладывались одна на другую. Опция 
Adjust for page breaks сдвигает блоки, соответствующие работам, таким обра-
зом, чтобы при печати один блок не оказывался на разных листах. 

При отображении на экране графика PERT можно (хотя это и не очень 
удобно) вносить изменения в данные о работах. Перемещая мышь при нажатой 
левой кнопке от одного блока к другому, можно установить новую связь между 
соответствующими работами; нарисовав мышью прямоугольник в любой сво-
бодной области — создать новую работу; дважды щёлкнув на блоке работы — 
вызвать диалоговое окно Task Information, чтобы изменить отображаемые в 
нём данные; пользуясь псевдокнопками  и  на панели инструментов For-
matting — управлять иерархическим упорядочением работ. 

 
Таблица работ, отображаемая командой View → Gantt Chart с после-

дующим скрытием графика Ганта, допускает различные формы  отображе-
ния. Из них до сих пор мы пользовались двумя: стандартной (View → Table → 
Entry) и используемой для целей мониторинга (View → Table → Tracking). 
Помимо них, часто используются следующие формы: 

♦ для анализа затрат (View → Table → Cost); 
♦ для сведений о запасе времени (View → Table → Schedule); 
♦ для вывода общих сведений о состоянии работ (View → Table → 

Summary); 
♦ для информации о совокупном объёме ресурсозатрат (View → Table 

→ Usage); 
♦ для анализа расхождений между запланированными и фактическими 

сроками выполнения работ (View → Table → Variance); 
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♦ для анализа расхождений между запланированными и фактическими 
объёмами работ (View → Table → Work); 

♦ а также многие другие (View → Table → More Tables…). 
Назначение столбцов, имеющихся в вышеперечисленных формах, пояс-

няется в приложении 1. 
Менеджер проекта может сам создать форму  отображения  таблицы  

работ , соответствующую стоящим перед ним задачам, указав, какие столбцы 
должны в ней присутствовать. Для этого используется команда View → Table 
→ More Tables… → New…, вызывающая диалоговое окно Table Definition. 

 

 
Рис. 6. Диалоговое окно Table Definition. 

 
Каждому столбцу создаваемой формы соответствует одна строка её опи-

сания в диалоговом окне. Вид окна с пояснением назначений его управляющих 
элементов приведён на рис. 6. 

В колонке Field Name диалогового окна Table Definition указываются 
(путём выбора из выпадающего списка) системные имена столбцов таблицы 
работ1, которые должны отображаться в данной форме её представления. 
В колонках Align Data и Width определяется формат отображения данных в 
создаваемой форме представления. В колонке Title указываются заголовки 

                                           
1 Системные имена наиболее употребительных столбцов таблицы работ вместе с 

описанием их назначения приведены в приложениях 1 и 2. Описания остальных столбцов 
можно найти в справочной системе программы Microsoft Project. 
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столбцов, которые будут использованы при отображении данной формы на эк-
ране и при выводе её на печать. Здесь при необходимости можно дать столбцам 
заголовки на русском языке. 

То же диалоговое окно используется для внесения изменений в опреде-
ления существующих форм (View → Table → More Tables → [выбрать требуе-
мую таблицу из списка Tables] → Edit). Прежде чем самостоятельно создавать 
новые формы, рекомендуем ознакомиться с описаниями уже имеющихся. 

Двойным щелчком левой кнопкой мыши на области заголовка столбца 
при отображении таблицы работ вызывается диалоговое окно Column Defini-
tion, в котором можно изменить формат данного столбца. Пользуясь поясне-
ниями к диалоговому окну Table Definition, не составит труда разобраться с 
окном Column Definition самостоятельно во время лабораторного практикума. 

Формат  отображения  данных  устанавливается путём настройки со-
ответствующих стилей текста. Команда Format → Text styles… вызывает од-
ноимённое диалоговое окно, в котором можно выбрать требуемый стиль из вы-
падающего списка Item to change:, после чего установить параметры формати-
рования — шрифт, начертание, размер, цвет, подчёркивание. Если выбрать ва-
риант All, вносимые изменения повлияют на все стили. Например, если в этом 
режиме выбрать шрифт Courier New, то для всех стилей будет использован 
именно этот шрифт, в то время как ранее установленные для стилей размер, на-
чертание (полужирный, курсив), подчёркивание и цвет останутся неизменными. 
К таблице работ относятся следующие стили. 
Row and column titles — стиль, используемый для заголовков строк и 

столбцов. 
Highlighted tasks — стиль, используемый для выделения строк, соот-

ветствующих заданному критерию отбора (об 
операции отбора см. с. 69). 

Marked tasks — стиль для строк, содержащих значение Yes в 
столбце Marked. 

Summary tasks — стиль для строк, соответствующих составным ра-
ботам. 

Milestone tasks — стиль для  строк, соответствующих событиям1. 

                                           
1 Под событием в Microsoft Project понимается работа, помеченная значением Yes в 

столбце Milestone. Если пользователь присваивает работе нулевую продолжительность, про-
грамма автоматически помечает её как событие. События используются для наглядного ото-
бражения значимых моментов в процессе реализации проекта: например, «заключены все 
контракты», «подписано соглашение о финансировании», «закончены строительно-
монтажные работы». 
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Critical tasks — стиль для строк, соответствующих критическим 
работам. 

Noncritical tasks — стиль для оформления строк, не имеющих ни од-
ного из вышеперечисленных атрибутов. 

Конфликты стилей (например, ситуации, когда критическая работа ото-
брана по заданному пользователем критерию) разрешаются в том же порядке, в 
котором они здесь перечислены: стили, расположенные выше, доминируют над 
нижеследующими. 

Для отдельной ячейки или выделенной группы ячеек можно установить 
параметры форматирования, отличающиеся от предусмотренных стилем, дав 
команду Format → Font…. 

Чтобы установить ширину  столбца, достаточно перетащить мышью 
его правую границу в области заголовков столбцов. Аналогичным образом — 
перетаскиванием нижней границы в области номеров строк — при необходи-
мости можно изменить ширину строки. Это полезно в тех случаях, когда на эк-
ране или при выводе на печать данные некоторых столбцов не умещаются в 
ячейках. 

Чтобы изменить взаимное расположение  столбцов, необходимо 
сначала выделить требуемый столбец, щёлкнув мышью на его заголовке, а за-
тем перетащить его за заголовок на требуемое место. 

Формат  даты  и времени , используемый по умолчанию, устанавлива-
ется выбором подходящего образца в выпадающем списке Tools → Options… 
→ View → Date format. Если для формы отображения таблицы работ, пред-
ставленной на экране, требуется формат даты, отличающийся от принятого по 
умолчанию, его можно выбрать в выпадающем списке View → Table → More 
Tables… → Edit… → Date format:. Возможность задания разных форматов да-
ты и времени для столбцов одной и той же формы отображения авторами про-
граммы не предусмотрена. 

Чтобы скрыть/показать работы , входящие в состав  составной  
работы , следует выделить её и нажать псевдокнопку [–] (Hide Subtasks) или 
[+] (Show Subtasks) на панели инструментов Formatting или в ячейке таблицы 
работ, содержащей наименование составной работы. 

З а м е ч а н и е .  Будьте внимательны! При выводе таблицы работ 
на печать те работы, которые не отображаются в текущем представлении 
таблицы работ на экране, не будут представлены и на распечатанном до-
кументе. Перед началом печати проверьте, не скрыты ли строки, которые 
необходимо вывести на печать. 
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Таблица ресурсов, отображаемая командой View → Resource Sheet, 
имеет следующие формы отображения: 

♦ для ввода данных о работах (View → Table → Entry); 
♦ для отображения сведений о загруженности ресурсов согласно опера-

тивному плану (View → Table → Summary); 
♦ для анализа затрат (View → Table → Cost); 
♦ для анализа использования ресурсов в сравнении с оперативным и со-

гласованным вариантами плана (View → Table → Work). 

З а м е ч а н и е .  Обратите внимание, что набор пунктов меню 
View → Table при отображении таблицы работ и таблицы ресурсов раз-
личен. 

Сведения о столбцах таблицы ресурсов, отображаемых в этих формах 
представления, приведены в приложении 3. 

Все приёмы управления отображением таблицы работ, рассмотренные 
выше, — определение набора отображаемых столбцов, форматирование 
и др. — применимы и к таблице ресурсов, за исключением, разумеется, управ-
ления отображением иерархии работ. Стилей текста, применимых к таблице ра-
бот, всего три: 
Highlighted resources — стиль, используемый для выделения строк, соот-

ветствующих заданному критерию отбора (об 
операции отбора см. с. 69); 

Overallocated resources — стиль оформления строк, соответствующих ре-
сурсам, использование которых в какие-то пе-
риоды времени запланировано в объёме, превы-
шающем наличие. 

Allocated resources — стиль оформления остальных строк. 
Стили перечислены в порядке снижающегося приоритета их примене-

ния. Для оформления заголовков строк и столбцов, как и в таблице работ, ис-
пользуется стиль Row and column titles. Несмотря на одинаковые названия, 
стили оформления заголовков строк и столбцов в таблице работ и таблице ре-
сурсов разные и могут быть определены независимо друг от друга. 

 
Распределительная таблица может быть отображена в двух формах: в 

разрезе работ (View → Task Usage) и ресурсов (View → Resource Usage). Пер-
вая форма представляет собой таблицу работ, дополненную строками, характе-
ризующими ресурсы, назначенные на каждую работу. Вторая — таблицу ресур-
сов, дополненную строками, характеризующими работы, на которые назначен 
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ресурс1. Именно в этих дополнительных строках — будем называть их 
строками распределения ресурсов — отображаются данные распределительной 
таблицы, в то время как остальные строки содержат данные таблицы работ (в 
первой форме) или ресурсов (во второй). 

Окно Microsoft Project при этом разделяется по вертикали на две поло-
вины: в левой отображаются столбцы таблицы работ (в первом случае) или ре-
сурсов (во втором), в правой — сведения об использовании ресурсов на каждой 
работе в каждый период времени. Масштаб оси времени устанавливается поль-
зователем. Как это делать — рассказывается ниже (с. 63).  

Данные о распределении ресурсов между работами отображаются в ле-
вой половине окна. Её представление управляется теми же способами, как и 
представление таблицы работ или ресурсов: можно выбрать форму отображе-
ния таблицы, добавить или удалить столбцы, определить стили текста, изме-
нить ширину строк и столбцов, отобразить или скрыть работы, входящие в со-
ставную работу. Кроме того, в обеих формах псевдокнопки структуры [–] и [+] 
используются для скрытия/отображения строк распределения ресурсов. 

Стили текста в формах отображения распределительной таблицы имеют 
те же наименования и назначение, что и в таблице работ (первая форма) или ре-
сурсов (вторая), но назначаются независимо от них. Для оформления строк рас-
пределения ресурсов предназначен стиль Assignment Row. 

В правой половине окна отображается таблица, характеризующая ис-
пользование ресурсов на каждой работе в течение срока выполнения проекта. 
Столбцы её соответствуют периодам времени (обычно дням), а каждой строке 
из левой половины ставится в соответствие одна или более строк, которые мо-
гут содержать данные, характеризующие использование ресурса на отдельной 
работе в конкретный период времени. Наиболее употребительные из них: 
Work — затраты ресурсо-часов по оперативному плану; 
Baseline Work — затраты ресурсо-часов по согласованному плану; 
Actual Work — фактическе затраты ресурсо-часов; 
Cumulative Work — затраты ресурсо-часов по оперативному плану 

нарастающим итогом; 
Cost, Baseline Cost, Actual Cost — затраты, связанные с использованием дан-

ного ресурса на данной работе (по оперативному, 
согласованному плану и фактические); 

                                           
1 Работы, на которые никаких ресурсов не назначено, в этой форме тоже отобража-

ются. Вместо наименования используемого ресурса для них указывается Unassigned (то 
есть «ничего не назначено»). 
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Percent Allocation — использование ресурса (по оперативному плану) 
в данный период времени в процентах к нали-
чию; 

Overallocation — превышение использования ресурса над наличи-
ем1; 

Remaining Availability — неиспользованный остаток рабочего времени ре-
сурса1; 

Overtime Work — запланированный объём сверхурочной работы, 
оплачиваемой по тарифу, указанному в столбце 
Ovt. Rate таблицы ресурсов. 

Actual Overtime Work — фактически выполненный объём сверхурочной 
работы, оплачиваемой по тарифу, указанному в 
столбце Ovt. Rate таблицы ресурсов. 

З а м е ч а н и е .  Данные строки Overtime Work в правой части 
окна не могут быть изменены вводом в её ячейки новых данных. Плани-
ровать объёмы сверхурочных работ следует, добавив столбец Overtime 
Work в распределительную таблицу (расположенную в левой половине 
окна). Объём сверхурочных работ, указанный в этом столбце, распреде-
ляется во времени пропорционально общему объёму работ соответст-
вующего ресурса. 

По умолчанию в правой части окна отображаются только данные о за-
тратах ресурсо-часов по оперативному плану. Добавить другие показатели 
можно командой Format → Details → [выбрать имя требуемого показателя]. 
Если требуемый показатель в этом меню отсутствует, воспользуйтесь командой 
Format → Detail Styles…, выберите его в поле Available Fields:, затем нажмите 
псевдокнопки Show >> и OK. 

Обратная операция (убрать ненужные показатели из правой части окна): 
Format → Detail Styles…, выбрать в списке Show these fields: требуемые име-
на, затем нажать псевдокнопки << Hide и OK. 

Кроме того, диалоговое окно Detail Styles, отображаемое командой 
Format → Detail Styles…, позволяет установить форматы отображения (вклю-
чая фон) каждого элемента данных индивидуально, что делает таблицу исполь-
зования ресурсов более наглядной. 

Элементы All resource rows, All task rows и All assign-
ment rows списков Show this field: и Available fields: содержат форматы для 

                                           
1 Эти показатели целесообразно использовать только в форме View → Resource Us-

age. В строках, соответствующих отдельным работам, значение соответствующих ячеек не 
определено. 
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строк ресурсов, работ и распределения ресурсов соответственно. Если они ука-
заны в списке Show these fields:, то с их помощью оформляются все строки, от-
носящиеся к данным из соответствующей таблицы, независимо от того, какой 
формат назначен для конкретного показателя. 

Изменение форматов в форме Task Usage не влияет на отображение 
формы Resource Usage, и наоборот. 

Простейший способ выбрать период  времени , в разрезе которого ха-
рактеризуется использование ресурса — использовать псевдокнопки  (Zoom 
In) и  (Zoom Out) на панели инструментов Standard. Каждое нажатие на 
первую из них приводит к разбивке оси времени на всё более короткие перио-
ды; на вторую — наоборот. Если результаты вас не удовлетворяют (например, 
вы хотите получить данные в разрезе декад), вам придётся воспользоваться ко-
мандой Format → Timescale…. Её возможности вы можете изучить самостоя-
тельно, привлекая при необходимости справочную систему программы Micro-
soft Project и рекомендуемую литературу. 

З а м е ч а н и е .  При использовании формы Task Usage полезно 
включить режим отображения сводной информации по всему проекту в 
виде составной работы. Для этого дайте команду Tools → Options… → 
View → Show project summary task. 

 
Столбцы, определяемые пользователем, могут использоваться не только 

в таблицах работ и ресурсов, но и для отображения соответствующих им гра-
фических элементов — например, на графике Ганта. Потребность в них возни-
кает, если менеджеру требуется отобразить данные, не предусмотренные разра-
ботчиками программы Microsoft Project. 

К числу столбцов, определяемых пользователем, относятся Text1…Text30 (для 
текстовых значений), Number1…Number20 (для числовых), Flag1…Flag20 
(для логических), Date1…Date10, Start1…Start10, Finish1…Finish10 (для дат), 
Duration1…Duration10 (для продолжительностей), Cost1…Cost10 (для денеж-
ных значений). Любому из них может быть назначено другое имя, соответст-
вующее находящимся в нём данным. 
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Рис. 7. Диалоговое окно Customize Fields. 

 
Какие данные будут находиться в этих столбцах — определяет пользо-

ватель, используя для этого диалоговое окно Customize Fields (рис. 7). Оно вы-
зывается командой Tools → Customize → Fields… 

Данные столбцов, определяемых пользователем, могут: 
♦ вводиться менеджером с клавиатуры; 
♦ выбираться из выпадающего списка; 
♦ вычисляться по заданной менеджером формуле, использующей в ка-

честве исходных данные как стандартных столбцов, так и других столбцов, оп-
ределяемых пользователем, при условии, что исходные столбцы относятся к 
той же таблице (работ либо ресурсов). 

В приложении 5 приведён список наиболее употребительных операторов 
и функций, которые могут использоваться в таких формулах. Их аргументами 
могут быть константы (числовые, строковые, даты, продолжительности) или 
системные имена столбцов — в том числе и определяемых пользователем.  

В столбцах, определяемых пользователем, данные ячеек, соответствую-
щих составным работам или, при использовании операций группировки, харак-
теризующих итоги по группам (см. с. 69), могут определяться по одному из 



65 

трёх способов, устанавливаемых переключателем Calculation for task and 
group summary rows: 

♦ None — вообще не вычисляться автоматически (допуская ручной 
ввод); 

♦ Rollup — определяться с использованием заданной операции сводки 
показателей данного столбца, определяемого пользователем, по работам, вхо-
дящим в составную работу или в данную группу — например, может рассчиты-
ваться сумма (Sum), арифметическое среднее (Average), выбираться макси-
мальное значение (Maximum); 

♦ Use formula — рассчитываться по той же формуле, как и для осталь-
ных строк, основываясь на данных текущей строки. 

Имеется возможность отображения данных посредством пиктограмм, 
назначаемых тем или иным интервалам данных. Числовое значение в этом слу-
чае можно посмотреть во всплывающей подсказке, наведя курсор мыши на 
пиктограмму. 

 
График Ганта по умолчанию может выводиться в одной из двух форм: 

View → Gantt Chart — для целей планирования либо View → Tracking 
Gantt — для мониторинга. Вторая отличается от первой тем, что на ней графи-
чески представлены данные о степени завершённости каждой работы и об от-
клонениях от согласованного варианта плана. Последние отображаются, разу-
меется, лишь в случае, если согласованный план сохранён в соответствующих 
столбцах таблицы работ. Обе формы могут быть дополнены отображением лю-
бых данных, содержащихся в таблице работ: календарная информация может 
быть представлена в виде полос, остальная — выведена в форме подписей к по-
лосам. 
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Рис. 8. Диалоговое окно Bar Styles. 

 
На рис. 8 представлено диалоговое окно Bar Styles, выдаваемое коман-

дой Format → Bar Styles… в режиме графика Ганта. Используя его средства, 
можно определить новую полосу для отображения тех или иных данных: 

♦ в колонке Name присвоить полосе наименование; 
♦ в колонке Show For … Tasks указать, для каких работ следует ото-

бражать данную полосу (см. приложение 6); 
♦ в колонке Row указать, какой по счёту сверху будет данная полоса 

для данной работы при отображении на графике Ганта; 
♦ в колонках From и To указать столбцы таблицы работ, в которых со-

держатся даты, определяющие начало и конец полосы. 
Далее следует настроить внешний вид полосы, используя ярлычок Bars 

в нижней половине диалогового окна. Результат настройки отобразится в ко-
лонке Appearance. Завершает определение полосы указание текстовых данных, 
которые должны выводиться рядом с полосой. Для этого используется ярлычок 
Text. Предлагаем вам самостоятельно исследовать возможности, предоставляе-
мые обоими ярлычками. 

Имеется возможность настроить внешний вид каждой полосы, отобра-
жаемой на графике, индивидуально. Для этого используется команда контекст-
ного меню Format Bar…. 
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Другие возможности настройки внешнего вида графика Ганта обеспечи-
ваются командами: 

♦ Format → Text Styles… — внешний вид шрифтов для различных 
элементов текста, в том числе для данных, выводимых рядом с полосами гра-
фика Ганта; 

♦ Format → Timescale… — настройка шкалы времени; 
♦ Format → Gridlines… — настройка линий разграфки; 
♦ Format → Layout… — общие настройки графика Ганта. 
Из этих команд некоторые были рассмотрены выше, с остальными вам 

не составит труда разобраться самостоятельно. 

З а м е ч а н и е .  Широкие возможности управления отображением 
графика Ганта предоставляют средства сортировки (упорядочения), груп-
пировки и фильтрации (отбора) работ. Эти средства будут рассмотрены 
ниже отдельно, поскольку они применимы и при использовании других 
форм представления данных о проекте. 

 
Календарь допускает весьма ограниченные возможности управления 

отображением. Здесь можно управлять: 
♦ шириной строк — псевдокнопки  и  (не влияют на распечатку: 

ширина строк меняется только на экране); 
♦ отображением суббот и воскресений: Format → Timescale… → Week 

headings → 7 days/5 days; 
♦ заливкой рабочих и нерабочих дней согласно календарям проекта или 

используемых ресурсов: Format → Timescale… → Date shading, далее предла-
гаем разобраться самостоятельно; 

♦ форматом текста: Format → Text Styles…; 
♦ оформлением полос, представляющих работы: Format → Bar 

Styles…, в том числе данными из таблицы работ, отображаемыми на каждой 
полосе. 

Данные каких столбцов таблицы работ следует отображать на календа-
ре — пользователь указывает в поле Fields: диалогового окна Bar Styles в фор-
ме имён требуемых столбцов, перечисляемых через точку с запятой (в русских 
версиях Windows) или через запятую (в английских). Имена столбцов можно 
посмотреть в выпадающем списке, связанном с текстовым полем. При необхо-
димости можно заставить программу размещать не умещающиеся данные более 
чем в одной строке: для этого служит переключатель Wrap text in bars. 

Если ширина строк на экране не достаточна для того, чтобы уместить 
все работы, выполняемые одновременно, полный список работ, выполняемых 
за определённую дату, можно отобразить двойным щелчком на дате. 
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З а м е ч а н и е .  Во многих случаях при печати бывает целесооб-
разно отменить заливку, используемую по умолчанию. Это экономит то-
нер, делает распечатки более пригодными к тиражированию и улучшает 
их внешний вид. 

 
График загруженности ресурса (View → Resource Graph) наглядно ото-

бражает распределение использования ресурсов во времени. 
Очевидно, что теоретический максимум производительности ресурсов 

достигается тогда, когда они все используются полностью в течение всего срока 
их эксплуатации. Этот идеал на практике недостижим. Однако периоды, когда 
ресурсы недоиспользуются, должны быть предметом столь же пристального 
внимания менеджера, как и периоды дефицита ресурсов: ведь здесь могут 
скрываться резервы сокращения продолжительности инвестиционной фазы 
проекта. Эту задачу удобно решать с помощью графика загруженности ресурса. 

Этот график представляет собой диаграмму, на которой использование 
выбранного ресурса в каждый период времени представлено в форме столбцов, 
высота которых определяется наибольшим количеством единиц ресурса, одно-
временно используемых в течение данного периода. По оси абсцисс откладыва-
ется время в масштабе, удобном для менеджера, а по оси ординат — количество 
единиц ресурса. Выбор требуемого ресурса производится клавишами [PgUp] и 
[PgDn] или с помощью полосы прокрутки. Ресурсы следуют в порядке возрас-
тания их номеров в таблице ресурсов, если не задано другое правило упорядо-
чения (с.70). Для ускорения поиска можно использовать фильтры (с.69). 

Наилучших результатов в управлении ресурсами можно достичь, ис-
пользуя график загруженности ресурса совместно с графиком Ганта для тех ра-
бот, которые используют данный ресурс. Для этого из контекстного меню для 
области графика выбирают команду Split, после чего активизируют нижнюю 
половину экрана (где теперь появилась форма ввода данных о ресурсе) щёлч-
ком мыши и дают команду View → Gantt Chart. 

Управление представлением данного графика, помимо выбора масштаба 
времени и требуемого ресурса, включает выбор отображаемого показателя. По 
умолчанию отображается, как уже было сказано, количество единиц ресурса, 
используемых одновременно в течение единицы времени. Кроме того, можно 
отобразить объём работ в ресурсо-часах (Format → Details → Work), количе-
ство простаивающих единиц ресурса  (Format → Details → Remaining Avail-
ability), затраты (Format → Details → Cost), затраты накопленным итогом 
(Format → Details → Cumulative Cost) и ещё ряд показателей. Возможность 
представления более одного показателя или данных более чем по одному ре-
сурсу на одном графике отсутствует. 
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Средства управления форматом текста, столбцов диаграммы и линий 
разграфки отличаются от своих аналогов в ранее рассмотренных формах пред-
ставления лишь в деталях. 

 
Фильтры, упорядочение и группировка могут использоваться при ис-

пользовании всех вышерассмотренных форм представления данных. Эти сред-
ства позволяют расположить работы (ресурсы) в желаемой логической после-
довательности и сосредоточить внимание на тех из них, которые имеют наи-
большее значение для решения возникшей управленческой задачи. 

Например, может оказаться удобным расположить ресурсы: 
♦ для целей поиска резервов сокращения затрат или анализа причин пе-

рерасхода — по убыванию величины начисленных затрат; 
♦ для того, чтобы сосредоточить внимание на наиболее перегруженных 

ресурсах — по объёму (в ресурсо-часах) работ, который осталось выполнить до 
завершения проекта, в расчёте на единицу ресурса; 

♦ для быстрого поиска сведений о нужном ресурсе по его наименова-
нию — в алфавитном порядке. 

В целях расчёта сводных показателей ресурсы можно сгруппировать: 
♦ для анализа структуры издержек — объединить в одну группу работ-

ников, в другую — оборудование, в третью — помещения и объекты инфра-
структуры; 

♦ для оценки способов привлечения ресурсов — сгруппировать их по 
источникам (собственные, арендованные). 

В процессе согласования использования ресурсов удобно, применив 
фильтр, отобрать лишь те из них, которые в те или иные периоды времени ока-
зываются в дефиците. 

Аналогичные мотивы могут возникать и в отношении работ. 
Простейший способ применения  фильтра — выбор имени требуемого 

фильтра из выпадающего списка Filter на панели инструментов Formatting. 
В зависимости от критерия отбора фильтр срабатывает сразу после выбора его 
имени либо предварительно запрашивает дополнительную информацию, выда-
вая соответствующее диалоговое окно. Список наиболее полезных фильтров 
приведён в приложении 7. 

Другая удобная возможность применима только к табличным формам 
представления данных. Это автофильтр, включаемый (и выключаемый) ко-
мандой Project → Filtered For: → AutoFilter или псевдокнопкой  панели 
инструментов Formatting. Используется он подобно автофильтру в Microsoft 
Excel: 
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♦ при его включении в заголовке каждого столбца таблицы появляется 
псевдокнопка ; 

♦ нажатием на неё вызывается список тех значений показателя, отобра-
жаемого в данном столбце, по которым может выполняться отбор записей; 

♦ пункт All в этом списке означает отмену фильтра по данному столб-
цу; 

♦ пункт Custom вызывает диалоговое окно Custom AutoFilter, которое 
позволяет сформулировать условие на значения с использованием шаблонов 
(для текста) и операций сравнения. 

В столбцах, по которым фильтр задан, псевдокнопка  меняет цвет. 
Список условий, которые могут использоваться в диалоговом окне Custom 
AutoFilter, также приведён в приложении 7. 

Собственный фильтр можно определить и с помощью команды Project 
→ Filtered For: → More Filters… → New…; но мы эту возможность подробно 
рассматривать не будем: при необходимости формулирования сложных крите-
риев поиска хороший стиль работы в Microsoft Project состоит в том, чтобы 
производить соответствующие логические операции в столбцах, определяемых 
пользователем (Flag1…Flag20), а потом использовать значения этих столбцов 
для фильтрации с помощью обыкновенного автофильтра. 

Упорядочение  (сортировка, ранжирование) производится командой 
Project → Sort → [имя столбца (ключа), по которому производится упорядоче-
ние]. Если требуется упорядочить строки по столбцу, имя которого не пред-
ставлено в списке, воспользуйтесь командой Project → Sort → Sort by…, вы-
зывающей диалоговое окно, изображённое на рис. 9. Здесь можно указать в ка-
честве ключа любой столбец таблицы работ или ресурсов, смотря по тому, ка-
кая из них в данный момент активна, — в том числе и не включённый в теку-
щую форму её отображения. 

При необходимости можно использовать до трёх ключей одновременно. 
Если значения первого одинаковы, упорядочение производится по второму 
ключу, а если во втором они тоже не различаются — то по третьему. 
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Рис. 9. Диалоговое окно Sort. 

Переключатель Keep outline structure появляется только при упорядо-
чении таблицы работ либо распределительной таблицы, сгруппированной по 
работам. Если он установлен, упорядочиваться будут только подработы в пре-
делах составных работ. В противном случае иерархия работ не будет сохранена, 
и вплоть до отмены назначенного правила упорядочения не будет возможности 
скрывать и отображать содержание составных работ. 

Группировка  позволяет получить сводные значения показателей, ха-
рактеризующих проект, по определённым пользователем группам работ или ре-
сурсов. 

Простейший способ использования группировки — выбор имени прави-
ла группировки из списка Group By на стандартной панели инструментов. 
Наиболее употребительные из этих правил прокомментированы в приложе-
нии 7. Если возможностей списка Group By недостаточно, следует воспользо-
ваться командой Project → Group by: → Customize Group By…, вызывающей 
одноимённое диалоговое окно, представленное на рис. 10. С его помощью 
можно выполнить группировку, в том числе многоуровневую (до четырёх 
уровней вложенности групп) по любым признакам, в том числе и по столбцам, 
определяемым пользователем. 
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Рис. 10. Диалоговые окна Customize Group By и Define Group Interval 
 
Если группировочный признак текстовый или логический, то группи-

ровка производится по каждому значению в отдельности1. Для числовых дан-
ных, дат и продолжительностей, помимо группировки по каждому значению 
(которая в этом случае редко имеет смысл), можно задавать интервальную 
группировку с помощью диалогового окна Define Group Interval, вызываемого 
одноимённой псевдокнопкой окна Customize Group By. 

Для процентных значений можно использовать предопределённые гра-
ницы групп, устанавливаемые в поле Group on:. Пример предопределённых 
границ приведён на рис. 10. Другой способ группировки, применимый для лю-
бых числовых значений, — интервалы равной ширины. Для этого в поле Group 
on: следует выбрать Interval, в нижеследующих полях указать нижнюю (или 
верхнюю, если выбрано упорядочение по убыванию) границу первой группы и 
ширину интервала. 

                                           
1 Текстовые значения допускают также группировку по 1…4 первым символам. Для 

этого в поле Group on: диалогового окна Define Group Interval выбирают Prefix Char-
acters, а в поле Group interval: указывают требуемое количество символов. 
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Для дат и продолжительностей используются только интервалы равной 
длительности. В этом случае менеджер должен указать подходящую единицу 
измерения длительности, выбрав её в поле Group on.  

В результате группировки в таблице работ или ресурсов появляются 
строки, содержащие сводные данные по всей группе — например, продолжи-
тельность работ группы от начала самой ранней из них до завершения самой 
поздней, общее количество отработанных ресурсо-часов, совокупные затраты, 
процент завершённости всей совокупности работ. Используя значки [+] или [–], 
отображаемые у названия группы в строке сводных данных по группе, можно 
скрывать или отображать данные по каждой из работ (ресурсов) группы. 

З а м е ч а н и е .  При выводе на печать скрытые данные не будут 
отображаться. Поэтому при использовании группировки, приступая к вы-
воду документа на печать, рекомендуется проверить, не скрыты ли те 
данные, которые должны присутствовать на распечатке. 

 
Microsoft Project позволяет создавать отчёты, не основанные на вышепе-

речисленных формах представления данных. Соответствующие средства дос-
тупны по команде меню View → Reports…. Она предоставляет возможность 
доступа к 22 стандартным формам отчётов и возможности их модификации. 
Более подробное её рассмотрение не входит в наши задачи. Команда View 
�Reports… → Custom… → Select → New… позволяет менеджеру создавать 
другие отчёты. Когда её возможностей оказывается недостаточно, менеджер 
обращается к помощи программиста, который разрабатывает программу фор-
мирования требуемого отчёта на языке программирования VBA, встроенном в 
Microsoft Project. 

 
Управление печатью производится при помощи диалогового окна Page 

Setup, вызываемого командой File → Page Setup…. Управляющие элементы 
этого окна кратко прокомментированы в приложении 8. 

При печати документа следует принимать во внимание, что таблицы и 
графики, создаваемые программой, зачастую нельзя разместить на одном листе, 
поэтому особое внимание следует уделить выбору подходящего масштаба пе-
чати и режимам, обеспечивающим печать для последующего склеивания лис-
тов. Если используется чёрно-белый принтер, целесообразно заранее подгото-
вить цветовую схему оформления, при которой все детали цветового оформле-
ния достаточно хорошо воспринимаются на распечатанном документе. Для 
достижения необходимого уровня контрастности могут потребоваться специ-
альные настройки драйвера принтера. Соответствующие рекомендации можно 
найти в руководстве пользователя принтера. 
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Контрольные вопросы 

1. Как уместить распечатку графика PERT на возможно меньшем числе листов? 
2. Перечислите известные вам стили, используемые для оформления таблицы 
работ. 

3. Какие способы видоизменения таблицы ресурсов вам известны? 
4. Как изменить набор сведений, отображаемых комбинационной таблицей? 
5. Для чего используется стиль Assignment Row? 
6. Предложите формулу, которая в столбце Text1 таблицы работ выдавала бы 
текст следующего вида: «Работа не началась»; «До завершения работы оста-
лось X дней», где X — число оставшихся дней до завершения работы исходя 
из степени её фактической завершённости, или «Работа завершена». 

7. Каковы правила определения значений столбцов, определяемых пользовате-
лем, для составных работ? 

8. Как присвоить имя столбцу, определяемому пользователем? 
9. Как упорядочить ресурсы в таблице ресурсов в порядке уменьшения стоимо-
сти их использования? 

10.Как расположить работы на графике Ганта в порядке сокращения их дли-
тельности? 

11.Как отобразить текстовые данные на графике Ганта? 
12.Как отобразить на экране только те строки таблицы работ, которые соответ-
ствуют критическим работам? 

13.Как отобразить график Ганта только для работ, использующих два заданных 
вида ресурсов? 

14.Как определить, когда заканчивается последняя из уже начавшихся работ? 
Предложите по крайней мере два способа. 

15. Как определить суммарные затраты ресурсо-часов выбранного ресурса по 
критическим и некритическим работам? 

16.Как при использовании графика загруженности ресурса выяснить, на каких 
работах задействован данный ресурс? 

9. Начальные сведения о коллективном управлении 
проектами 

Потребность в коллективном управлении проектами. Проблемы взаимодействия ме-
неджеров проекта. Технологические средства поддержки взаимодействия менеджеров: под-
проекты и ресурсные пулы. Начальные сведения о серверах проектов. 

Нужно ли применять технологию PERT и как организовать её примене-
ние — зависит от сложности проектов, выполняемых организацией. 
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Положим, организация выполняет ограниченное количество небольших 
проектов, в которых: 

♦ число работ при самом детальном их представлении в совокупности 
не превышает нескольких сотен; 

♦ на самых сложных этапах не более десятка могут выполняться парал-
лельно; 

♦ номенклатура ресурсов также не превышает одного десятка; 
♦ различные проекты, как правило, не конкурируют за одни и те же ре-

сурсы. 
Тогда обычно не возникает необходимости применения технологии 

PERT. Её использование и в этом случае может сократить сроки выполнения 
проектов, повысить эффективность использования ресурсов. Но формирование 
всех её обеспечивающих подсистем потребует затрат, которые едва ли окупят-
ся. 

Рассматривать вопрос о внедрении технологии PERT приходится тогда, 
когда хотя бы одно из перечисленных условий не выполняется. Но и в этом 
случае решение об её использовании не обязательно будет положительным. 

Если применение технологии PERT оправданно, то, пока общее число 
параллельных работ на всех выполняемых проектах остаётся в пределах одной-
двух сотен, все решения по управлению работами и ресурсами может с её по-
мощью принимать один менеджер. В его распоряжении при необходимости 
должно быть достаточное количество вспомогательного персонала, которому 
можно поручить рутинные операции: ввод данных, контроль корректности вво-
да, мониторинг проектов, подготовку документов по заданным формам. В этом 
случае положительный эффект информационной технологии управления про-
ектами оказывается тем больше, чем сложнее область проектной деятельности, 
чем больше решений в единицу времени приходится принимать менеджеру. 

Но наибольшую пользу технология PERT приносит тогда, когда она 
применяется либо в очень крупных организациях, выполняющих одновременно 
множество различных проектов, либо на фирмах, специализирующихся на пре-
доставлении услуг по управлению проектами. Такие фирмы могут управлять 
одновременно сотнями различных проектов. Среди этих проектов могут ока-
заться очень сложные и предъявляющие жёсткие требования по срокам выпол-
нения. Управляя ими, приходится согласовывать использование многих сотен и 
даже тысяч наименований ресурсов. 

Чем масштабнее деятельность подобной фирмы, тем больше оказывают-
ся возможности достижения наиболее полной загрузки ресурсов, тем меньше 
задержек из-за их недостатка и тем выше заинтересованность клиентов в при-
обретении её услуг. 
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При таком уровне специализации один менеджер уже не в состоянии 
обеспечить принятие управленческих решений с должным качеством. Управле-
нием проектами занимается целая группа. Как правило, один менеджер контро-
лирует группу родственных проектов, возможно более близких по номенклату-
ре используемых ресурсов, либо один большой проект, либо одну составную 
работу проекта, реализуемого в масштабах региона или национальной эконо-
мики. В связи с этим возникает необходимость согласования использования ре-
сурсов между проектами, управляемыми разными менеджерами, а технология 
PERT требует расширения инструментальными средствами, упрощающими со-
гласование. 

Программа Microsoft Project поддерживает три способа взаимодействия 
между менеджерами: 

♦ подпроекты; 
♦ ресурсные пулы; 
♦ серверы проектов. 
Выбор одного из них зависит от сложности решаемых задач, обуслов-

ленной, в свою очередь, тем, насколько поддаются упорядочению взаимозави-
симости совместно выполняемых проектов. 

 
Подпроекты используются самостоятельно либо в сочетании с двумя ос-

тальными способами. Условие использования подпроектов без обращения к ре-
сурсным пулам либо серверу проектов следующее: можно выделить группы ра-
бот, использующих непересекающиеся подмножества ресурсов1. 

Пример подобной ситуации — управление несколькими небольшими 
однородными проектами, которые выполняются силами фирм-заказчиков услуг 
по управлению проектами и требуют надзора со стороны специалистов опреде-
лённого профиля (инженеров, юристов, врачей и т.д.) на протяжении всего хода 
их выполнения. Обеспечение услугами по надзору берёт на себя организация, 
управляющая совокупностью проектов. В этом случае перераспределение ре-
сурсов между фирмами-заказчиками обычно невозможно по организационным 
причинам, и условия использования подпроектов выполняются. 

С точки зрения программной реализации подпроект представляет собой 
самостоятельную модель проекта, реализованную в виде отдельного файла Mi-
crosoft Project, созданную и используемую одним менеджером нижнего звена 

                                           
1 Обычно литература по анализу проектов указывает ещё одно условие: отсутствие 

связей между работами, относящимися к разным подпроектам. При использовании совре-
менных версий Microsoft Project выполнение этого условия не требуется; но в целях повы-
шения скорости вычислений рекомендуется выделять подпроекты так, чтобы связей между 
работами, относящимися к разным подпроектам, было как можно меньше. 
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(возможно, при поддержке вспомогательного персонала). Этот менеджер опре-
деляет все исходные данные для модели своего проекта и осуществляет (либо 
организует) его мониторинг. 

Генеральный менеджер имеет модель генерального проекта — совокуп-
ности совместно выполняемых проектов, где подпроекты представлены в фор-
ме составных работ. Данные о последних содержатся не в файле модели, ис-
пользуемой генеральным менеджером, а в соответствующем файле менеджера 
низшего звена. 

Файлы подпроектов целесообразно размещать в персональных каталогах 
(папках) менеджеров нижнего звена на файловом сервере локальной вычисли-
тельной сети организации. 

При использовании подпроектов без ресурсных пулов ни один ресурс не 
должен описываться более чем в одной модели проекта: каждый менеджер ра-
ботает только с ресурсами, находящимися в его ведении. Все расчёты выпол-
няются в файле, содержащем данные о модели генерального проекта: в против-
ном случае возможности оптимизации расписания, связанные с изменением 
сроков выполнения работ в других подпроектах, не будут реализованы. Схема 
информационного обмена между компонентами проекта для случая, когда один 
из трёх подпроектов доступен генеральному менеджеру только для чтения, 
представлена на рис.11. 

Генеральный
проект

Подпроект I Подпроект II
Подпроект III

(только
чтение)

Даты и время,
затраты

Исправления

Параметры
работ и ресурсов, данные

мониторинга

 
Рис. 11. Схема информационного взаимодействия моделей генерального 
проекта и подпроектов в Microsoft Project на рабочем месте генерального 

менеджера.  
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З а м е ч а н и е .  В приведённом на рис.11 примере генеральный 
менеджер имеет полномочия вносить изменения в подпроекты I и II. Он 
может воспользоваться ими при крайней необходимости, но с организа-
ционной точки зрения подобной практики следует избегать как в целях 
разграничения ответственности, так и во избежание путаницы, принятия 
взаимно противоречащих решений. Хороший стиль управления проекта-
ми предполагает, что генеральный менеджер распределяет только ресур-
сы, назначаемые на подпроекты в целом, а также на работы, не вошедшие 
ни в один из подпроектов. Он не вмешивается в работу менеджеров низ-
шего звена. 

В целях разделения ответственности файлы подпроектов можно 
защитить от вмешательства генерального менеджера средствами опера-
ционной системы. Но тогда менеджер подпроекта, чтобы получить дан-
ные о согласованном расписании, составленном генеральным менедже-
ром, должен будет открыть файл генерального проекта. 

Генеральный
проект (только

чтение)

Подпроект I
(только
чтение)

Подпроект II
(только
чтение)

Подпроект III

Даты и время, затратыПараметры
работ и ресурсов, данные

мониторинга

 
Рис. 12. Схема информационного взаимодействия моделей генерального 
проекта и подпроектов в Microsoft Project на рабочем месте менеджера 

подпроекта III. 

Если генеральный проект не содержит конфиденциальной информации, 
которая не должна быть доступна менеджерам подпроектов, то генеральному 
менеджеру рекомендуется предоставить своим подчинённым доступ к файлу 
генерального проекта на чтение. Тогда менеджеры нижнего звена получат воз-
можность наблюдать влияние изменений, вносимых ими в модель проекта или 
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в данные мониторинга, на оперативный план, не дожидаясь интеграции произ-
ведённых корректировок в генеральный проект. В этом случае менеджер под-
проекта открывает файл генерального проекта, но вносит необходимые измене-
ния только в свой подпроект. Возникающие при этом информационные потоки 
отражены на рис.12. 

Для создания  подпроектов требуется установить связь между файлом 
генерального проекта и файлами подпроектов. Для этого: 

1) создать файлы, в которых будут храниться подпроекты; 
2) ввести в них данные моделей подпроектов; 
3) создать файл генерального проекта;  
4) повторить для каждого файла подпроекта следующие действия: ус-

тановив табличный курсор в первую свободную строку таблицы работ гене-
рального проекта, дать команду Insert � Project… и указать требуемый файл 
подпроекта1; 

5) добавить в файл генерального проекта данные о работах и ресурсах, 
контролируемых непосредственно генеральным менеджером; 

6) установить связи между работами генерального проекта и, если тре-
буется, работами из разных подпроектов (последнего по возможности следует 
избегать); 

7) настроить права доступа к файлам или обратиться к администрации 
локальной вычислительной сети с соответствующим поручением. 

З а м е ч а н и е .  Ничто, кроме организационных трудностей, не 
запрещает подпроектам содержать подпроекты более низкого уровня. 
Однако хороший стиль управления проектами предписывает по возмож-
ности ограничиваться одним уровнем вложенности подпроектов. При 
этом достигается более чёткое разделение ответственности и упрощается 
взаимодействие с администрацией вычислительной сети, особенно в слу-
чаях технических сбоев. 

Связи  между  работами , относящимися  к разным файлам , уста-
навливаются непременно до разграничения прав доступа к файлам. Для этого 
следует: 

♦ открыть файл генерального проекта; 
♦ выделить две связываемые работы (сначала предшествующую, затем, 

при нажатой клавише [Ctrl], — зависимую); 

                                           
1 Если все файлы подпроектов находятся в одном каталоге, их можно связать с гене-

ральным проектом одной командой, выделив все требуемые файлы по обычным правилам 
Windows ([Ctrl]+щелчок мышью). 
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♦ нажать псевдокнопку Link Tasks ( ) на панели инструментов Stan-
dard. 

Можно вводить информацию о связях непосредственно в столбец Prede-
cessors таблицы работ, придерживаясь того же синтаксиса описания связей, ко-
торый порождается вышеописанной процедурой. 

З а м е ч а н и е .  Если работы подпроекта имеют связи с работами 
других подпроектов или генерального проекта, то при открытии файла 
подпроекта работы, с которыми установлена связь, отображаются в таб-
лице работ и выделяются особым цветом — обычно серым. 

 
Ресурсные пулы обычно используются совместно с подпроектами для 

согласования использования ресурсов между ними. Однако их можно исполь-
зовать и для согласования использования одних и тех же ресурсов между раз-
личными проектами, расписания которых не связаны ничем, кроме общих ре-
сурсов. Ресурсные пулы создают в тех случаях, когда одни и те же ресурсы ис-
пользуются на отдельных работах различных проектов или подпроектов и су-
щественно влияют на планы их выполнения. 

Ресурсный пул размещается в одном из файлов Microsoft Project. Для не-
го рекомендуется выделять отдельный файл, таблица работ в котором не запол-
няется. 

Для создания  ресурсного  пула следует: 
♦ создать пустой файл для ресурсного пула; 
♦ ввести в файл ресурсного пула все данные о ресурсах, подлежащих 

совместному использованию в разных проектах; 
♦ установить связь проектов с ресурсным пулом: в каждом из файлов, 

содержащих модели проектов, использующих ресурсы из пула, дать команду 
Tools → Resource Sharing → Share Resources…, в появившемся диалоговом 
окне установить переключатель Use resources From: и в соответствующем поле 
ввода указать путь к файлу ресурсного пула. 

Файл ресурсного пула должен быть доступен всем его пользователям 
на чтение и запись — вот почему не следует помещать его в файл, содержащий 
модель какого-либо проекта, в том числе генерального. Информационные пото-
ки, возникающие при использовании ресурсного пула, представлены на рис.13. 

С момента  установления связи с ресурсным пулом в таблице ресурсов 
будут отображаться все ресурсы, представленные в пуле, а также ресурсы, спе-
цифические для данного проекта и отсутствующие в ресурсном пуле. 

Добавление нового ресурса в таблицу ресурсов подпроекта не приводит 
к его добавлению в ресурсный пул. Такой ресурс будет доступен только рабо-
там данного подпроекта. Если необходимо использовать его и в других подпро-
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ектах, менеджер должен открыть файл ресурсного пула и внести новый ресурс 
в его таблицу ресурсов.  

Передача  изменений  в наличии  и использовании  ресурсов не 
производится автоматически. Иначе случайные операторские ошибки, устра-
няемые через несколько секунд или минут после того, как допущены, могли бы 
отрицательно повлиять на процесс планирования на других рабочих местах, 
создавая стрессовые ситуации и снижая производительность труда. Передача в 
ресурсный пул данных об использовании ресурсов производится командой Tools 
→ Resource Sharing → Update Resource Pool1. Актуальные на текущий момент 
данные о наличии свободных ресурсов и о затратах, связанных с их использова-
нием, могут быть получены из ресурсного пула командой Tools → Resource 
Sharing → Refresh Resource Pool. 

Ресурсный пул

Проект I Проект II Проект III

Наличие
свободных ресурсов,
величины затрат

Использование ресурсов

 
Рис. 13. Схема информационного взаимодействия моделей проектов с 

ресурсным пулом. 

 
Сервер проектов доступен только пользователям профессионального 

выпуска Microsoft Project. Он требует наличия сети Интернет или внутрифир-
менной сети (интранета), а в ней — http-сервера, предоставляющего пользова-

                                           
1 Эта команда не может быть выполнена, пока кто-либо из менеджеров модифициру-

ет ресурсный пул, внося изменения в его таблицу ресурсов. При необходимости внесения в 
ресурсный пул новых работ рекомендуется оповещать о ней коллег с помощью средств об-
мена сообщениями, предоставляемых локальной вычислительной сетью. 
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телям право модификации размещённых на нём данных. Используют его в сле-
дующих случаях: 

♦ для организации взаимодействия между различными организациями, 
вовлечёнными в общий проект, особенно если централизованный менеджмент 
не может быть подходящим решением — например, из-за недостаточной согла-
сованности интересов участников проекта; 

♦ в условиях очень большой организации, желающей извлечь выгоду из 
оптимального использования высококвалифицированного персонала ограни-
ченной численности при выполнении очень большого количества параллельно 
выполняемых проектов, отличающихся целями, масштабами и продолжитель-
ностью (пример — крупная корпорация по разработке программного обеспече-
ния, выпускающая десятки наименований программных продуктов в условиях 
острой конкуренции). 

Инструментальные средства для работы с сервером проектов собраны в 
меню Collaborate и Tools → Enterprise Options. 

Сервер проектов обеспечивает: 
♦ ведение единой базы данных ресурсов, которыми располагает органи-

зация; 
♦ ведение базы данных проектов организации (в базе обычно размеща-

ются типовые проекты, аналоги которых выполняются многократно с несуще-
ственными корректировками); 

♦ формирование команды для работы над заданным проектом по задан-
ным спецификациям профессиональных навыков специалистов; 

♦ двусторонний обмен данными о планах выполнения проекта и об ис-
пользовании ресурсов между менеджерами различных проектов аналогично 
тому, как это происходит при использовании подпроектов и ресурсных пулов, 
но в масштабе глобальной сети; 

♦ автоматизацию взаимодействия с ресурсами — работниками и спе-
циалистами для передачи им плановых заданий и получения от них мониторин-
говой информации; 

♦ оперативное распространение информации о возникших проблемах 
среди менеджеров и другого персонала, к которому она имеет отношение; 

♦ гибкий контроль прав доступа к данным о выполняемых проектах — 
параметрам моделей проектов, базе данных ресурсов, данным мониторинга, от-
чётным и аналитическим документам; 

♦ публикацию на сайте проекта документов о ходе его выполнения. 
Сервер проектов настраивается администратором сервера проектов, а 

при его отсутствии — специалистами административной группы локальной вы-
числительной сети. Те же специалисты, основываясь на типовых документах, 
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разрабатывают при участии генерального менеджера проектов сопроводитель-
ную документацию к серверу, включая руководства пользователей, обладаю-
щих различными правами доступа, а также необходимые программные модули 
на языке программирования VBA для реализации функций менеджера, специ-
фических для данной организации. Конкретные правила и процедуры работы с 
сервером проектов определяются этими документами. 

Базу данных ресурсов формирует рабочая группа, создаваемая генераль-
ным менеджером. 

Контрольные вопросы 

1. Укажите условия, при которых целесообразно рассматривать вопрос о 
внедрении технологии PERT. 

2. Какие обстоятельства вызывают необходимость коллективного управле-
ния проектами? 

3. Может ли одна группа менеджеров управлять одновременно множеством 
различных проектов? Ответ аргументируйте. 

4. Какие способы взаимодействия между менеджерами при коллективном 
управлении проектами поддерживаются программой Microsoft Project? 

5. Когда для налаживания взаимодействия между менеджерами достаточно 
использовать подпроекты? 

6. Как создать подпроект? 
7. Как установить связи между работами, относящимися к разным подпро-

ектам? 
8. Какой режим доступа целесообразно предоставлять менеджеру нижнего 

звена к файлу генерального проекта? Обоснуйте своё мнение. 
9. Что такое ресурсный пул? 
10. Какие команды служат для обмена данными с ресурсным пулом? 
11. Как вы думаете, почему к файлу ресурсного пула всем использующим его 

менеджерам требуется доступ на чтение и запись? 
12. Как добавить ресурс в ресурсный пул? 
13. В каких случаях оправданно применение сервера проектов? 
14. Каковы, по вашему мнению, достоинства и недостатки использования 

сервера проектов для организации коллективного управления проектами? 
15. Какой способ организации коллективного управления проектами вы бы 

предложили фирме, управляющей двадцатью проектами, выполняемыми 
разными клиентами, и предоставляющей им услуги специалистов — ин-
женеров и технологов — для выполнения отдельных работ? 

16. Каковы функции сервера проектов? 
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Лабораторный  практикум  

Описание учебной ситуации 
Имеется проект рекультивации крупного отработанного щебёночного 

карьера путём создания на его месте водоёма с последующим разведением ры-
бы для промышленной переработки. Проект предусматривает также оборудо-
вание рыбоперерабатывающего мини-цеха. 

Общая характеристика проекта 

Предварительно согласованный вариант проекта включает два компо-
нента: собственно рекультивацию карьера и сооружение мини-цеха по перера-
ботке рыбы. После выхода на проектную мощность цех будет выпускать дели-
катесные рыбные продукты. Отходы производства предполагается использо-
вать в качестве корма для свиней на близлежащем свиноводческом комплексе. 
Работы планируется начать 1 сентября 2006 г. 

В связи с тем, что зарплата рабочих, работающих в зимних условиях, 
вдвое выше, а затраты на эксплуатацию техники зимой возрастают в среднем на 
50%, не планируется никаких работ на период с 1 ноября по 31 марта. 

Предлагается следующий график рабочего времени. Рабочая неделя 
шестидневная (кроме воскресенья), рабочее время — с 9 до 18 часов с переры-
вом на обед с 13 до 14 часов. В субботние и предпраздничные дни рабочее вре-
мя заканчивается на час раньше. Праздничные дни (за исключением приходя-
щихся на нерабочий зимний период) — 1 и 9 мая, 12 июня, 4 ноября. 

Характеристика ресурсов1 

Руководитель. Количество — 1 чел. Оплата — 35 руб. в неделю. Работа-
ет в течение всей инвестиционной фазы проекта вплоть до выхода рыбоперера-
батывающего цеха на проектную мощность. 

Рабочие. Количество — 20 чел. Оплата — 20 руб. в неделю. Имеющиеся 
различия в квалификации и опыте работы для выполнения проекта значения не 
имеют. 

Автомобили. Количество — 2. Стоимость эксплуатации — 40 руб. в 
день. Стоимость эксплуатации автомобиля включает зарплату водителя, амор-
тизацию, стоимость текущего ремонта и горюче-смазочных материалов. 

                                           
1 Все денежные затраты указываются в условных рублях в расчёте на единицу ре-

сурса. Один условный рубль соответствует 100 руб. по состоянию на 1 сентября 2006 г. 
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При необходимости имеется возможность арендовать дополнительные 
автомобили (с водителями) за 60 руб. в день. 

Тракторы. Количество — 2. Стоимость эксплуатации — 40 руб. в день. 
Имеется возможность привлечения дополнительных тракторов. Помимо 

вышеуказанных эксплуатационных издержек, это повлечёт потери в размере 
примерно 20 руб. в день вследствие отвлечения техники от сельскохозяйствен-
ных работ. 

Сеялки. Количество — 1. Стоимость эксплуатации — 5 руб. в день. 
Бульдозер. Количество — 1. Стоимость эксплуатации — 70 руб. в день. 
Экскаватор (роторный). Количество — 1. Стоимость эксплуатации — 

100 руб. в день. 
Трубы. Цена — 2000 руб. за 1 км. 
Железобетонные конструкции створок для регулирования оттока воды 

из пруда. Цена — 250 руб. за количество, необходимое для строительства. 
Саженцы для посадки лесополосы. Цена — 15 руб. за количество, необ-

ходимое для посадки лесополосы. 
Семена многолетних трав для залужения берегов отточного русла. За-

траты на семена нулевые, поскольку необходимый их запас уже имеется в на-
личии, а альтернативные варианты его использования отсутствуют. 

Оборудование технического водозабора. Цена — 300 руб. за комплект. 
Сантехническое оборудование. Цена — 300 руб. за комплект. 
Оборудование газоснабжения. Цена — 300 руб. за комплект. 
Автоматизированная линия для переработки рыбы. Цена — 2500 руб. за 

комплект. 
Строительные материалы. Стоимость количества, необходимого для 

восстановления стены цеха по переработке рыбы после завершения монтажных 
работ, — 300 руб. 

Характеристика работ 

1. Решение вопросов землеустройства.  
Продолжительность: 2 недели1. 
Для выполнения работы необходимо привлечь одного рабочего. 
Дополнительные затраты: командировочные и накладные расходы (40 

руб. в неделю). 

                                           
1 Кроме специально оговорённых случаев, продолжительность работ исчисляется в 

рабочем времени согласно принятому на проекте распорядку дня. 
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2. Проведение трубопровода от дренажной системы. 
Трубопровод от дренажной системы обеспечивает 40% потребности во-

доёма в приточном водоснабжении. 
2.1. Освобождение  площадки . 
Работы по освобождению площадки начинаются после решения юриди-

ческих вопросов с пользователями земельных участков, по которым пройдёт 
трубопровод длиной 500 м. 

Продолжительность: 1 неделя. 
Для выполнения работы требуются: рабочие — 6 чел., автомобиль. 
2.2. Копание траншеи . 
Земляные работы начинаются после полного завершения освобождения 

площадки. Иначе не удастся использовать экскаватор из-за его низкой манёв-
ренности.  

Продолжительность: 2 дня. 
Для выполнения работы требуются: рабочие — 6 чел., экскаватор, авто-

мобиль. 
2.3. Прокладка  труб . 
Продолжительность: 1 неделя. 
Для выполнения работы требуются: рабочие — 20 чел., автомобили — 2, 

трубы — 500 м. 
2.4. Рекультивация  траншеи . 
Ещё до рекультивации необходимо заполнить трубопровод водой, чтобы 

убедиться в герметичности стыков. Поэтому рекультивация траншеи начинает-
ся не ранее завершения прокладки труб. 

Продолжительность: 3 дня. 
Для засыпки траншеи и укладки дёрна требуются рабочие  (12 чел.). Так 

как траншея проходит вдоль зданий и лесополосы, бульдозер не может приме-
няться из-за недостаточной манёвренности. 

3. Проведение трубопровода от реки.  
Трубопровод от реки выполняет двоякую функцию. Во-первых, он заби-

рает воду из впадающего в реку ручья и обеспечивает 60% приточного водо-
снабжения пруда, заодно уменьшая водоток ручья и вызываемый им рост ов-
ражка. Во-вторых, при переполнении пруда дождевой водой излишек ее сбра-
сывается по трубам мимо отточного русла непосредственно в реку, снижая эро-
зию. 

Технически работы этой группы аналогичны работам по прокладке тру-
бопровода от дренажной системы, отличаясь только объёмом: длина траншеи 
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1000 метров против 500, а глубина достигает 3,5 метров. Кроме того, для за-
сыпки траншеи, ведущей к реке, можно использовать бульдозер. 

Освобождение площадки для второго трубопровода при этих условиях 
займёт 2 недели, копание траншеи — 4 дня, прокладка труб — 2 недели, ре-
культивация траншеи, благодаря бульдозеру, — 3 дня. Отсутствие бульдозера 
увеличило бы продолжительность работ по рекультивации траншеи втрое. 

4. Укрепление отточного русла. 
Избыток воды из пруда будет стекать естественным путем. Чтобы избе-

жать возникновения оврага вдоль вновь возникающего ручья, пропускная спо-
собность истока будет ограничена железобетонными створками; предполагает-
ся, что если вследствие ограниченной пропускной способности отточного русла 
уровень воды в пруде поднимется на 0,6 метра сверх норматива (что может 
случиться только во время половодья или при очень сильном и продолжитель-
ном дожде), её избыток начнет стекать в реку по трубопроводу. Однако работы 
по укреплению берегов будущего ручья все равно потребуются, так как песча-
ные почвы вдоль его русла слишком легко смываются. 

Перед началом работ данной группы должны быть завершены работы по 
проведению трубопровода к реке и по устройству канализации цеха переработ-
ки рыбы, иначе придётся перекапывать только что посаженную лесополосу и 
только что засеянное культурное пастбище. 

4.1. Установка регулирующих  створок. 
Продолжительность: 5 дней. 
Для выполнения работы требуются: рабочие — 8 чел., бульдозер, авто-

мобиль, железобетонные конструкции для сооружения створок. 
Бульдозер и автомобиль используются только в течение одного дня. 
4.2. Посадка  лесополосы . 
Лес лучше всего сажать в конце лета-начале осени1. 
Продолжительность: 4½ недели. 
Для выполнения работы требуются: рабочие — 20 чел., автомобиль, са-

женцы. 
4.3. Залужение берегов  отточного  русла. 
Продолжительность: 3 дня. 
Для выполнения работы требуются: рабочие — 3 чел., бульдозер (только 

в течение одного дня), трактор, сеялка, семена многолетних трав. 

                                           
1 Эта информация может пригодиться вам при выполнении лабораторной работы 

№4. 
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5. Обводнение пруда. 
Начинать обводнение можно после прокладки трубопроводов и уста-

новки регулирующих створок. Оно не может приходиться на зимнее время, зато 
по окончании половодья его безусловно можно считать законченным. 

Обводнение завершается достижением 3-метровой глубины водоёма. 
Продолжительность: до 3 недель астрономического времени. 
Никаких ресурсов не требуется. 

6. Разведение рыбы 
Продолжительность: не менее 14 недель астрономического времени с 

момента достижения двухметрового уровня воды1. 

7. Монтаж оборудования для перерабатывающего цеха 

7.1. Освобождение  помещения. 
Цель этой работы — освободить помещение бывшего склада вблизи 

карьера для размещения там автоматизированной линии по переработке рыбы. 
Продолжительность: 5 недель. 
Для выполнения работы требуются: рабочие — 4 чел., автомобиль — 1. 
7.2. Разборка стены  здания. 
Мини-цех планируется разместить в помещении бывшего склада. Круп-

ногабаритное оборудование автоматизированной линии не может быть смонти-
ровано в нём без разборки части капитальной стены. 

Начинается работа не ранее решения вопросов землеустройства и осво-
бождения помещения. 

Продолжительность: 4 дня. 
Для выполнения работы требуются: рабочие — 20 чел. 
7.3. Сооружение технического  водозабора. 
Работа может быть начата в любое время. 
Продолжительность: 2 недели. 
Для выполнения работы требуются: рабочие — 8 чел., автомобили — 2, 

оборудование технического водозабора. 
7.4. Устройство  канализации . 
Так как трубы канализации пересекают обводнительные трубопроводы и 

заложены на меньшей глубине, целесообразно начать работы по устройству ка-

                                           
1 В реальных условиях формирование экосистемы пруда и разведение устойчивой 

популяции рыбы, пригодной для промышленной эксплуатации, требует нескольких лет. 
Здесь мы допускаем, что в бывшем карьере уже существовал пруд меньшей глубины и её 
увеличение необходимо лишь для достижения плановой численности популяции рыбы.  
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нализации после завершения работ, связанных со строительством обводнитель-
ных трубопроводов. Кроме того, стена склада должна быть уже разобрана. 

Продолжительность: 4 недели. 
Для выполнения работы требуются: рабочие — 6 чел., сантехническое 

оборудование. 
Альтернативный вариант. 
Продолжительность: 1 неделя. 
Для выполнения работы требуются: рабочие — 4 чел., экскаватор, сан-

техническое оборудование. 
7.5. Подключение газоснабжения . 
Работа должна начаться после завершения работ по устройству канали-

зации. 
Продолжительность: 1½ недели. 
Для выполнения работы требуются: рабочие — 6 чел., автомобиль, обо-

рудование для газоснабжения. 
7.6. Установка автоматизированной  линии. 
Начало работ по установке автоматизированной линии возможно после 

сооружения технического водозабора, разборки стены, устройства канализации 
и завершения работ по подключению газоснабжения. 

Продолжительность: 6 недель. 
Для выполнения работы требуются: рабочие — 5 чел., автомобиль, ав-

томатизированная линия. 
7.7. Восстановление  стены . 
После завершения установки автоматизированной линии можно присту-

пать к восстановлению стены. 
Продолжительность: 3 дня. 
Для выполнения работы требуются: рабочие — 6 чел., автомобиль, 

строительные материалы. 
7.8. Наладка . 
Пуско-наладочные работы можно начинать, как только будет восстанов-

лена стена. 
Продолжительность — 3 недели. 
Для выполнения работы требуются: рабочие — 2 чел. 
Дополнительные расходы: 300 руб. 
7.9. Опытная  эксплуатация . 
Начало опытной эксплуатации требует завершения двух работ: наладки 

оборудования и разведения рыбы. 
Продолжительность: 5 недель. 
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Для выполнения работы требуются: рабочие — 6 чел., автомобиль (же-
лательно). 

Дополнительные расходы: 20 руб. в день. 

8. Выход рыбоконсервного цеха на проектную мощность. 
Это событие наступает после завершения фазы опытной эксплуатации. С 

выходом цеха на проектную мощность заканчивается инвестиционная стадия 
проекта, и он начинает себя окупать. 

Лабораторная работа №1 
Ввод модели проекта 

Цель занятия: научиться формулировать модель проекта с использова-
нием изобразительных средств программы Microsoft Project. 

Содержание задания 

1. Установить параметры Microsoft Project, требуемые для выполнения 
заданий лабораторного практикума. 

2. Ввести общие данные по проекту. 
3. Создать календарь проекта. 
4. Ввести данные таблицы ресурсов. 
5. Ввести данные таблицы работ. 
6. Записать результаты в файл. 

Требования к усвоению теоретического материала 

Приступая к лабораторной работе, студент должен овладеть материалом 
разделов 1…5 теоретической части и ответить на соответствующие контроль-
ные вопросы, а также ознакомиться с описанием учебной ситуации в разделе 
«Лабораторный практикум». 

Методические указания к выполнению задания 

1. Параметры программы Microsoft Project, требуемые для выполнения 
заданий лабораторного практикума, приведены в приложении 9. 

2. Общая информация по проекту вводится с помощью команды Project 
→ Project Information: 

♦ Start date = 01.09.2006 9:00 — дата начала проекта (преподава-
телем может быть указана иная дата); 

♦ Schedule from = Project start date — планировать работы с 
целью возможно более раннего завершения; 

Кроме того, следует дать команду File → Properties → Summary и в 
появившемся диалоговом окне заполнить следующие поля: 
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♦ Title = Учебный проект рекультивации карьера — наиме-
нование проекта; 

♦ Manager = <Фамилия, имя и отчество студента> — сведения о ме-
неджере, который управляет проектом в настоящее время. 

Если преподавателем не указано иначе, с помощью команды Tools → 
Options… → Calendar установите следующие параметры модели проекта: 

♦ Week starts on = Monday — первым днём недели считать понедель-
ник; 

♦ Fiscal year starts in = January — принять, что финансовый год на-
чинается в январе; 

♦ Default start time = 9:00; Default end time = 18:00 — по умолча-
нию принимать, что вновь введённая работа начинается в 9:00 и заканчивается 
в 18:00; 

♦ значения параметров Hours per day, Hours per week и Days per 
month установите самостоятельно, используя для их обоснования сведения из 
раздела «Общая характеристика проекта» (с. 84). 

З а м е ч а н и е .  Если поведение программы Microsoft Project от-
личается от ожидаемого, то прежде чем обратиться к преподавателю с 
возникшей проблемой, проверьте правильность установки вышеперечис-
ленных параметров. 

3. Созданному вами календарю проекта присвойте имя Fish. Теорети-
ческий материал по вводу расписания рабочего времени приведён на с. 37. 

Нерабочий зимний период установите только для первого года выполне-
ния проекта, поскольку предполагается завершить инвестиционную фазу до на-
чала второго зимнего периода. Не забудьте указать праздничные дни в качестве 
нерабочих, а для предпраздничных используйте расписание субботы. 

После создания календаря дайте команду Project → Project Information 
→ Calendar = Fish, установив тем самым, что основным календарём проекта 
будет созданный вами календарь Fish. 

4. Для ввода данных о ресурсах используйте форму представления дан-
ных «Таблица ресурсов». Необходимые теоретические сведения содержатся на 
с. 36. 
 Принадлежность ресурсов к группам материалов либо нескладируемых 
ресурсов и способы списания затрат на ресурсы определите самостоятельно. 
Примите во внимание, что заработную плату обычно выдают по завершении 
работы; оплата аренды, как правило, производится авансом; материалы приоб-
ретаются заранее; при длительных сроках эксплуатации техники или труда ра-
ботников оплата производится периодически. В случае затруднений с опреде-
лением типа ресурса или способа списания затрат обратитесь к преподавателю. 
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 Данные о затратах на привлечение дополнительных автомобилей и трак-
торов используйте при заполнении столбца таблицы ресурсов, отражающего 
оплату ресурсов при их сверхурочном использовании. 
 Не забудьте, что рабочим календарём каждого ресурса проекта должен 
быть календарь Fish, а не Standard. 

5. Для ввода данных о работах используйте форму представления дан-
ных «График Ганта». При вводе рекомендуется переместить границу между 
таблицей работ и графиком Ганта вправо, чтобы на экране одновременно уме-
щалось возможно больше столбцов таблицы работ. Теоретический материал по 
процедурам ввода данных приведён начиная со с. 29. Рекомендуем пользовать-
ся при вводе данных различными способами, чтобы оценить их преимущества и 
недостатки. 
 Группы работ, представленные в описании ситуации, должны быть от-
ражены в модели проекта в форме составных работ (с. 35). Для ускорения вво-
да одноимённых работ, входящих в разные составные работы, используйте опе-
рацию копирования строк таблицы работ через буфер обмена с последующей 
корректировкой копии. По завершении ввода данных о работах, перечисленных 
в описании ситуации, объедините мелиоративные работы (проведение трубо-
проводов, укрепление отточного русла и обводнение пруда) в составную работу 
«Мелиоративные работы». 
 Для выполнения условий задания вам придётся представить в модели 
проекта некоторые работы как составные, хотя в описании учебного проекта 
они таковыми не представлены. 

Перечень ресурсов, приведённый в описании проекта, при необходимо-
сти следует расширить, чтобы отразить все требуемые условия выполнения ра-
бот. Указывая расход материальных ресурсов, самостоятельно принимайте ре-
шение о способе указания потребности в них (см. с. 32). 

Работу «разведение рыбы» следует представить как событие «Разведе-
ние рыбы закончено», которое произойдёт спустя 14 календарных недель после 
предшественника (см. табл.2 на с. 33, чтобы вспомнить, как это делается). Руко-
водитель должен использоваться в течение всего срока выполнения проекта, 
для чего необходимо самостоятельно предусмотреть соответствующую состав-
ную работу. 

Альтернативные варианты выполнения работ в модели проекта не отра-
жайте. Они потребуются вам только при выполнении следующей лабораторной 
работы. 

6.  Имя файла модели проекта должно содержать номер группы и фами-
лию студента. 
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Отчёт о выполнении задания 

Отчётом о выполнении задания служит файл с введённой моделью учеб-
ного проекта. Защищая отчёт, студент должен быть готов обосновать выбран-
ные значения параметров Hours per day, Hours per week и Days per month, 
объяснить назначение установленных при выполнении лабораторной работы 
параметров программы и продемонстрировать преподавателю действия по вво-
ду модели проекта. 

Лабораторная работа №2 
Разработка плана на основе модели проекта  

Цель занятия: получить практические навыки составления 
согласованного плана проектных работ с использованием инструментальных 
средств программы Microsoft Project. 

Содержание задания 

1. Проверить корректность ввода модели проекта. 
2. Выполнить корректировку данных в таблице работ. 
3. Выполнить корректировку данных в таблице ресурсов. 
4. Согласовать использование ресурсов между различными работами. 
5. Зафиксировать согласованный вариант плана. 

Требования к усвоению теоретического материала 

Приступая к лабораторной работе, студент должен повторить материал 
разделов 1…5 теоретической части, изучить раздел 6 и ответить на контроль-
ные вопросы к нему. 

Методические указания к выполнению задания 

1. Сравните оперативный сетевой план, автоматически вычисленный 
программой после ввода модели проекта, с результатами работы ваших това-
рищей по группе. Обнаруженные расхождения позволят вам быстро устранить 
ошибки, допущенные при вводе — например, пропущенные или неправильно 
установленные связи. 

2. Найдите на графике Ганта критический путь1. Внося соответствующие 
изменения в таблицу работ, убедитесь в следующем: 

♦ разрыв связи между двумя последовательными работами критическо-
го пути приводит к его изменению; 

                                           
1 Для этого, возможно, потребуется изменить параметры текущего отображения гра-

фика Ганта (см. с. 65). 
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♦ сокращение продолжительности некоторых критических работ может 
привести к изменению критического пути; 

♦ увеличение продолжительности критических работ влияет на про-
должительность проекта, но не изменяет критического пути; 

♦ сокращение некритических работ никак не влияет на критический 
путь и сроки выполнения проекта, но может влиять на его смету; 

♦ увеличивая продолжительность любой некритической работы, можно 
добиться того, что она окажется на критическом пути; 

♦ при включенном переключателе Effort Driven (см. с. 43) назначение 
дополнительных ресурсов на данную работу сокращает её продолжительность, 
если увеличено количество всех назначенных на неё ресурсов; 

♦ программа не позволяет создавать циклические зависимости между 
работами; 

♦ перемещение мышью полосы, соответствующей работе, на графике 
Ганта создаёт ограничение на сроки начала работы. 
 После каждого произведённого изменения возвращайте модель проекта 
к исходному состоянию. При выполнении задания изменения производите каж-
дым из следующих способов: 

♦ в таблице работ; 
♦ на графике Ганта; 
♦ на графике PERT; 
♦ в календарной форме представления данных. 

 Для тех работ, по которым предусмотрены альтернативные варианты 
выполнения, замените основные варианты альтернативными, предусмотрев не-
обходимые изменения в модели проекта. Сохраните модель проекта с альтерна-
тивными вариантами работ в отдельный файл, добавив к исходному имени 
файла цифру 1. 

3. Установите, какие ресурсы оказались в дефиците. Внося соответст-
вующие изменения в таблицу ресурсов, убедитесь в следующем: 

♦ изменение количества ресурсов не влияет ни на продолжительность 
проекта, ни на его смету; 

♦ изменение затрат на ресурсы влияет на смету, но не на продолжи-
тельность; 

♦ назначение ресурсу календаря, отличающегося от Fish, может при-
вести к увеличению продолжительности проекта. 
 После каждого произведённого изменения возвращайте модель проекта 
к исходному состоянию. 

4. Согласованного использования ресурсов добейтесь методом задержек 
(с. 41). Сравните результаты подневного и поминутного согласования. 
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 Увеличьте количество работников до 30 чел., выполните поминутное со-
гласование и сравните его результат с результатом согласования исходного ва-
рианта (20 чел.). 
 В модели проекта с альтернативными вариантами работ выполните 
только поминутное согласование. 

5. Результат поминутного согласования зафиксируйте в обоих файлах — 
с основной и альтернативной моделями проекта при исходной численности ра-
ботников (20 чел.) — в качестве согласованного плана (с. 47). Запишите резуль-
таты расчётов в файлы. 

Отчёт о выполнении задания 

Отчёт может быть представлен в рукописном виде, в виде компьютерной 
распечатки или в виде файла, в том числе предоставленного преподавателю по 
электронной почте (конкретный вариант представления отчёта определяет пре-
подаватель). 

В отчёте должны быть описаны: 
♦ выявленные ошибки ввода модели проекта и действия по их устране-

нию; 
♦ результаты выполнения п.2 и 3 задания к лабораторной работе: дан-

ные по какой работе модифицировалась; какие конкретно изменения были вне-
сены для достижения ожидаемого результата; какими изобразительными сред-
ствами программа сообщила о произошедших изменениях; сравнение моделей 
проекта с основными и альтернативными вариантами работ по продолжитель-
ности фазы реализации проекта и по величине затрат; 

♦ сравнение оперативных планов до и после согласования использова-
ния ресурсов по продолжительности и затратам; 

♦ сравнение по тем же показателям результатов подневного и поминут-
ного согласования использования ресурсов для основной модели проекта; 

♦ сравнение по тем же показателям результатов поминутного согласо-
вания использования ресурсов для основной модели проекта при исходной и 
увеличенной до 30 чел. численности работников; 

♦ сравнение по тем же показателям согласованных (поминутно) вариан-
тов плана для основной и альтернативной моделей при исходной численности 
работников. 

Рекомендуется при составлении отчёта о лабораторной работе пользо-
ваться материалами подходящих стандартных отчётов программы Microsoft 
Project (команда View → Reports…). 
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Лабораторная работа №3 
Мониторинг проекта 

Цель занятия: получить практические навыки выполнения операций мо-
ниторинга проекта с использованием инструментальных средств программы 
Microsoft Project. 

Содержание задания 

1. Отметить работы, предусмотренные проектом, в качестве выполнен-
ных по состоянию на дату, указанную преподавателем1. 

2. Выполнить корректировку данных мониторинга. 
3. Ввести сверхурочное использование тракторов и автомобилей в объё-

ме, обусловленном имеющимися возможностями аренды, с целью сокращения 
оставшегося объёма работ. 

4. Составить оперативный план с учётом текущего состояния выполне-
ния проекта. 

Требования к усвоению теоретического материала 

Приступая к лабораторной работе, студент должен повторить материал 
раздела 6 теоретической части, изучить разделы 7 и 8, ответить на контрольные 
вопросы к ним. 

Методические указания к выполнению задания 

1. Необходимые теоретические сведения по средствам автоматизации 
мониторинга представлены на с. 50. 

2. Выдайте на графике Ганта информацию о степени завершённости ра-
бот. Внося соответствующие изменения в таблицу работ, убедитесь в следую-
щем: 

♦ при противоречии между установленными связями между работами и 
данными мониторинга программа выдаёт предупреждение; 

♦ если данные мониторинга противоречат связям между работами, при-
оритет имеют данные мониторинга, но оставшаяся невыполненной часть работ 
планируется в соответствии с моделью проекта; 

♦ различие между данными мониторинга и согласованным вариантом 
плана приводит к изменению срока выполнения проекта и затрат на его выпол-
нение; 

♦ ввод данных мониторинга может привести к сокращению общего 
срока выполнения проекта, но только в том случае, если эти данные противоре-

                                           
1 Рекомендуется выбрать в качестве даты 29 октября первого года выполнения про-

екта. 
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чат либо условиям согласования ресурсов, либо установленным связям между 
работами; 

♦ если ход выполнения проекта отклоняется от согласованного плана, 
ввод данных мониторинга может привести к изменению критического пути; 

♦ процент выполнения можно вводить для составных работ, при этом 
объёмы выполнения распределяются между подработами с учётом связей меж-
ду ними. 

3. Последовательность действий по вводу данных о сверхурочном ис-
пользовании ресурсов описана на с. 41. Перед вводом изменений включите пе-
реключатель Effort driven для работ, использующих арендуемые ресурсы. Вво-
дя сверхурочные работы, обратите внимание на изменения, происходящие в се-
тевом плане. 

4. Не отменяя сверхурочных работ, установите, что проведение трубо-
провода от реки на момент мониторинга выполнено на 60%, а остальные рабо-
ты выполняются без отклонений от согласованного плана1. Составьте план вы-
полнения оставшихся работ, выполните согласование использования ресурсов. 
Сравните получившийся план с предыдущим вариантом плана. Объясните про-
изошедшие изменения в сроках выполнения работ. Изменилась ли величина за-
трат на проект? Почему? 

Результат работы запишите в файл, к имени которого добавлена циф-
ра 2. 

Отчёт о выполнении задания 

Отчёт может быть представлен в рукописном виде, в виде компьютерной 
распечатки или в виде файла, в том числе предоставленного преподавателю по 
электронной почте (конкретный вариант представления отчёта определяет пре-
подаватель). 

В отчёте должны быть описаны: 
♦ результаты выполнения п.2 задания к лабораторной работе: данные по 

какой работе модифицировалась; какие конкретно изменения были внесены для 
достижения ожидаемого результата; какими изобразительными средствами 
программа сообщила о произошедших изменениях; 

♦ сравнение (по продолжительности и затратам) оперативных планов до 
и после выполнения п.3 задания; 

                                           
1 Задание составлено в предположении, что момент мониторинга — 29 октября пер-

вого года выполнения проекта. Если преподаватель выбрал другой момент мониторинга, оно 
может потребовать изменений: указанный в задании процент выполнения работы по прове-
дению трубопровода от реки должен быть меньше, чем в отсутствие отклонений от согласо-
ванного плана. 
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♦ сравнение (по продолжительности и затратам) оперативных планов до 
и после выполнения п.4 задания с кратким анализом причин различий. 

Рекомендуется при составлении отчёта о лабораторной работе пользо-
ваться материалами подходящих стандартных отчётов программы Microsoft 
Project (команда View → Reports…). 

Лабораторная работа №4 
Выявление резервов совершенствования проекта 
Цель занятия: овладеть навыками использования инструментальных 

средств программы Microsoft Project для выявления резервов сокращения про-
должительности проекта и затрат на его реализацию. 

Содержание задания 

1. Проанализировав описание учебной ситуации, выявить имеющиеся 
риски возникновения неучтённых затрат. 

2. Проанализировав имеющиеся ресурсы и альтернативные варианты 
выполнения работ, установить, можно ли начать работу «разведение рыбы» ещё 
до начала зимнего нерабочего периода. 

3. Определить, на сколько можно сократить время выполнения проекта 
при максимально достижимой интенсификации темпов его реализации. 

4. Предложить и обосновать наиболее оправданный компромисс между 
затратами на выполнение проекта и его продолжительностью. 

Требования к усвоению теоретического материала 

Приступая к лабораторной работе, студент должен повторить материал 
разделов 4, 6 и 8 теоретической части. 

Методические указания к выполнению задания 

Задание выполняется коллективно рабочими группами студентов чис-
ленностью 4-6 чел. Преподавателю рекомендуется определить состав групп та-
ким образом, чтобы в них не было явных лидеров. Различие в среднем уровне 
подготовленности студентов разных групп не препятствует достижению целей 
лабораторной работы. Группы следует сформировать заранее с тем, чтобы сту-
денты имели возможность провести необходимую подготовительную работу во 
время самоподготовки (целесообразно выделить на неё 2 часа самостоятельной 
работы). 

Преподавателю рекомендуется конкретизировать вышеприведённое за-
дание индивидуально для каждой группы, вводя дополнительные условия по 
своему усмотрению. 



99 

1. Эта часть работы — экспертная. Организовать её лучше всего сле-
дующим образом: каждый студент группы в течение 3-5 минут выписывает все 
возможные причины неучтённых затрат, которые, по его мнению, могут воз-
никнуть в рамках данной учебной ситуации. Далее из всех списков группа пу-
тём совместного обсуждения выбирает 3-5 наиболее значимых и вероятных 
причин неучтённых затрат, даёт заключение о значимости связанного с ними 
риска, а также предложения по способам реагирования на эти риски с целью 
снижения вероятного ущерба. 

2. Для решения этой задачи следует воспользоваться вариантами модели 
проекта, созданными при выполнении предыдущих лабораторных работ. 

3. Предположения о максимально допустимой концентрации ресурсов 
на каждой работе можно обосновать информацией о характере работ, имею-
щейся в описании учебной ситуации. Если группа считает возможным измене-
ние в самой модели проекта без ущерба качеству выполняемых работ, необхо-
димо согласовать его с преподавателем. 

При выполнении этого пункта могут оказаться полезными сведения, 
приводимые в приложении 4. 

4. Чтобы установить, что важнее экономить — время или деньги, реко-
мендуется сделать несколько различных предположений о стоимости ежеме-
сячной продукции цеха и построить соответствующие потоки денежных 
средств. Желательно получить решение задачи о компромиссе между временем 
и затратами в общем виде. 

Отчёт о выполнении задания 

Каждая группа отчитывается о своих результатах в форме десятиминут-
ной презентации с последующими ответами на вопросы преподавателя и пред-
ставителей других групп. Презентация должна содержать аргументированные 
заключения по каждому из четырёх пунктов задания. При оценке качества док-
лада учитывается, кроме прочего, умение студентов обоснованно выбрать воз-
можности программы Microsoft Project для наиболее эффективного достижения 
целей презентации. 

В процессе работы рекомендуется использовать стандартные отчёты 
программы Microsoft Project, а также сведения, приводимые в приложениях к 
настоящему учебному пособию, для достижения максимальной информативно-
сти и доказательности презентации. 



100 

Лабораторная работа №5 
Коллективное управление проектом 

Цель занятия: овладеть навыками использования инструментальных 
средств программы Microsoft Project для организации коллективного управле-
ния проектами. 

Содержание задания 

1. Настроить права доступа к сетевым ресурсам в соответствии с требо-
ваниями организации коллективной работы над проектом1. 

2. Создать ресурсный пул. 
3. Создать подпроекты для работ, указанных преподавателем. 
4. Составить согласованный план выполнения проекта. 
5. Ввести данные о состоянии проектных работ на указанный преподава-

телем момент времени. 
6. Составить оперативный план завершения проекта. 

Требования к усвоению теоретического материала 

Приступая к лабораторной работе, студент должен изучить раздел 9 тео-
ретической части и ответить на контрольные вопросы к нему. 

Методические указания к выполнению задания 

Задание выполняется коллективно рабочими группами студентов чис-
ленностью 4-6 чел. Преподаватель назначает по одному студенту из каждой 
группы исполняющим функции генерального менеджера. Всем остальным сту-
дентам выделяется по одной составной работе в качестве подпроекта, которым 
они управляют. При этом в число ресурсов студенты добавляют: 

♦ генерального менеджера, который назначается на составную работу, 
представляющую собой проект целиком, с оплатой в размере 120 руб. в неделю; 

♦ менеджеров подпроектов, назначаемых на составные работы, пред-
ставляющие собой подпроекты, с оплатой 90 руб. в неделю; 

♦ инспектора по качеству, который проверяет качество выполнения ка-
ждой работы, работая в течение последних восьми часов её выполнения (80 
руб. в неделю). 

З а м е ч а н и е .  При организации учебной практики на базе дан-
ной лабораторной работы целесообразно усложнить задание, используя 

                                           
1 Если выполнение этого пункта не соответствует регламенту вычислительной сети 

вуза либо квалификационные требования к студентам данной специальности не предусмат-
ривают практических навыков операторского обслуживания вычислительных сетей, его 
можно опустить. 
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следующие варианты: предположить, что в общем числе работников 
имеются работники разных специальностей, а некоторые работы предъ-
являют конкретные требования по специальности; разбить работы, при-
ведённые в описании учебной ситуации, на подработы; ввести дополни-
тельную составную работу «обучение персонала рыбоперерабатывающе-
го предприятия» и соответствующие ей ресурсы и т.п. 

1. Студенты самостоятельно выбирают способ распределения прав дос-
тупа с учётом рекомендаций на с. 78 и 80. Последовательность действий по на-
значению прав доступа к сетевым ресурсам зависит от типа локальной вычис-
лительной сети и системных политик. Необходимые методические указания по 
этим действиям предоставляет преподаватель. 

2. Теоретический материал по созданию ресурсного пула представлен на 
с. 80. Пустой ресурсный пул создаётся «генеральным менеджером»; затем каж-
дый студент добавляет туда те ресурсы, которые встречаются в выделенном 
ему подпроекте; наконец, «генеральный менеджер» добавляет в пул ресурсы, 
имеющиеся только в его распоряжении. 

3. Теоретический материал по созданию подпроектов представлен на 
с. 76. 

4. В согласованном плане должен быть полностью устранён дефицит ре-
сурсов без обращения к сверхурочным работам. Альтернативные варианты вы-
полнения работ из описания проекта здесь не должны использоваться. Если в 
процессе разработки плана предусмотрено использование сервера проектов, 
студент обязан изучить дополнительную литературу, рекомендованную препо-
давателем, — например, [2]. 

5. Дата, по состоянию на которую вводятся данные мониторинга, опре-
деляется преподавателем. Он же предлагает дополнительные условия по откло-
нению хода выполнения проекта от графика индивидуально каждому студенту. 

6. При составлении оперативного плана завершения проекта при необ-
ходимости можно использовать сверхурочные работы и альтернативные вари-
анты работ, указанные в описании учебной ситуации. 

Отчёт о выполнении задания 

Каждая группа отчитывается о выполнении задания в форме десятими-
нутной презентации. Она должна содержать: 

♦ обоснование составленного плана; 
♦ краткий анализ различий в плане, составленном коллективно, по 

сравнению с исходным вариантом, составленным по результатам лабораторной 
работы №2; 
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♦ краткое обоснование оперативного плана завершения проекта, со-
ставленного с учётом данных мониторинга. 

При оценке качества доклада учитывается, кроме прочего, умение сту-
дентов обоснованно выбрать возможности программы Microsoft Project для 
наиболее эффективного достижения целей презентации. 
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 Пр и л ож е н и я  

1. Основные формы отображения таблицы работ 

Столбец Системное 
имя столбца 

Тип 
данных Значение 

View → Table → Entry 
 Indicators Индикатор Информация о системных преду-

преждениях по введённым дан-
ным. 

Task Name Name Текст Наименование работы. 
Duration Duration Продолжи-

тельность 
Продолжительность работы (см. 
описание синтаксиса на с. 27). 

Start Start Дата Начало работы согласно опера-
тивному плану. 

Finish Finish Дата Завершение работы согласно опе-
ративному плану. 

Predecessors Predecessors Текст Предшествующие работы (см. 
описание синтаксиса на с. 32). 

Resource 
Names 

Resource 
Names 

Текст Ресурсы, требующиеся для вы-
полнения работы (см. описание 
синтаксиса на с. 30). 

View → Table → Tracking 
Task Name Name Текст Наименование работы 
Act. Start Actual Start Дата Дата фактического начала работы.
Act. Finish Actual Finish Дата Дата фактического завершения 

работы. 
% Comp. % Complete Процент Процент завершённости работы. 
Phys. % 
Comp. 

Physical % 
Complete 

Процент Физический (не зависящий от 
времени) процент завершённости 
работы. Вводится менеджером. 
Используется, если затраты рабо-
чего времени не отражают дейст-
вительную степень завершённо-
сти работы. 
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Продолжение приложения 1

Столбец Системное 
имя столбца 

Тип 
данных Значение 

Act. Dur. Actual Dura-
tion 

Продолжи-
тельность 

Фактическая продолжительность 
выполнения работы. 

Rem. Dur. Remaining 
Duration 

Продолжи-
тельность 

Количество рабочего времени, 
необходимое для завершения ра-
боты. 

Act. Cost Actual Cost Денежный Фактические расходы на выпол-
нение работы, отражённые дан-
ными мониторинга на данный 
момент. 

Act. Work Actual Work Продолжи-
тельность 

Фактическое количество ресурсо-
часов, затраченных на выполне-
ние данной работы. Вычисляется. 
При необходимости можно пере-
определять вычисленное значение 
ручным вводом. 

View → Table → Cost 
Task Name Name Текст Наименование работы. 
Fixed Cost Fixed Cost Денежный Запланированные затраты на вы-

полнение работы, не связанные с 
использованием ресурсов. 

Fixed Cost 
Accrual 

Fixed Cost 
Accrual 

Выпадаю-
щий список 

Способ начисления затрат, не свя-
занных с ресурсами (подробнее 
см. с. 37). 

Total Cost Cost Денежный Сумма затрат на данную работу 
согласно оперативному финансо-
вому плану. 

Baseline Baseline Cost 
(ВАС) 

Денежный Сумма затрат на данную работу 
по согласованному финансовому 
плану. 

Variance Cost Variance Денежный Разница между Cost и Baseline 
Cost. 

Actual Actual Cost Денежный Сумма затрат на данную работу, 
отражённых данными мониторин-
га. 

Remaining Remaining 
Cost 

Денежный Предстоящие затраты (разница 
между Cost и Actual Cost). 
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Продолжение приложения 1

Столбец Системное 
имя столбца 

Тип 
данных Значение 

View → Table → Schedule 
Task Name Name Текст Наименование работы 
Start Start Дата Начало работы согласно опера-

тивному плану. 
Finish Finish Дата Завершение работы согласно опе-

ративному плану. 
Late Start Late Start Дата Позднее время начала работы 

согласно оперативному плану 
(самый поздний срок начала рабо-
ты, при котором продолжитель-
ность инвестиционной фазы про-
екта ещё не увеличивается). 

Late Finish Late Finish Дата Позднее время завершения рабо-
ты согласно оперативному плану 
(Late Start + Duration). 

Free Slack Free Slack Продолжи-
тельность 

Допустимая задержка, не тре-
бующая изменений сроков вы-
полнения других работ. 

Total Slack Total Slack Продолжи-
тельность 

Запас времени для данной работы 
(Late Start – Start). 

View → Table → Summary 
Duration Duration Продолжи-

тельность 
Продолжительность работы (см. 
описание синтаксиса на с. 27). 

Start Start Дата Начало работы согласно опера-
тивному плану. 

Finish Finish Дата Завершение работы согласно опе-
ративному плану. 

% Comp. % Complete Процент Процент завершённости работы. 
Cost Cost Денежный Сумма затрат на выполнение ра-

боты согласно оперативному фи-
нансовому плану. 

Work Work Продолжи-
тельность 

Количество ресурсо-часов, запла-
нированных на выполнение рабо-
ты (согласно оперативному пла-
ну). 
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Продолжение приложения 1

Столбец Системное 
имя столбца 

Тип 
данных Значение 

View → Table → Usage 
 Indicators Индикатор Информация о системных преду-

преждениях и подсказках по вве-
дённым данным. 

Task Name Name Текст Наименование работы. 
Work Work Продолжи-

тельность 
Количество ресурсо-часов, запла-
нированных на выполнение рабо-
ты (согласно оперативному пла-
ну). 

Duration Duration Продолжи-
тельность 

Продолжительность работы (см. 
описание синтаксиса на с. 27). 

Start Start Дата Начало работы согласно опера-
тивному плану. 

Finish Finish Дата Завершение работы согласно опе-
ративному плану.  

View → Table → Variance 
Task Name Name Текст Наименование работы. 
Start Start Дата Начало работы согласно опера-

тивному плану. 
Finish Finish Дата Завершение работы согласно опе-

ративному плану. 
Baseline Start Baseline Start Дата Начало работы по согласованно-

му плану. 
Baseline Fin-
ish 

Baseline Fin-
ish 

Дата Завершение работы по согласо-
ванному плану. 

Start Var. Start Variance Продолжи-
тельность 

Разница между Start и Baseline 
Start. 

Finish Var. Finish Vari-
ance 

Продолжи-
тельность 

Разница между Finish и Baseline 
Finish. 

View → Table → Work 
Task Name Name Текст Наименование работы. 

Work Work Продолжи-
тельность 

Количество ресурсо-часов, запла-
нированных на выполнение рабо-
ты (согласно оперативному пла-
ну). 
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Столбец Системное 
имя столбца 

Тип 
данных Значение 

Baseline Baseline 
Work 

Продолжи-
тельность 

Количество ресурсо-часов, запла-
нированных на выполнение рабо-
ты (по согласованному плану). 

Variance Work Vari-
ance 

Продолжи-
тельность 

(Work – Baseline Work). 

Actual Actual Work Продолжи-
тельность 

Фактическое количество ресурсо-
часов, затраченных на выполне-
ние данной работы. Вычисляется. 
При необходимости можно пере-
определять вычисленное значение 
ручным вводом. 

Remaining Remaining 
Work 

Продолжи-
тельность 

Количество ресурсо-часов, кото-
рое необходимо затратить на за-
вершение работы (Work – Actual 
Work). 

% W. Comp. % Work 
Completed 

Процент (Actual Work/Work) × 100%. 
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2. Наиболее употребительные столбцы таблицы работ, не 
вошедшие в её стандартные формы 

Системное имя 
столбца 

Тип 
данных Значение 

ACWP Денежный Фактические затраты, отнесённые на работу 
по данным мониторинга. 

Baseline Duration Продол-
житель-
ность 

Продолжительность работы по согласован-
ному плану. 

Baseline Work Продол-
житель-
ность 

Совокупные затраты ресурсо-часов на вы-
полнение работы по согласованному плану. 

BCWP Денежный Затраты на выполнение работы по согласо-
ванному плану, умноженные на процент за-
вершённости работы по данным мониторин-
га. Используется для анализа в сравнении с 
ACWP и BCWS. 

BCWS Денежный Затраты на работу по согласованному сете-
вому плану, умноженные на процент завер-
шённости работы на текущую дату согласно 
оперативному плану. Используется для ана-
лиза в сравнении с ACWP и BCWP. 

Constraint Type Выпада-
ющий спи-
сок 

Тип ограничения на срок выполнения рабо-
ты1. Используется совместно с Constraint 
Date. 

Constraint Date Дата Дата ограничения на срок выполнения рабо-
ты. Используется совместно с Constraint 
Type. 

Contact Текст Лицо, ответственное за выполнение данной 
работы. 

 
 

                                           
1 Возможные значения: As Soon As Possible — как можно раньше; As Late 

As Possible — как можно позже; Finish No Earlier (No Later) Than — завер-
шить не раньше (не позже) указанной даты; Must Start (Finish) On — начать (завер-
шить) строго в указанную дату; Start No Earlier (No Later) Than — начать не 
раньше (не позже) указанной даты. 
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Продолжение приложения 2
Системное имя 

столбца 
Тип 

данных Значение 

Cost Variance Денежный Разница между затратами, относимыми на 
данную работу по согласованному плану 
(Baseline Cost) и по оперативному плану 
(Cost). 

CPI Вещест-
венное чис-
ло 

Отношение затрат, причитающихся на фак-
тически выполненный объём работ по согла-
сованному финансовому плану, к затратам 
по данным мониторинга. 

Created Дата Дата и время ввода данной работы в модель 
проекта по системным часам ПЭВМ. Ис-
пользуется при обнаружении ошибочности 
данных, поступавших в определённый пери-
од времени, и при оценке работы менеджера.

Critical Логический Yes, если работа критическая. Иначе No. 
CV Денежный (BCWP – ACWP). 
CV% Процент ((BCWP – ACWP)/BCWP)×100%. 
Deadline Дата Контрольный срок завершения работы. Вво-

дится менеджером на основе соображений, 
не отражаемых моделью проекта. В расчётах 
не участвует, за исключением процесса со-
гласования использования ресурсов. Ис-
пользуется для предупреждения о наруше-
нии контрольного срока при оперативном 
планировании. 

Duration Variance Продол-
житель-
ность 

(Baseline Duration – Duration). 

EAC Денежный Оценка затрат к моменту завершения работ: 
ACWP + (BAC – BCWP)/CPI 

Early Start Дата Раннее время начала работы1. 

                                           
1 Пока не выполнено согласование использования ресурсов или не введены ограни-

чения на сроки выполнения работ, совпадает со временем начала работы по оперативному 
плану (Start), за исключением особых случаев, не рассматриваемых в пособии. 
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Продолжение приложения 2
Системное имя 

столбца 
Тип 

данных Значение 

Earned Value 
Method 

Выпада-
ющий спи-
сок 

Указывает, какие данные использовать для 
вычисления BCWP данной работы: % Com-
plete или Physical % Complete. 

Effort Driven Логический Правило определения продолжительности 
работы (см. с. 43). 

Estimated Логический Помечает работы, информация о продолжи-
тельности которых требует уточнения. 

Finish Variance Продол-
житель-
ность 

(Finish – Baseline Finish). 

Hide Bar Логический Yes — скрывать полосу, соответствующую 
данной работе, на графике Ганта и 
календаре. Иначе No. 

ID Целое чис-
ло 

Номер строки таблицы работ. 

Ignore Resource 
Calendar 

Логический Yes — игнорировать календари ресурсов, 
назначенных на данную работу; иначе No 
(по умолчанию). 

Level Assignments Логический No — отменяет действие опции Leveling can 
adjust individual assignments on a task 
(с. 41). По умолчанию — Yes. 

Leveling Can Split Логический No — отменяет действие опции Leveling can 
create splits in remaining work (с. 41). По 
умолчанию — Yes. 

Leveling Delay Продол-
житель-
ность 

Задержка, введённая процедурой автомати-
ческого согласования использования ресур-
сов (Start – Early Start). 

Marked Логический По умолчанию — No. Менеджер может по-
мечать работу значением Yes для своих 
собственных целей. 

Notes Формати-
рованный 
текст 

Произвольный комментарий. Форматирова-
ние текста комментария отображается толь-
ко в поле Notes диалогового окна Task In-
formation. 

Outline Level Целое чис-
ло 

Номер уровня в иерархии работ (см. с. 35). 
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Продолжение приложения 2
Системное имя 

столбца 
Тип 

данных Значение 

Outline Number Текст Иерархический номер работы (например, 
2.4.27 — 27-я работа в составе 4-й составной 
работы второго уровня, входящей во вторую 
составную работу первого уровня; подроб-
нее см. с. 35). 

Overallocated Логический Yes, если на работу назначены ресурсы 
сверх имеющегося количества; иначе No. 

Preleveled Finish Дата Дата завершения работы, содержавшаяся в 
столбце Finish перед автоматическим согла-
сованием использования ресурса. 

Preleveled Start Дата Дата начала работы, содержавшаяся в 
столбце Start перед автоматическим согласо-
ванием использования ресурса. Как правило, 
при отсутствии ограничений на сроки вы-
полнения работы совпадает с Early Start. 

Priority Целое чис-
ло 

Приоритет работы. К работам с наивысшим 
приоритетом задержки при автоматическом 
согласовании использования ресурсов при-
меняются в последнюю очередь. 

Recurring Логический Yes, если данная работа — периодическая1. 
Иначе No. 

Status Список Complete — работа завершена; On 
Schedule — работа выполняется согласно 
оперативному плану; Late — работа вы-
полняется с отставанием от оперативного 
плана или, вопреки ему, не началась; 
Future Work — предстоящая работа. 

Status Indicator Пикто-
грамма 

Пиктограммы, аналогичные по смыслу зна-
чениям поля Status. 

Subproject File Полное имя 
файла 

Только для работ, представляющих собой 
подпроекты: имя файла, содержащего под-
проект. 

                                           
1 О периодических работах см. с.35, а также в рекомендуемой литературе и в спра-

вочной системе программы Microsoft Project. 
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Продолжение приложения 2
Системное имя 

столбца 
Тип 

данных Значение 

Successors Текст Список работ, зависящих от данной работы 
по срокам выполнения. Обычно вычисляется 
на основе данных столбца Predecessors1. 

Summary Логический Yes, если работа составная. Иначе No.  
SV Денежный (BCWP – BCWS). 
SV% Процент (SV/BCWS)×100%. 
Task calendar Выпада-

ющий спи-
сок 

Имя календаря, определяющего рабочее 
время для данной работы (если он отличает-
ся от календаря проекта). 

Type Выпада-
ющий спи-
сок 

Fixed Work — при изменении продолжи-
тельности вычисляется количество назна-
ченных ресурсов, и наоборот. Ресурсозатра-
ты не изменяются. 
Fixed Units — при изменении продол-
жительности изменяется объём ресурсозат-
рат, и наоборот. Количество назначенных 
ресурсов не изменяется. 
Fixed Duration — при изменении коли-
чества назначенных ресурсов изменяется 
объём ресурсозатрат, и наоборот. Продол-
жительность работы остаётся неизменной. 

Unique ID Целое чис-
ло 

Номер, присваиваемый работе при вводе. 
Если работа будет удалена, её Unique ID не 
будет присвоен никакой другой работе. 
Unique ID, в отличие от ID, не меняется при 
изменении размещения работ в таблице ра-
бот. 

Unique ID Prede-
cessors 

Текст То же, что и Predecessors, но для ссылки на 
работы используются значения Unique ID2. 

                                           
1 При вводе данных в столбец Successors автоматически корректируются данные 

столбца Predecessors по соответствующим работам. Синтаксис данных столбцов Successors 
и Predecessors один и тот же (см. с. 32). 

2 Синтаксис данных в столбце Unique ID Predecessors тот же, что и в Predecessors 
(см. с.32). 
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Системное имя 

столбца 
Тип 

данных Значение 

Unique ID Succes-
sors 

Текст То же, что и Successors, но для ссылки на ра-
боты используются значения Unique ID1. 

VAC Денежный (Baseline Cost – EAC). 
WBS Текст Иерархический код работы. Формат кода 

может задаваться менеджером (Project → 
WBS → Define Code). 

WBS Predecessors Текст То же, что и Predecessors, но для ссылки на 
работы используются значения WBS2. 

WBS Successors Текст То же, что и Successors, но для ссылки на ра-
боты используются значения WBS2. 

Work Variance Продол-
житель-
ность 

Work – Baseline Work. 

                                                                                                                                          
Использование столбца Unique ID Predecessors для ввода связей между работами 

снижает риск ошибок по сравнению с использованием для той же цели столбца Predecessors. 
Рекомендуем ввести столбец Unique ID в стандартное представление таблицы работ (View 
→ Table → Entry) и заменить столбец Predecessors столбцом Unique ID Predecessors (если 
это не противоречит внутрифирменному стандарту). 

1 Синтаксис данных в столбце Unique ID Successors тот же, что и в Predecessors (см. 
с.32). 

2 Синтаксис данных в этом столбце схож с принятым в столбце Predecessors (см. 
с.32) с тем отличием, что модификаторы типа связи и лаги заключаются в квадратные скоб-
ки. 
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3. Основные формы отображения таблицы ресурсов 

Столбец Системное 
имя столбца 

Тип 
данных Значение 

View → Table → Entry 
 Indicators Индикатор Информация о системных преду-

преждениях и подсказках по вве-
дённым данным. 

Resource 
Name 

Name Текст Наименование ресурса 

Type Type Выпадаю-
щий список 

Work — нескладируемый ресурс. 
Material — материал. 

Material La-
bel 

Material La-
bel 

Текст Единица измерения (для материа-
лов). 

Initials Initials Текст Инициалы (сокращённое обозна-
чение) ресурса. 

Group Group Текст Группа, к которой относится ре-
сурс. Вводится при необходимо-
сти анализа ресурсов в разрезе 
групп. 

Max. Units Max Units Веществен-
ное число 
или процент1 

Наличие (только для 
нескладируемых ресурсов). 

Std. Rate Standard Rate Денежный Затраты на использование не-
складируемого ресурса за едини-
цу времени или цена единицы 
материала2. 

Ovt. Rate Overtime 
Rate 

Денежный Затраты на сверхурочное исполь-
зование нескладируемого ресурса 
за единицу времени2. 

Cost/Use Cost Per Use Денежный Затраты, связанные с привлечени-
ем ресурса. 

 
Продолжение приложения 3

                                           
1 В зависимости от значения параметра Tools → Options → Schedule → Show as-

signment units as. 
2 Синтаксис данных описан на с. 36. 
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Столбец Системное 
имя столбца 

Тип 
данных Значение 

Accrue At Accrue At Выпадаю-
щий список 

Способ начисления затрат (под-
робнее см. с. 37). 

Base Calen-
dar 

Base Calendar Выпадаю-
щий список 

Имя календаря ресурса. 

Code Code Текст Внутрифирменный код ресурса. 
View → Table → Cost 

Resource 
Name 

Name Текст Наименование ресурса 

Cost Cost Денежный Затраты на ресурс согласно опе-
ративному финансовому плану. 

Baseline Cost Baseline Cost Денежный Затраты на ресурс по согласован-
ному финансовому плану. 

Variance Cost Variance Денежный (Cost – Baseline Cost). 
Actual Cost Actual Cost Денежный Фактические затраты на ресурс по 

данным мониторинга. 
Remaining Remaining 

Cost 
Денежный Предстоящие затраты на ресурс 

согласно оперативному плану. 
View → Table → Summary 

Resource 
Name 

Name Текст Наименование ресурса 

Group Group Текст Группа, к которой относится ре-
сурс. Вводится при необходимо-
сти анализа ресурсов в разрезе 
групп. 

Max. Units Max Units Веществен-
ное число 
или процент1 

Наличие (только для 
нескладируемых ресурсов). 

Peak Peak Веществен-
ное число 
или процент2 

Максимальная одновременная по-
требность в данном ресурсе. 

                                           
1 В зависимости от значения параметра Tools → Options → Schedule → Show as-

signment units as. 
2 В зависимости от значения параметра Tools → Options → Schedule → Show as-

signment units as. 
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Продолжение приложения 3

Столбец Системное 
имя столбца 

Тип 
данных Значение 

Std. Rate Standard Rate Денежный Затраты на использование не-
складируемого ресурса (за едини-
цу времени) или цена единицы 
материала1. 

Ovt. Rate Overtime 
Rate 

Денежный Затраты на сверхурочное исполь-
зование нескладируемого ресурса 
(за единицу времени)2. 

Cost Cost Денежный Затраты на ресурс согласно опе-
ративному финансовому плану. 

Work Work Продолжи-
тельность 
или вещест-
венное число 

Для нескладируемого ресурса — 
объём назначенной ему работы за 
время проекта согласно оператив-
ному плану. Для материала — его 
суммарный расход за время про-
екта согласно оперативному пла-
ну. 

View → Table → Work 
Resource 
Name 

Name Текст Наименование ресурса 

% Comp. % Work 
Complete 

Процент Процент работы, выполненной 
ресурсом, от предусмотренной 
оперативным планом. 

Work Work Продолжи-
тельность 
или вещест-
венное число 

Для нескладируемого ресурса — 
объём назначенной ему работы за 
время проекта согласно оператив-
ному плану. Для материала — его 
суммарный расход за время про-
екта согласно оперативному пла-
ну. 

Overtime Overtime 
Work 

Продолжи-
тельность 

Объём сверхурочной работы ре-
сурса согласно оперативному 
плану. 

                                           
1 Синтаксис данных описан на с. 36. 
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Продолжение приложения 3

Столбец Системное 
имя столбца 

Тип 
данных Значение 

Baseline Baseline 
Work 

Продолжи-
тельность 
или вещест-
венное число 

Для нескладируемого ресурса — 
объём назначенной ему работы за 
время проекта по согласованному 
плану. Для материала — его сум-
марный расход за время проекта 
по согласованному плану. 

Variance Work Vari-
ance 

Продолжи-
тельность 
или вещест-
венное число 

(Work – Baseline Work) 

Actual Actual Work Продолжи-
тельность 
или вещест-
венное число 

Для нескладируемого ресурса — 
фактический объём выполненных 
им работ согласно данным мони-
торинга. 
Для материала — его суммарный 
расход по данным мониторинга. 

Remaining Remaining 
Work 

Продолжи-
тельность 
или вещест-
венное число 

(Work – Actual Work) 
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4. Назначение переменных профилей платы за ресурс 

1. Дать команду View → More Views… → Resource Allocation. 
2. Двойным щелчком на имени требуемого ресурса вызвать диалоговое 

окно Resource Information. Выбрать ярлычок Costs (рис. 14). 
3. Ввести профиль оплаты, используемый по умолчанию. Для этого в 

первой строке таблицы указать ставки, действующие с начала выполнения про-
екта (здесь дата не может быть указана∑); во второй — ставки, вступающие в 
силу после первого её изменения (указывается дата изменения); в третьей — 
вступающие в силу после второго изменения и т.д. 

 
Рис. 14. Диалоговое окно Resource Information. 

4. При необходимости ввести дополнительные профили оплаты, исполь-
зуемые на отдельных работах, выбрав ярлычки B, С и т.д. (назначьте столько 
профилей, сколько требуется; максимум — пять). 

5. Нажать псевдокнопку OK. 
6. Повторить пп. 2…4 для всех ресурсов, по которым требуется задание 

профилей оплаты. 
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7. Для работы, на которой необходимо назначить профиль платы за ис-
пользование некоторого ресурса, вызвать диалоговое окно Assignment Infor-
mation двойным щелчком на наименовании требуемой работы в строке распре-
деления ресурсов, соответствующей данному ресурсу. 

8. Из выпадающего списка Cost rate table выбрать букву, соответст-
вующую требуемому профилю платы за использование данного ресурса.  

9. Нажать псевдокнопку OK. С этого момента плата за данный ресурс 
при использовании на данной работе будет начисляться согласно указанному 
профилю. 

10. Повторить пп. 7…9 для всех строк распределения ресурсов, для ко-
торых необходимо назначить профиль платы за ресурс, отличающийся от ис-
пользуемого по умолчанию (т.е. от A). 
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5. Операторы и наиболее употребительные функции, 
используемые в формулах расчёта значений столбцов, 

определяемых пользователем 

Операторы 

+, –, *, /, ^ — арифметические операторы: сложение, вычита-
ние, умножение, деление, возведение в степень. 

\ — целочисленное деление (остаток отбрасывается). 
MOD — остаток от деления. Например, значение выраже-

ния 8 MOD 3 равно 2. 
& — конкатенация (объединение) двух текстовых 

строк. 
=, <>, <, >, >=, <= — операторы сравнения (результат имеет значения 

«истина» или «ложь»)1. 
AND, OR, NOT — логические операции "и", "или", "не". 

Математические функции 

sqr(x), log(x), exp(x)  — x, ln(x), ex. 
sin(x), cos(x), tan(x), atn (x) — sin(x), cos(x), tg(x), arctg(x). 
abs(x) — |x|. 
fix(x) — округление отбрасыванием дробной части. 
sgn(x) — 1, если x > 0; 0, если x = 0; –1, если x < 0. 
rnd() — равномерно распределённая случайная величина 

в интервале [0; 1). Значение обновляется при ка-
ждом пересчёте модели проекта. 

Логические функции 

isnumeric(x) — «истина», если аргумент числовой; иначе «ложь». 
isdate(x) — «истина», если аргумент — дата; иначе «ложь»2. 
isnull(x) — «истина», если аргументу не присвоено никакое 

значение; иначе «ложь». 
iif(x,y,z) — y, если x имеет значение «истина»; в противном 

случае — z. 
choose(i,x1,x2…) — возвращает значение xi. 

                                           
1 Эти операторы могут использоваться для сравнения не только чисел и дат, но и 

текстовых строк (в лексикографическом порядке). Регистр символов учитывается. 
2 В справочной системе программы Microsoft Project эта функция отнесена к числу 

функций даты и времени. 
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switch(c1,x1,c2,x2…) — аргументы ci содержат логические условия, xi — 
некоторые значения. Результат — первое слева 
значение xi, для которого соответствующее ci 
принимает значение «истина». 

Функции даты и времени 

К календарным значениям можно прибавлять и вычитать вещественные 
числа, трактуемые в этом случае как число дней (возможно, дробное) согласно 
астрономическому времени. 

В столбцах для представления календарных значений могут отображать-
ся только даты в интервале с 1 января 1984 г. по 31 декабря 2049 г.  
now() — текущие дата и время по системным часам ком-

пьютера (обновляются при каждом пересчёте 
модели проекта). 

date() — текущая дата по системным часам компьютера. 
cdate(x) — преобразование текстового значения к типу «да-

та». 
dateserial(y,mn,d), timeserial(h,m,s) — формирование календарного значе-

ния из номеров года y, месяца mn и числа d; но-
меров часа h, минуты m и секунды s. Например, 
чтобы сформировать календарное значение, со-
ответствующее моменту h часов 15 минут 
30 секунд 17 июня y-го г., можно записать 
dateserial(y,6,17) + 

timeserial(h,15,30). 
dateadd(u,n,d) — дата, отстоящая от даты d (возможно её задание в 

форме текста) на n периодов, специфицирован-
ных аргументом u. Последняя может принимать 
одно из следующих значений: "h", "d", "m", 
"y", что означает соответственно часы, дни, ме-
сяцы и годы. Время астрономическое. Например, 
результат вычисления функции 
dateadd("m",1,"23.05.2006")  — 23 ию-
ня 2006 г. 

datediff(u,d1,d2) — число полных и неполных периодов заданной 
продолжительности между двумя указанными 
датами d1 и d2 (возможно их задание в форме 
текста по образцу "23.05.2006 23:59"). Пе-
риод задаётся аргументом u, который может 
принимать значения "h", "d", "w", "m" (часы, 
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дни, недели, месяцы). Если d1 > d2, результат от-
рицательный. 

datepart(u,d,f) — в зависимости от значения аргумента u выдаёт: 
"h" — час, "d" — календарное число, "m" — 
номер месяца, "w" — номер дня недели, "y" — 
номер дня в году, соответствующие дате d (дата 
может задаваться как календарным значением, 
так и текстом по образцу "23.05.2006 
23:59"). Аргумент f используется только при 
u = "w": если он равен 0, первым днём недели 
считается понедельник, если 1 — воскресенье. 
В других случаях он игнорируется и может быть 
опущен. 

З а м е ч а н и е .  Результат вычислений функций datediff и date-
part является числом, а не календарным значением (датой). Попытка ото-
бражения числового значения в календарных столбцах, определяемых 
пользователем, вызовет сообщение об ошибке. 

year(d) — номер года, соответствующий дате d. 
month(d) — равносильно datepart("m",d). 
weekday(d,f) — равносильно datepart("w",d,f). 
day(d) — равносильно datepart("d",d). 
hour(d) — равносильно datepart("h",d). 
minute(d) — минута, соответствующая дате d (например, для 

даты "17.06.2006 9:15" результат равен 
15). 

projdateadd(d,n,c) — дата, отстоящая от даты d на период рабочего 
времени n согласно календарю c. Дата задаётся 
календарным или текстовым (например, 
"17.06.2006 9:15") значением. Кален-
дарь — именем. Период может задаваться чис-
лом (обозначающим число минут) или текстовой 
строкой со спецификацией периода: например, 
"3m" — 3 минуты; "4h" — 4 часа; "5d" — 
5 рабочих дней; "6w" — 6 рабочих недель; 
"7mon" — 7 рабочих месяцев; "8ed" — 
8 24-часовых периодов рабочего времени; 
"9ew" — 9 168-часовых периодов рабочего вре-
мени; "10emon" — 10 720-часовых периодов 
рабочего времени. Продолжительность рабочего 
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дня, рабочей недели и рабочего месяца устанав-
ливается параметрами текущего проекта (Tools 
→ Options… → Calendar). Если агрумент c 
опущен, используются календари, назначенные 
текущей строке таблицы работ или ресурсов, а 
при отсутствии таковых — календарь проекта. 

projdatesub(d,n,c) — функция аналогична projdateadd, но вычисляется 
дата, предшествующая d на период n. 

projdurvalue(n) — вычисляет продолжительность периода n, задан-
ного так же, как в функции projdateadd, — в 
минутах. 

projdatediff(d1,d2,c) — количество минут рабочего времени между дата-
ми d1 и d2 согласно календарю c. Если аргумент c 
опущен, используются календари, назначенные 
текущей строке таблицы работ или ресурсов, а 
при отсутствии таковых — календарь проекта. 

projdurconv(n,f) — вычисляет продолжительность периода n, задан-
ного так же, как в функции projdateadd, в еди-
ницы, заданные флагом f. Флаг должен содер-
жать целое значение. Нечётные значения от 3 до 
11 обозначают единицы рабочего времени — 
минуты, часы, дни, недели, месяцы. Чётные от 
4 до 12 — соответствующие единицы астроно-
мического времени. 

Текстовые функции 

format(x,f) — отображение числа или даты x по формату f. 
Например: 
♦ функция format(cdate("15.1.04 10:30"), "hh ч. mm 

мин. d mmmm yyyy г.") выдаст текст "10 ч. 30 мин. 15 января 
2006 г."; 

♦ функция format(cdate("5.1.06 10:30"), "dd mmm yyг. 
в hh:mm") выдаст текст "05 янв 04г. в 10:30"; 

♦ функция format(3.14159, "#.###") выдаст текст "3.142"; 
♦ функция format(0.14159, "#.###") выдаст текст ".142"; 
♦ функция format(3.14, "000.000") выдаст текст "003.140". 

instr(n,b,s,c) — номер символа, начиная с которого в строке b со-
держится строка s, или 0. Аргумент c определяет 
правила сравнения: с учётом регистра (0) или без 
учёта (4). 
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len(s) — число символов в строке s. 
lcase(s), ucase(s), — перевод текста s в строчной и заглавный регистры 

соответственно. 
ltrim(s), rtrim(s) — возвращают исходный текст (s), удалив соответ-

ственно начальные или конечные пробелы (если 
имелись). 

space(n) — возвращает строку, состоящую из n пробелов. 
mid(s,i,l) — возвращает подстроку строки s, начинающуюся с 

i-го символа и имеющую длину l (если аргумент l 
опущен — до конца строки).  
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6. Наименования типов работ, используемые при сопоставлении 
им элементов графика Ганта 

Normal — все работы, исключая составные и помеченные как «со-
бытия». 

Milestone — работы, помеченные как  «события» (содержащие значе-
ние Yes в столбце Milestone). Работы нулевой продол-
жительности автоматически помечаются как «события». 

Summary — составные работы. 
Critical — критические работы. 
Noncritical — некритические работы. 
Marked — помеченные работы (содержащие значение Yes в столб-

це Marked). 
Finished — завершённые работы. 
In progress — работы, выполнение которых продолжается. 
Started late — работы, начатые позже даты, установленной согласован-

ным планом. 
Finished late — работы, завершённые с опозданием против согласован-

ного плана. 
Started early — работы, начатые раньше даты, установленной согласо-

ванным планом. 
Finished early — работы, завершённые с опережением согласованного 

плана. 
Started on time — работы, начатые в срок, установленный согласованным 

планом. 
Finished on time — работы, завершённые в срок, установленный согласо-

ванным планом. 
Project summary — фиктивная составная работа, представляющая собой весь 

проект целиком. Отображается командой Tools → Op-
tions… → View → Show project summary task. 

Group by summary — фиктивная работа, объединяющая группу работ, опреде-
лённую по заданному пользователем критерию. 

Split — работы, выполняемые с перерывами. 
External tasks — работы из других проектов, связанные с работами дан-

ного проекта. 
Flag1…Flag20 — работы, имеющие значение Yes в соответствующем 

столбце таблицы работ (Flag1…Flag20). Это значение 
может быть результатом вычислений: подробнее см. о 
вычисляемых столбцах на с. 63. 
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При настройке элементов графика Ганта разрешается указывать ключе-
вое слово Not перед идентификаторами типов работ, чтобы специфицировать 
все работы, за исключением работ указанного типа. 

Можно указывать несколько идентификаторов типа (в том числе с клю-
чевым словом Not) через точку с запятой (в нерусифицированных версиях 
Windows — через запятую). В этом случае соответствующий элемент графика 
Ганта будет отображаться только для работ, относящихся ко всем указанным 
типам одновременно. Например: Summary,Not In Progress — составные 
работы, за исключением выполняющихся в настоящее время. 
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7. Наиболее употребительные фильтры, 
приёмы поиска данных и группировки 

Фильтры таблицы работ 

All Tasks — отменить фильтр и отобразить все работы. 
Completed Tasks — завершённые работы. 
Critical — критические работы. 
Date Range… — работы, которые будут завершены не ранее ука-

занной даты. 
Incomplete Tasks — незавершённые работы (включая работы, кото-

рые ещё не начались). 
Milestones — события, то есть работы, содержащие значение 

Yes в столбце Milestone. Работы нулевой про-
должительности автоматически помечаются как 
события. 

Summary Tasks — составные работы. 
Tasks with Deadlines — работы с заданными контрольными сроками за-

вершения (в столбце Deadline). 
Tasks with Estimated Durations — работы, продолжительность которых требу-

ет уточнения (содержащие значение Yes в 
столбце Estimated). 

Tasks with Fixed Dates — работы с ограничениями по срокам. 
Using Resource… — использующие указанный ресурс. 

Фильтры таблицы ресурсов 

All Resources — отменить фильтр и отобразить все ресурсы. 
Overallocated Resources — ресурсы, используемые сверх наличия (согласно 

оперативному плану). 
Resources – Material — складируемые ресурсы (материалы). 
Resources – Work — нескладируемые ресурсы. 
Work Overbudget — ресурсы, объём использования которых (в ре-

сурсо-часах) по данным мониторинга превысил 
предусмотренные согласованным планом. 

Cost Overbudget — ресурсы, затраты на которые превысили преду-
смотренные согласованным планом. 

Group… — ресурсы, относящиеся к указанной группе. 

Правила группировки таблицы работ 

No Group — отменить группировку. 
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Complete and Incomplete Tasks — группировка работ по признаку завершён-
ности (две группы). 

Constraint Type — группировка по типу ограничения на сроки вы-
полнения, вменённого данной работе. 

Critical — группировка по признаку принадлежности кри-
тическому пути. 

Duration — группировка работ по продолжительности. 
Duration then Priority — двухуровневая группировка по признакам про-

должительности и приоритета работ. 
Milestones — разбиение на обычные работы и события, то 

есть работы, содержащие значение Yes в 
столбце Milestone. Работы нулевой продолжи-
тельности автоматически помечаются как собы-
тия. 

Priority — группировка по приоритету. 
Priority Keeping Outline Structure — группировка по приоритету с сохранени-

ем иерархии работ. Группируются только рабо-
ты, не являющиеся составными, относящиеся к 
одной и той же составной работе. 

Правила группировки таблицы ресурсов 

No Group — отменить группировку. 
Resource Group — группировка по группам ресурсов (по содержи-

мому столбца Group таблицы ресурсов). 
Work vs Material Resources — разделение ресурсов на нескладируемые и скла-

дируемые. 
Complete and Incomplete Resources — группировка по фактически выполнен-

ному ресурсами объёму запланированных для 
них работ: ресурс не приступал к работе; про-
должает выполнение; полностью выполнил все 
работы. 

Standard Rate — группировка по величине оплаты использования 
ресурсов в единицу времени. 

 

Операторы сравнения, используемые 
в диалоговом окне Custom AutoFilter 

Значение в левом выпадающем списке: 
equals — означает, что значение фильтруе-

мого столбца должно быть равно 
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значению в правом выпадающем 
списке; 

does not equal — не равно; 

 

 
Рис. 15. Диалоговое окно Custom AutoFilter. 

 
is greater than — больше; 
is greater than or equal to — не меньше; 
is less than — меньше; 
is less than or equal to — не больше; 
is within — в указанном диапазоне1; 
is not within — за пределами указанного диапазо-

на1; 
contains — содержит подстроку; 
does not contain — не содержит подстроку; 
contains exactly — в точности совпадает (для тексто-

вых строк аналогична equals). 

                                           
1 Значения диапазона указываются через точку с запятой или (в английских версиях 

Windows) через запятую. 
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8. Настройка вывода на печать 

 

Рис. 16. Настройка параметров страницы. 

 

Рис. 17. Настройка полей листа. 
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Рис. 18. Настройка колонтитулов. 

Назначение псевдокнопок на рис. 18 (слева направо): выбор шрифта для 
колонтитула; вставка номера страницы; вставка количества страниц в распечат-
ке; вставка даты; вставка времени; вставка имени файла; вставка рисунка из 
файла. 

Наиболее употребительные коды из списка General (на рис. 18) 

Page Number — номер страницы. 
Total Page Count — число страниц в распечатке. 
Project Title — название проекта. 
Company Name — наименование организации. 
Manager Name — фамилия менеджера. 
Project Start Date — дата начала проекта. 
Project Finish Date — дата завершения проекта. 
Project Current Date — дата и время последнего перевычисления моде-

ли проекта. 
Project Status Date — дата последней актуализации данных монито-

ринга. 
View Name — наименование формы отображения данных. 
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Report Name — наименование отчёта. Используется, если печа-
тается отчёт, созданный командой View → Re-
ports…. В противном случае вставка этого кода 
безрезультатна. 

Filter Name — имя используемого фильтра. 
Group Name — имя используемого правила группировки работ 

(ресурсов). 
File Name — имя файла. 
File Name and Path — полное имя файла (включая путь). 
Last Saved Date — дата последней записи файла проекта. 
System Date — текущая дата. 
System Time — текущее время. 
 
 
 

 

 

Рис. 19. Настройка легенды (для графиков и диаграмм). 
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Рис. 20. Другие настройки печати. 
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9. Настройки программы Microsoft Project, рекомендуемые для 
выполнения заданий лабораторного практикума 

9.1. Параметры, устанавливаемые командой Tools → Options… → Schedule 

Рекомендуемые значения 
параметров Пояснения 

Show scheduling messages включить Выдавать сообщения о процессе рас-
чёта плана. 

Show assignment units as a = Deci-
mal 

Ресурсы измерять в целых единицах, а 
не в процентах. 

New tasks = Start on project 
start day 

Начало вновь создаваемых работ, пока 
не указаны их связи с другими работа-
ми, планировать на дату начала проек-
та. 

Duration is entered in = Days Если продолжительность работ введе-
на без указания единиц измерения, 
считать, что введённые данные обо-
значают число рабочих дней. 

Work is entered in = Hours Если объём ресурсозатрат введён без 
указания единиц измерения, считать, 
что введённые данные обозначают ко-
личество ресурсо-часов. 

Default task type = Fixed Units При изменении пользователем вели-
чины ресурсозатрат корректировать 
продолжительность работы, а не коли-
чество назначенных на неё ресурсов. 

New tasks are effort driven отключить По умолчанию назначение ресурсов на 
работы будет приводить к увеличению 
их ресурсоёмкости. 

Остальные переключатели включить. 
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9.2. Параметры, устанавливаемые командой Tools → Options… → Calculation 

Рекомендуемые значения 
параметров Пояснения 

Calculation mode = Automatic Любое изменение модели проекта бу-
дет сопровождаться вычислением но-
вого варианта оперативного плана. 

Updating task status updates resource 
status включить 

Автоматически вычислять фактиче-
ские ресурсозатраты при вводе данных 
мониторинга. 

Inserted projects are calculated as 
summary tasks включить 

Включать подпроекты в процесс авто-
матического планирования. 

Actual costs are always calculated by 
Microsoft Project включить 

Автоматически вычислять затраты при 
вводе данных мониторинга. 

Move ends of completed parts after 
status date back to status date выклю-
чить 

Не осуществлять автоматическую при-
вязку дат и времени завершения за-
конченных работ к текущей дате. 

Move start of remaining parts below 
status date forward to status date вы-
ключить 

Не осуществлять автоматическую при-
вязку сроков продолжения незавер-
шённых работ к текущей дате. 

Edits to total task % complete will be 
spread to the status date выключить 

Не ограничивать максимальную сте-
пень завершённости работы по состоя-
нию на текущую дату. 

Calculate multiple critical paths вы-
ключить 

Отображать, при наличии альтерна-
тивных критических путей, только 
один из них. 

Default fixed costs accrual = Pro-
rated 

По умолчанию начислять затраты, не 
зависящие от ресурсов, пропорцио-
нально времени выполнения работы. 

Tasks are critical if slack is less than or 
equal to = 0 days 

Считать критическими только работы, 
не имеющие никакого запаса времени. 
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9.3. Параметры, устанавливаемые командой Tools → Options… → Calculation 
→ Earned value 

Рекомендуемые значения 
параметров Пояснения 

Default task Earned Value method = % 
Complete 

Использовать данные столбца 
% Complete для вычисления показате-
ля BCWP (с. 109). 

Baseline for Earned Value calculations 
= Baseline 

Использовать данные столбцов Base-
line в качестве данных о согласован-
ном плане. 

 
9.3. Параметры, устанавливаемые командой Tools → Options… → View 

Рекомендуемые значения 
параметров Пояснения 

Date format = 28.01.02 12:33 Выдавать даты и время в таблицах и на 
графиках согласно указанному образ-
цу. 

Show summary tasks включить Отображать данные о составных рабо-
тах. 

 
9.4. Параметры, устанавливаемые командой Tools → Level Resources… 

Рекомендуемые значения 
параметров Пояснения 

Manual включить Отменить автоматическое согласова-
ние использования ресурсов. 

Clear leveling values before leveling 
включить 

Устранять результаты предыдущих со-
гласований перед новым согласовани-
ем. 

Look for the overallocations on = Min-
ute by Minute basis 

Проверять наличие дефицита ресурсов 
для каждой минуты выполнения про-
екта. 

 
Остальные параметры программы Microsoft Project не влияют на выпол-

нение заданий лабораторного практикума. 
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Предметный  ука з а т ель  

  
CPM: см. Метод критического пути 
  
PERT: см. Технология PERT 
  
VBA: см. Язык программирования VBA 
  
Автофильтр: 71 
Анализ (этап управления проектом): 9 
Арендная плата: 24 
Астрономическое время: 28, 32, 36, 44 
  
Базы данных: 24 
Беллман Р.: 10 
  
Ввод данных о работах: 28 
Ввод данных о ресурсах: 36 
  
График PERT: 27, 44, 56 
График Ганта: 26, 42, 44, 45, 52, 66, 114 
График загруженности ресурса: 69 
Группировка: 72 
  
Данные мониторинга: 50, 53, 108, 119, 121 
Диалоговое окно 

Assignment information: 47, 123 
Change Working Time: 39 
Column Definition: 59 
Custom AutoFilter: 133 
Customize Fields: 65 
Customize Group By: 72 
Define Group Interval: 73 
Detail Styles: 64 
Layout: 57 
Page Setup: 74, 134 
Recurring Task Information: 36 
Resource information: 36, 122 
Resource Leveling: 41 
Save Baseline: 48 
Sort: 71 
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Table Definition: 58 
Task Dependency: 30 
Task Information: 29, 30, 32, 44, 45, 57, 114 
Update Project: 51, 53 
Update Tasks: 52 

Динамическое программирование: 10 
  
Единицы измерения времени: 19, 28, 29 
Единицы измерения продолжительности работ: см. Единицы измерения времени 
  
Запас времени: 20, 109 
Затраты 
начисление: 20, 37, 108, 119 
не связанные с ресурсами: 37, 108 

  
Инвестиционная фаза проекта: см. Фаза реализации проекта 
Интранет: 83 
  
Календарь 
проекта: 19, 32, 39, 127 
работы: 116 
ресурсов: 19, 21, 32, 37, 43, 114, 119 

Календарь (форма представления данных): 27, 42, 45, 68, 114 
Конкатенация: 124 
Критерии управления проектом: 7 
Критический путь: 10, 23, 132 
  
Лаг: 34 
  
Мастера (wizards): 25 
Материалы: 6, 36, 118, 120, 131 
использование переменного количества: 32 
использование фиксированного количества: 32, 45, 47 
цена: 21 

Метод критического пути: 10 
Модель проекта: 18, 25, 92 
Модификатор вида связи: 34 
Мониторинг: 9, 15, 50, 98 
  
Назначение ресурсов на работы: 30 
Начисление затрат: см. Затраты: начисление 
Нормативы продолжительности работ: 22 
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Ограничения на сроки выполнения работ: 132 
Ограничения по ресурсам: 13 
Оперативное планирование: 50, 53 
Ответственность менеджера проекта: 8 
Отчёты: 74 
  
Перерывы работ: 42, 43 
План 
оперативный: 50, 54, 61 
согласованный: 48, 61, 95, 97 

Планирование: 9 
Плата за ресурсы: 21 
Подпроект: 78 
Позднее время начала (завершения) работы: 109 
Программа 1C–Предприятие: 17 
Программа Microsoft Project: 15 
Программа OpenPlan: 16 
Программа Project Expert: 17 
Программа Spider Project: 16 
Продолжительность работы: 29 
вариация: 23 
единица измерения: 19, 28, 29 
источники данных: 21 
резерв времени: 22 
экспертная оценка: 22 

Проект: 6 
генеральный: 78, 82 
инвестиционная фаза: см. Фаза реализации проекта 
фаза реализации: см. Фаза реализации проекта 

Проектный цикл: 9 
Процент завершённости: 51, 52, 107, 109 
  
Работы: 6, 10 
добавление в таблицу работ: 29 
иерархическое упорядочение: 35, 57, 72, 132 
критические: 11, 60, 113, 129, 131 
некритические: 11, 43, 129 
ограничения по срокам: 20, 43, 45, 53, 131 
параллельные: 6, 76 
периодические: 35 
предшествующие: 20, 30, 81, 107 
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приоритеты: 43, 132 
продолжительность: 20 
процент завершённости: 20, см. Процент завершённости 
сверхурочные: 41 
составные: 56, 60, 61, 66, 100, 129, 131, 132 
удаление из таблицы работ: 29 
фактическое начало (завершение): 51, 52 

Рабочее время: 19, 28, 32, 38 
Ранжирование данных в таблицах: 71 
Распределительная таблица: 18, 41, 46 
формы отображения: 62 

Резерв времени: 11, 41 
Ресурсный пул: 77, 82 
Ресурсоёмкость: 44, 100, 138 
Ресурсы: 6, 10, 20, 53, 107 
использование: 63 
нескладируемые: 6, 36, 45, 118, 119, 131 
оплата: 36 
переменный профиль платы: 36, 122 
складируемые: см. Материалы 

Российская ассоциация управления проектами: 17 
Рынок труда: 24 
  
Связи между работами: 23 
ввод: 30 
виды связей: 32 
удаление: 30 

Семейство программ Microsoft Office: 15 
Сетевой график: см. Сетевой план 
Сетевой план: 7, 11, 15, 26, 40 
отклонения: 50 

Системные часы ПЭВМ: 51 
Смета: 7 
События: 11, 56, 60, 129, 131, 132 
Согласование использования ресурсов: 13, 15, 40, 115 
нештатные ситуации: 42 

Сортировка: 71 
Составные работы: 115, 116 
Способы ввода данных: 25 
Стиль текста: 59, 61 
Столбцы, определяемые пользователем: 65, 71, 73, 124 
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Строка распределения ресурсов: 62, 123 
  
Таблица работ: 18, 20, 26, 51, 81 
отображение требуемого столбца: 37, 59 
системное имя столбца: 59 
фильтр: 45 
формы отображения: 57, 107, 118 

Таблица ресурсов: 18, 20, 27, 36 
отображение требуемого столбца: 61 
формы отображения: 61 

Тарифная сетка: 24 
Терминология управления проектами: 6 
Технологические карты: 22 
Технология PERT: 12 
Требования к квалификации менеджеров: 8 
  
Упорядочение данных в таблицах: 71 
Управление проектами: 6 
  
Фаза реализации проекта: 8, 9, 56 
Факторы управления проектом: 8 
Фиксация плана: 48 
Фильтр: 45, 71 
Финансовый план: 7 
Формы представления данных: 25 
  
Цель управления проектом: 7 
Цикл проекта: 9 
  
Чистая текущая стоимость: 7 
  
Штатное расписание: 24 
  
Экспертная оценка продолжительности работ: 22 
Эксплуатационные сметы: 24 
Этапы управления проектом: 9 
  
Язык программирования VBA: 16, 74 
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